Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-11-03, 01:43 PM   #1
Guardian Bob
Registered User
 
Join Date: Apr 2003
Posts: 6
Exclamation Nvidia drivers and X usage

I used the installer to install the new nvidia drivers on RH9 (kernel 2.4.20-9.)

Now, what's happening, is after leaving my box running for a while, especially raising and lowering window in the wm, at random points X usage will go to 99.9% (as reported by top, from an external machine, sshing in) and the system will be frozen. The only way to get at it, is to ssh in from another box and kill X. Now this did happen with the 4xxx versions of the nvidia driver in RH 8, but not the 3xxx version. So I strongly suspect it is the driver. Any suggestions?

--GB

[added]
BTW, I have an AMD Athalon machine, 512 ram, 1.3 ghz, and GeForce2 MX.

Last edited by Guardian Bob; 04-11-03 at 01:48 PM.
Guardian Bob is offline   Reply With Quote
Old 04-11-03, 03:15 PM   #2
wizdom
Registered User
 
Join Date: Jan 2003
Posts: 89
Default

This is probably unrelated, but I experience the same thing on a distroless machine (XF 4.3) when using:

Option "RenderAccel" "1"

In my XF86Config. NVIDIA mark this off by default and say it's experimental, but it used to work prior to the 4xxx series on this GF2Ti, now it's broken.

If you have RenderAccel set, try removing that line.

Cheers,
Alistair Strachan.
wizdom is offline   Reply With Quote
Old 04-11-03, 03:53 PM   #3
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

I've got RenderAccel set, with no problems at all. Of course, the longest I've ever run X was approx. 3 days, but I didn't see a problem then. Normal usage is boot it up around 7 or 8 AM, and shut it down around 10 or 11 PM, so anywhere from 14 to 16 hours a day, it's running.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 04-11-03, 04:14 PM   #4
Guardian Bob
Registered User
 
Join Date: Apr 2003
Posts: 6
Default

I have this in my XF86Config:
Code:
Section "Device"
        
        # no known options
        # Driver       "nvidia"    #using nv right now to keep from crashing
        Identifier  "NVIDIA GeForce 2 MX (generic)"
        Driver      "nv"
        VendorName  "NVIDIA GeForce 2 MX (generic)"
        BoardName   "NVIDIA GeForce 2 MX (generic)"
        Option      "CursorShadow" "on"
        Option      "HWCursor" "on"
        Option      "NoLogo" "on"
        Option      "NoRenderAccel" "off"
        Option      "NvAGP" "3"
EndSection
--GB

[Edited: added code tags]
Guardian Bob is offline   Reply With Quote
Old 04-11-03, 06:21 PM   #5
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

None of those Options will take effect, you're using the wrong Driver. Those are not options for the XFree86 "nv" driver, only for the nVidia-provided "nvidia" driver. Did you edit the config file like the README says to?
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 04-11-03, 08:18 PM   #6
Guardian Bob
Registered User
 
Join Date: Apr 2003
Posts: 6
Default

If you read the comment you would realize that I switched to the NV driver so that X won't crash. I realize that if I want the options to take affect, I need to load the nvidia driver.
Guardian Bob is offline   Reply With Quote
Old 04-11-03, 09:10 PM   #7
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Quote:
Originally posted by Guardian Bob
If you read the comment you would realize that I switched to the NV driver so that X won't crash.
Hmm, I don't see where you said that -- am I blind? Entirely possible... Could you quote it for me? Thanks...

If you do "NoRenderAccel" "on" (and obviously switch back to "nvidia"), does that work?
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 04-13-03, 05:27 PM   #8
Guardian Bob
Registered User
 
Join Date: Apr 2003
Posts: 6
Default

Yes, setting the norenderaccel to on seems to have fixed my problems.

--GB
Guardian Bob is offline   Reply With Quote

Old 04-15-03, 10:29 AM   #9
wizdom
Registered User
 
Join Date: Jan 2003
Posts: 89
Default

NVIDIA, if you're listening, this adds another person to those experiencing problems with RenderAccel on GF2 (or newer?) hardware.

I can confirm this bug was not present in the 3xxx series. The performance boost from having RenderAccel flagged is considerable, could you look into this?

Cheers,
Alistair Strachan.
wizdom is offline   Reply With Quote
Old 04-15-03, 06:06 PM   #10
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

Thanks for your reports - it would also be helpful to let linux-bugs@nvidia.com know.

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA Drivers Receive Windows 8 Certification News Archived News Items 0 06-01-12 05:30 AM
295.40 Drivers and Xorg 1:7.6+12 HIGH cpu usage norrland NVIDIA Linux 2 05-13-12 09:11 AM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM
nvidia drivers in a motherboard with AGP 1.0 (motherboard MVP3+) knocker NVIDIA Linux 1 08-19-02 01:57 AM
NVIDIA 2960 Drivers & RH 7.3 W/2.4.18-5 XASCompuGuy NVIDIA Linux 6 08-02-02 11:53 AM

All times are GMT -5. The time now is 06:03 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.