Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-12-03, 04:11 AM   #1
Eric
Registered User
 
Join Date: Apr 2003
Posts: 4
Default Stuttering Sound after installing Nvidia Drivers

Hi,

I sucessfully installed the new Nvidia Drivers on my Redhat 7.3 Box using the Shell Script provided on the webpage.

When booting up X usin Fluxbox as my Window Manager the sound begins to stutter if i am loading an application (Opera etc.) or compiling a program.

I am playing my MP3s usin XMMS 1.2.7 with the Artsd Sound Daemon.
I even tried mpg123, i think thats not the problem.

And yes, this just happens with the accelerated Server (both Arts and ESD)

I own the AC97 VIA Audio Mobo Sound Card (Already installed vendor drivers, and yes i know this card sucks :-\ )

Anyone able to help? This is kinda annoyin ....

/var/log/messages shows this:

Apr 14 00:33:54 localhost kernel: Linux agpgart interface v0.99 (c) Jeff Hartman n
Apr 14 00:33:54 localhost kernel: agpgart: Maximum main memory to use for agp me mory: 291M
Apr 14 00:33:54 localhost kernel: agpgart: Unsupported Via chipset (device id: 3 128), you might want to try agp_try_unsupported=1.
Apr 14 00:33:54 localhost insmod: /lib/modules/2.4.18-3/kernel/drivers/char/agp/ agpgart.o: init_module: No such device
Apr 14 00:33:54 localhost insmod: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters. You may find m ore information in syslog or the output from dmesg
Apr 14 00:33:54 localhost insmod: /lib/modules/2.4.18-3/kernel/drivers/char/agp/ agpgart.o: insmod agpgart failed
Apr 14 00:33:54 localhost kernel: 0: NVRM: AGPGART: unable to retrieve symbol ta ble


Greetings and thanks for your help

Eric
Eric is offline   Reply With Quote
Old 04-12-03, 08:40 AM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Which motherboard chipset are you using? The error messages in syslog are from agpgart not recognizing the chipset you have, which means that AGP support does not start up.

Now, this won't cause skips in your MP3's, that's likely caused by high CPU usage while playing them. That, in turn, is probably caused by a crappy sound card, or crappy drivers for it.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 04-12-03, 10:30 AM   #3
Eric
Registered User
 
Join Date: Apr 2003
Posts: 4
Default

An P4VXAS mainboard with VIA VT8753 Northbridge and VT8233 Southbridge Chipset using the AC 97 audio codec.

The Sound was working fine with the unaccelerated X Server
Eric is offline   Reply With Quote
Old 04-12-03, 03:34 PM   #4
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Which KT* chipset is that? KT400? If so, there is a thread about that chipset and the problems it causes. KT333? Which kernel version are you using?
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 04-13-03, 03:05 AM   #5
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

Are you using a PCI video card?

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 04-13-03, 05:24 AM   #6
Eric
Registered User
 
Join Date: Apr 2003
Posts: 4
Default

Well, i use an Tornado Geforce 2 MX 200 (AGP) by Inno3d and bwkaz there is nothing in my Mainboard Manual stating that it is an KT* Mainboard.

Last edited by Eric; 04-13-03 at 06:15 AM.
Eric is offline   Reply With Quote
Old 04-13-03, 07:57 AM   #7
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Oh, P4Vsomething. It's a P4 mainboard. Do you know which one? Perhaps upgrading the kernel would add support for your board to the agpgart driver. Otherwise, you could add an options agpgart agp_try_unsupported=1 to your modules.conf, run /sbin/depmod -a, and restart. That might at least let the driver load.

One other thing is, you'll probably want to lower your AGP aperture in the BIOS. It looks like it's (somehow) set at 291MB, which is way too high. You probably don't need more than 64MB, and if you've got enough video RAM on the card, you won't need any.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 04-16-03, 05:32 AM   #8
Eric
Registered User
 
Join Date: Apr 2003
Posts: 4
Default

Hrm i took a look at my bios conf and agp has been set to 64M .. i played around a bit with the Settings .. settin them to 32M and 16M and so on .. also changed 4x AGP to 2x and Enabled FastWrite .. hrm made no difference
Eric is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
monitor not recognised after installing nvidia drivers Horaciusl NVIDIA Linux 3 08-10-12 10:59 PM
NVIDIA Drivers Receive Windows 8 Certification News Archived News Items 0 06-01-12 05:30 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM
Nvidia Stereo Drivers Soudontsay NVIDIA Windows Graphics Drivers 2 08-26-02 10:48 AM

All times are GMT -5. The time now is 11:28 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.