Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-29-07, 04:05 PM   #1
gluhoff
Registered User
 
Join Date: Feb 2005
Location: Moscow, Russia
Posts: 10
Send a message via Skype™ to gluhoff
Default GLX couldn't get initialized on Debian

Hi,
I can't get NVIDIA driver working on my laptop after upgrade to Etch. Seems that X hangs during GLX initialization.
I experienced an installation error:
ERROR: The runtime configuration check failed for the library
'libnvidia-tls.so.100.14.11' (expected:
'/usr/lib/tls/libnvidia-tls.so.1', found:
'/usr/lib/libnvidia-tls.so.1'). The most likely reason for this is that
conflicting OpenGL libraries are installed in a location not inspected
by `nvidia-installer`. Please be sure you have uninstalled any
third-party OpenGL and/or third-party graphics driver packages.
Searching for the third-party OpenGL libraries, I found libgl1-mesa-glx and libglu1-mesa packages. Unfortunately, I couldn't remove them, because xserver-xorg depends on libgl1-mesa-glx.
Could you help me please?
Thanks,
Val.
gluhoff is offline   Reply With Quote
Old 09-29-07, 04:08 PM   #2
gluhoff
Registered User
 
Join Date: Feb 2005
Location: Moscow, Russia
Posts: 10
Send a message via Skype™ to gluhoff
Default Re: GLX couldn't get initialized on Debian

After choosing --force-tls=new the installation problem has gone.
But X still cannot go through GLX initialization
I'm uploading the log files.
Attached Files
File Type: gz nvidia-bug-report.log.gz (35.3 KB, 106 views)
File Type: gz nvidia-installer.log.gz (4.7 KB, 73 views)
gluhoff is offline   Reply With Quote
Old 10-18-07, 07:25 PM   #3
gluhoff
Registered User
 
Join Date: Feb 2005
Location: Moscow, Russia
Posts: 10
Send a message via Skype™ to gluhoff
Default Re: GLX couldn't get initialized on Debian

The problem has gone after I reinstalled Linux.

Thanks a lot,
Val.
gluhoff is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
173.14.34 -- Xorg 1.12.1 & 1.11.4, glx module fails to load mereset NVIDIA Linux 17 06-10-12 01:24 AM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 06:45 AM
Problems with a GeForce4 MX 440 under Debian Iainuki NVIDIA Linux 1 09-24-02 09:27 PM

All times are GMT -5. The time now is 04:50 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.