Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-23-07, 01:18 PM   #1
mooninite
Registered User
 
Join Date: May 2006
Posts: 477
Default 100.14.19 - Xv is corrupted after using MythTV

I seem to have found a bug.

Sometimes after using MythTV, my Xv port is corrupted and I have to restart X to get it back. This is rather inconvenient.

The attached bug report was taken right after I noticed Xv was broken. All programs that want Xv acceleration present me an area of rather random colors and lines. (tvtime, gxine, mplayer, and even MythTV)
Attached Files
File Type: bz2 nvidia-bug-report.log.tar.bz2 (21.4 KB, 128 views)
mooninite is offline   Reply With Quote
Old 09-29-07, 01:41 PM   #2
creese
Registered User
 
Join Date: Aug 2007
Posts: 3
Default Re: 100.14.19 - Xv is corrupted after using MythTV

I've seen the exact same issue. I was forced to disable xvmc.
creese is offline   Reply With Quote
Old 09-29-07, 03:48 PM   #3
dowop
Registered User
 
Join Date: Oct 2006
Posts: 5
Default Re: 100.14.19 - Xv is corrupted after using MythTV

I'm having the same problem. But I do not use XvMC. Just normal Xv.

I've had to restart X many times now.
dowop is offline   Reply With Quote
Old 09-30-07, 01:38 AM   #4
mooninite
Registered User
 
Join Date: May 2006
Posts: 477
Default Re: 100.14.19 - Xv is corrupted after using MythTV

Yes, I'm talking about Xv, not XvMC. I imagine XvMC becomes broken as well, but I only need Xv (my Core 2 can handle any video job).
mooninite is offline   Reply With Quote
Old 09-30-07, 05:55 AM   #5
Nias
Registered User
 
Join Date: Aug 2004
Posts: 24
Default Re: 100.14.19 - Xv is corrupted after using MythTV

same here with xv, but only mythtv shows a garbled screen, other video-xv-player (mplayer, xine, ...) are showing correct video.

Restart is not needed, change the resolution to another one (with xrandr) and back again and mythtv is working again.
Nias is offline   Reply With Quote
Old 09-30-07, 08:14 AM   #6
briohewi
Registered User
 
Join Date: Apr 2007
Posts: 8
Default Re: 100.14.19 - Xv is corrupted after using MythTV

Already logged under an existing thread?

http://www.nvnews.net/vbulletin/showthread.php?t=98852
briohewi is offline   Reply With Quote
Old 09-30-07, 11:34 PM   #7
mooninite
Registered User
 
Join Date: May 2006
Posts: 477
Default Re: 100.14.19 - Xv is corrupted after using MythTV

Quote:
Originally Posted by briohewi
Already logged under an existing thread?

http://www.nvnews.net/vbulletin/showthread.php?t=98852
Hm, they might be using MythTV to cause it, too.


I had to use MythTV again today, after the computer had been running for 3 days straight with Xv working wonderfully. After using MythTV, Xv was corrupted. Had to restart X.

Note: After using MythTV and starting up mplayer the entire screen blacks out and I get an Xid error:
Code:
NVRM: Xid (0001:00): 13, 0000 01019700 00004097 00001808 00000000 00800000
Just so everyone knows, this is bug 353274.
mooninite is offline   Reply With Quote
Old 10-01-07, 12:24 AM   #8
dowop
Registered User
 
Join Date: Oct 2006
Posts: 5
Default Re: 100.14.19 - Xv is corrupted after using MythTV

Quote:
Originally Posted by mooninite
Just so everyone knows, this is bug 353274.
Where is the bug tracker?
dowop is offline   Reply With Quote

Old 10-20-07, 11:46 AM   #9
dowop
Registered User
 
Join Date: Oct 2006
Posts: 5
Default Re: 100.14.19 - Xv is corrupted after using MythTV

After upgrading to 100.14.23, this problem is still occuring, with the following from dmesg:
Code:
NVRM: Xid (0004:00): 13, 0000 01019700 00004097 00001808 00000000 00800000
dowop is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Corrupted display - 302.17 - Dell Precision T3500 (G98 [Quadro NVS 295]) gbailey NVIDIA Linux 1 06-27-12 10:24 AM
Corrupted display - 302.11 - Dell Precision T3500 (G98 [Quadro NVS 295]) gbailey NVIDIA Linux 0 06-15-12 04:38 PM
Corrupted display - 295.59 - Dell Precision T3500 (G98 [Quadro NVS 295]) gbailey NVIDIA Linux 1 06-14-12 06:49 PM
Corrupted display - 295.53 - Dell Precision T3500 (G98 [Quadro NVS 295]) gbailey NVIDIA Linux 9 06-12-12 03:34 PM

All times are GMT -5. The time now is 02:31 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.