Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-22-07, 09:00 PM   #1
WesleyWex
Registered User
 
Join Date: Oct 2007
Posts: 3
Arrow 96.43.01: Ubuntu 7.10: Works perfectly until next boot

I've tried to install 71.86.01 and 96.43.01 versions, both end up with this (of course I uninstalled one before installing the other).

The installer goes normally. When it finishes I start GDM and the screen is displayed correctly (nvidia boot logo, bigger resolution). But as I restart the computer, X does not start, because the nvidia driver says:

Code:
Error: API mismatch: this NVIDIA driver component has version
96.43.01, but the NVIDIA kernel module's version does not match.
Please make sure that the kernel module and all NVIDIA driver
components have the same version.
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
(...)
The detailed error message is not included on Xorg.0.log, only the error end.

How can this happen? I install it, reboot and suddenly the version is different?

I have a GeForce4 MX 440 with AGP8X. The kernel version is 2.6.22-14.
Attached Files
File Type: log nvidia-bug-report.log (88.0 KB, 96 views)
WesleyWex is offline   Reply With Quote
Old 10-22-07, 11:26 PM   #2
Mam(O)n
Lamer
 
Join Date: Jun 2007
Posts: 8
Default Re: 96.43.01: Ubuntu 7.10: Works perfectly until next boot

It's probably problem with the proprietary driver manager on ubuntu.
__________________
Sorry for my bad english...
mount -o ro /dev/language/english /me
Мы люди не местные...
Mam(O)n is offline   Reply With Quote
Old 10-23-07, 03:51 AM   #3
Zaeggu
Registered User
 
Join Date: Oct 2007
Posts: 3
Default Re: 96.43.01: Ubuntu 7.10: Works perfectly until next boot

Use the Envy for Install this Driver 96.43.01, works perfect in Ubuntu Gutsy!

The newer Drivers 100.14.x include the new Beta Driver = Freeze!

Envy install 75 dependencys bevor install the Driver, please Nvidia show this, here is the place for search the problem!
Zaeggu is offline   Reply With Quote
Old 10-23-07, 06:48 AM   #4
WesleyWex
Registered User
 
Join Date: Oct 2007
Posts: 3
Talking Re: 96.43.01: Ubuntu 7.10: Works perfectly until next boot

I've tried lots of stuff later that day, and found that there is something about ubuntu rewriting the modules. Now, after many reinstalls of the 'nvidia-glx' package (and the 'nvidia-glx-new', 'nvidia-glx-legacy'), only the legacy work, even with the installer the kernel module is stuck at 1.0.7185.

When I get home I'll try envy and post the results.
WesleyWex is offline   Reply With Quote
Old 10-23-07, 03:25 PM   #5
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: 96.43.01: Ubuntu 7.10: Works perfectly until next boot

Please also see http://www.nvnews.net/vbulletin/showthread.php?t=72490.
zander is offline   Reply With Quote
Old 10-24-07, 07:58 AM   #6
Zaeggu
Registered User
 
Join Date: Oct 2007
Posts: 3
Default Re: 96.43.01: Ubuntu 7.10: Works perfectly until next boot

I have see your Installation Thread, and the 100.14.19 and the New Beta Driver Freeze by tests from my

Acer Aspire 9302WSMi Notebook
AMD Turion 64x2 Mobile Technology TL-50
GeForce Go 7300
2 Gb DDR2 Ram

in:

Ubuntu Gutsy 7.10
OpenSuse 10.3
Fedora 7
Mandriva One 2008

The Driver installation is not Problem for me, the Problem is your Driver!
Zaeggu is offline   Reply With Quote
Old 10-24-07, 05:32 PM   #7
WesleyWex
Registered User
 
Join Date: Oct 2007
Posts: 3
Thumbs up Re: 96.43.01: Ubuntu 7.10: Works perfectly until next boot

Thank you, the procedure you suggested worked perfectly.

This is what I did:

1 - Install again the nvidia-glx, nvidia-glx-new and nvidia-glx-legacy that I had installed before, and then purge them all.
2 - Purged the package linux-restricted-modules.
3 - Downloaded envy_0.9.8-0ubuntu8_all.deb from http://albertomilone.com/nvidia_scripts1.html
4 - Installed it (using dpkg -i envy_0.9.8-0ubuntu8_all.deb, some dependency problems, corrected by apt-get -f install)
5 - Reboot the computer

And it's done!

WesleyWex is offline   Reply With Quote
Old 10-26-07, 03:06 AM   #8
Zaeggu
Registered User
 
Join Date: Oct 2007
Posts: 3
Default Re: 96.43.01: Ubuntu 7.10: Works perfectly until next boot

For German Language Users, here the HowTo, for the 96.43.01 driver installation!

Sorry, the English language is for moment a grande problem for me, for i make this HowTo in English!
Zaeggu is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:36 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.