Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-03-06, 07:16 PM   #1
Demon Lord
Registered User
 
Join Date: Jul 2004
Posts: 8
Default Toshiba resolution EDID fix

I am the proud owner of a Toshiba Satellite 5100, with a nice 1600x1200 display and a GeForce 440 Go. After many years of EDID hacks and workarounds to have full resolution, I noticed the "CustomEDID" option so I decided to give it a try.

I successfully managed to get rid of custom modelines and timing/EDID options in my Xorg config file by using a custom EDID file. You'll need this Windows program (very simple, works fine with Wine) Phoenix EDID Designer (http://www.tucows.com/preview/329441).

Here's how:
1) Start X with level 6 verbosity:
# X -logverbose 6
2) Kill X
3) Look for raw EDID bytes in the log file:
Code:
(--) NVIDIA(0): Raw EDID bytes:
(--) NVIDIA(0):
(--) NVIDIA(0):   00 ff ff ff ff ff ff 00  3a c4 00 04 00 00 00 00
(--) NVIDIA(0):   2d 0c 01 03 80 20 18 00  ea a8 e0 99 57 4b 92 25
(--) NVIDIA(0):   1c 50 54 00 00 00 01 01  01 01 01 01 01 01 01 01
(--) NVIDIA(0):   01 01 01 01 01 01 48 3f  40 30 62 b0 32 40 4c c0
(--) NVIDIA(0):   13 00 42 f3 10 00 00 1e  00 00 00 fc 00 4e 76 69
(--) NVIDIA(0):   64 69 61 20 44 65 66 61  75 6c 00 00 00 fc 00 74
(--) NVIDIA(0):   20 46 6c 61 74 20 50 61  6e 65 6c 00 00 00 00 fd
(--) NVIDIA(0):   00 00 3c 1d 4c 11 00 00  20 20 20 20 20 00 00 9c
(--) NVIDIA(0):   00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
(--) NVIDIA(0):   00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
(--) NVIDIA(0):   00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
(--) NVIDIA(0):   00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
(--) NVIDIA(0):   00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
(--) NVIDIA(0):   00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
(--) NVIDIA(0):   00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
(--) NVIDIA(0):   00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00
Save the first 8 lines (the ones that aren't filled with zeroes) in the following format (spacing and capitals are important!), making sure you have Windows end-of-lines and a blank line in the end:
Code:
EDID BYTES:
0x   00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F
    ------------------------------------------------
00 | 00 FF FF FF FF FF FF 00 3A C4 00 04 00 00 00 00
10 | 2D 0C 01 03 80 20 18 00 EA A8 E0 99 57 4B 92 25
20 | 1C 50 54 00 00 00 01 01 01 01 01 01 01 01 01 01
30 | 01 01 01 01 01 01 48 3F 40 30 62 B0 32 40 4C C0
40 | 13 00 42 F3 10 00 00 1E 00 00 00 FC 00 4E 76 69
50 | 64 69 61 20 44 65 66 61 75 6C 00 00 00 FC 00 74
60 | 20 46 6C 61 74 20 50 61 6E 65 6C 00 00 00 00 FD
70 | 00 00 3C 1D 4C 11 00 00 20 20 20 20 20 00 00 9C
4) Open the EDID editor and load the data file you just made. If it fails to open, make sure your format is exactly the same as above.
5) Click on the pencil icon to make the file editable and open up the last tab (Detailed Timings). The first block option should contain your display configuration.
6) The display incorrectly reported a maximum resolution of 1588x1200 pixels, so I changed the H. Active Pxl value to 1600, and, since I added 12 more pixels, I removed them from H Blank, from 572 to 560.
7) Save the file, and strip back the headers to:
Code:
00 FF FF FF FF FF FF 00 3A C4 00 04 00 00 00 00
2D 0C 01 03 80 20 18 00 EA A8 E0 99 57 4B 92 25
1C 50 54 00 00 00 01 01 01 01 01 01 01 01 01 01
01 01 01 01 01 01 48 3F 40 30 62 B0 32 40 4C C0
13 00 42 F3 10 00 00 1E 00 00 00 FC 00 4E 76 69
64 69 61 20 44 65 66 61 75 6C 00 00 00 FC 00 74
20 46 6C 61 74 20 50 61 6E 65 6C 00 00 00 00 FD
00 00 3C 1D 4C 11 00 00 20 20 20 20 20 00 00 9C
8) Compile the following and run your data file through it:
Code:
#include <stdio.h>

int main()
{
  while (!feof(stdin))
  {
    unsigned char i;
    scanf("%02X ", &i);
    printf("%c", i);
  }
  return 0;
}
Code:
# gcc comp.c -o comp
# ./comp < custom_edid.dat > custom_edid.bin
This should get you a 128 bytes file
9) Move this file somewhere safe and add this option to the Device section of your config file:
Code:
Option "CustomEDID" "DFP-0:/path/to/file/custom_edid.bin"
10) Remove any custom EDID configuration you might have added in the past, and X should now work...
Attached Files
File Type: bz2 custom_edid.tar.bz2 (2.8 KB, 959 views)
Demon Lord is offline   Reply With Quote
Old 12-03-06, 10:56 PM   #2
macemoneta
Registered User
 
macemoneta's Avatar
 
Join Date: Oct 2002
Location: NJ
Posts: 159
Default Re: Toshiba resolution EDID fix

Are you able to get the 9629 driver working? It just generates a kernel Oops on my 5105 (US version of the 5100) when X starts.
macemoneta is offline   Reply With Quote
Old 12-04-06, 10:09 AM   #3
Demon Lord
Registered User
 
Join Date: Jul 2004
Posts: 8
Default Re: Toshiba resolution EDID fix

Yes, I'm on 9629 right now (compiled from source, SourceMage Linux).
Demon Lord is offline   Reply With Quote
Old 12-04-06, 10:59 AM   #4
macemoneta
Registered User
 
macemoneta's Avatar
 
Join Date: Oct 2002
Location: NJ
Posts: 159
Default Re: Toshiba resolution EDID fix

One of the interesting variation Toshiba produced no doubt. I have two 5105-s607, same BIOS levels, same video BIOS, same GeForce 440 Go, same FC6 software and software levels, same Nvidia driver. Yet the two are subtly different in their video handling.

Unfortunately, both also cause any driver in the 9xxx series to cause a kernel Oops as soon as X is started (no errors in the Xorg log).

Out of curiosity what does your '/proc/driver/nvidia/cards/0' file show:

$ cat /proc/driver/nvidia/cards/0
Model: GeForce4 440 Go
IRQ: 5
Video BIOS: 04.17.00.26.a6
Card Type: AGP
DMA Size: 32 bits
DMA Mask: 0xffffffff
macemoneta is offline   Reply With Quote
Old 12-04-06, 12:17 PM   #5
macemoneta
Registered User
 
macemoneta's Avatar
 
Join Date: Oct 2002
Location: NJ
Posts: 159
Default Re: Toshiba resolution EDID fix

Nevermnd; the new 9631 driver has corrected the problem.
macemoneta is offline   Reply With Quote
Old 12-05-06, 09:56 AM   #6
Demon Lord
Registered User
 
Join Date: Jul 2004
Posts: 8
Default Re: Toshiba resolution EDID fix

Code:
Model:           GeForce4 440 Go
IRQ:             5
Video BIOS:      04.17.00.41.c5
Card Type:       AGP
DMA Size:        32 bits
DMA Mask:        0xffffffff
By the way, is there a way to use an equivalent CustomEDID option in the Windows driver? I'd like to have my full resolution for the first time since the 60.00 era...
Demon Lord is offline   Reply With Quote
Old 12-05-06, 10:38 AM   #7
Falkon
Registered User
 
Join Date: Nov 2006
Posts: 26
Default Re: Toshiba resolution EDID fix

Windows can't even handle my Toshiba HDTV with DVI->HDMI. I never even get a display.
Falkon is offline   Reply With Quote
Old 12-26-06, 07:28 PM   #8
Nuke-Refugee
Registered User
 
Join Date: Apr 2005
Posts: 10
Default Re: Toshiba resolution EDID fix

One big THANK YOU to you!!
It's been MONTHS since my 3D stopped working after an update on my laptop and I had to use the nv driver... Now the problem is solved! I'm going to save that custom edid file & bookmark this thread for futures reference.

Thanks a lot!

Seb.
Nuke-Refugee is offline   Reply With Quote

Old 01-15-07, 01:18 PM   #9
uranusi
Registered User
 
Join Date: Jan 2007
Posts: 1
Default Re: Toshiba resolution EDID fix

I am using a 5105-s501.
I have worked on this problem for many years too.
Thanks god , you saved my life!

Here is my fixed edid file for 5105-s501, you can copy or type the code below to a bin file with a HEX editor.
Becarful, the size of the file have to be 128 byts.

Code:
00 FF FF FF FF FF FF 00 3A C4 00 03 00 00 00 00
2D 0C 01 03 80 20 19 00 EA A8 E0 99 57 4B 92 25
1C 50 54 00 00 00 01 01 01 01 01 01 01 01 01 01
01 01 01 01 01 01 30 2A 78 3C 51 1A 10 40 4C 70
13 00 42 F6 10 00 00 18 00 00 00 FC 00 4E 76 69
64 69 61 20 44 65 66 61 75 6C 00 00 00 FC 00 74
20 46 6C 61 74 20 50 61 6E 65 6C 00 00 00 00 FD
00 00 3C 1D 41 0B 00 00 20 20 20 20 20 00 00 B2
Attached Files
File Type: gz 5105-s501edid.tar.gz (269 Bytes, 376 views)

Last edited by uranusi; 01-16-07 at 02:09 AM.
uranusi is offline   Reply With Quote
Old 01-16-07, 08:08 AM   #10
HeSaid
Registered User
 
HeSaid's Avatar
 
Join Date: Aug 2004
Posts: 2
Default Re: Toshiba resolution EDID fix

Thank you, uranusi.
Your custom edid worked great for me!!
HeSaid is offline   Reply With Quote
Old 02-08-07, 01:58 AM   #11
tinetof
Registered User
 
Join Date: Aug 2006
Posts: 1
Default Re: Toshiba resolution EDID fix

Thanks for your thread.

My GeForce 6200 was not able to work in full HD (1080i) on the Toshiba 42WLG66 TV.

Finally, this is due to an incorrect EDID data (vertical refresh). What I had to do was very simple (it was not necessary to edit EDID data):
in the Monitor section of xorg.conf, the three lines are necessary to add:
HorizSync 15.0 - 46.0
VertRefresh 49.0 - 122.0
Option "UseEdidFreqs" "false"

And now this works, I post this reply if anyone has the same issue again.
tinetof is offline   Reply With Quote
Old 02-16-07, 04:17 AM   #12
mmejia
Registered User
 
Join Date: Dec 2006
Posts: 1
Default Re: Toshiba resolution EDID fix

OMG!! thank you so much!!
I have Ubuntu feisty in a toshiba satellite 2410 with geforce4 420 go, your solution works great with 1.0.9631. Here is my custom edid that i made I hope it to be usefull for someone.
Attached Files
File Type: gz custom_edid.tar.gz (272 Bytes, 463 views)
mmejia is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Opinions on 1280x1024 resolution skipparoo NVIDIA GeForce 7, 8, And 9 Series 103 06-22-12 11:38 PM
HDMI overscan fix for multiple resolutions + Zod Engine Problem. cheechr1 NVIDIA Linux 0 06-11-12 02:27 PM
Toshiba debuts widescreen Ultrabook News Archived News Items 0 06-05-12 01:20 PM
30.82 and 40.41 resolution + monitor OSD. Max3D NVIDIA Windows Graphics Drivers 2 09-05-02 02:15 AM
QIII engines & Dets 40.41 "darkness" fix... sisi NVIDIA Windows Graphics Drivers 6 09-03-02 04:55 AM

All times are GMT -5. The time now is 06:31 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.