Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-26-07, 02:35 PM   #1
mfeif
Registered User
 
Join Date: Oct 2005
Posts: 1
Default problem with gdm switching 100.14.19

Hello.

I'm using a fresh install of Ubuntu/Gutsy/x86_64. I've got an 8600GTS and an Intel Core-duo cpu. I'm using the Ubuntu-packaged nvidia driver (not 'nv'... 'nvidia' version) of full version "100.14.19+2.6.22.4-14.9". My kernel is 2.6.22-14-generic stock. My system is up-to-date as of today.

Everything is basically working ok, including "Desktop Effects".

I do have a problem when switching users, either via the "fast-user-switching" applet or via a Applications > System Tools > New Login. When I do that, GDM comes up, I can login as another user, the desktop comes up, so far so good...

But when I try to log that user (the second user) out or switch back to the first, I get a hung X server. SOMETIMES I can do CTRL-ALT-minus to change resolutions, but oddly enough I can't kill the server with CTRL-ALT-backspace. The screen looks mostly black, with a corner filled with the old root window color, and the mouse pointer is visible and active (I can move it). Once, I saw a fragment of a window in the non-black portion, and noticed that it moved when I moved the mouse pointer... in the same way as it does when you have a bigger desktop than your viewport and you hit the edge of your viewport with the mouse.

Though I can't kill the Xserver or move to another tty, I CAN log in via ssh and stop/restart gdm. No errors appear in the Xorg or gdm logs. I've attached the nvidia-bug-report.log but I can't start X in the special mode you requested, as X is starting from gdm, not "startx".

I see some others in various Ubuntu forums are having similar problems. One user suggested that turning off "desktop" effects helped; I have not yet been able to verify or contradict this.

Thanks!
Attached Files
File Type: bz2 nvidia-bug-report.log.bz2 (23.4 KB, 73 views)
mfeif is offline   Reply With Quote
Old 10-30-07, 01:54 AM   #2
FuturePilot
Registered User
 
Join Date: Aug 2007
Posts: 35
Default Re: problem with gdm switching 100.14.19

Sounds like this
https://bugs.launchpad.net/ubuntu/+s...er/+bug/112518
FuturePilot is offline   Reply With Quote
Old 03-20-08, 09:17 AM   #3
OkropNick
Registered User
 
Join Date: Mar 2008
Posts: 1
Default Re: problem with gdm switching 100.14.19

Hi all,

It's my first post.

I have similar problem with one exception. I don't have system crash, only white screen. I can switch to tty or even login.

Here is my hardware:

CPU: Intel Pentium D dual core (2x 3GHz)
GPU: GeForce 8600GT (driver v.169.12)
OS: Ubuntu 7.10 Gutsy Gibon

Here is described how to reproduce bug:

1. Log in as desktop user A
2. Switch to desktop user B
3. Log off user B

Now I have only white screen (looks like unrefreshed)

I can still back to user A session by blindly typing user's A password, I can also switch to any tty, but there is no way so far to login other desktop user than user A, because I can't see anything on screen - whole screen is completly white. Only thing to do is to restart x server.

I'm using compiz-fuzion and it seems to be Nvidia driver error, because I didn't have this problem with ATI graphic card.

I saw that many users has the same problem.

Any hints?

I can provide any informations. The nvidia log is also attached.

Thank you
Attached Files
File Type: zip nvidia-bug-report.log.zip (32.1 KB, 70 views)
OkropNick is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Post working out problem with 40.xx trying to work problem out, ONLY system specs b5fan NVIDIA Windows Graphics Drivers 11 10-19-02 10:17 AM
nv30 problem rumor bob747b Rumor Mill 37 10-10-02 04:14 PM
funny problem with 2960 and GF4 konsti NVIDIA Linux 3 09-03-02 08:08 AM
Geforce 4 Go and X-Server Problem with shutdown rapljenovic NVIDIA Linux 2 08-30-02 11:11 AM
Nvidia Go on laptop, black border within XFree86 problem raxip NVIDIA Linux 3 07-31-02 11:58 AM

All times are GMT -5. The time now is 01:52 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.