Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-27-07, 11:43 PM   #1
bugchong
Registered User
 
Join Date: Oct 2007
Posts: 4
Default Ubuntu Gutsy amd64 with 8500GT = black screen

After installing the nvidia driver 100.14.19, when X starts up the LCD monitor goes into standby mode and the machine is dead (ctrl-alt-del works sometimes). I've tried using the nvidia installer, the Restricted Driver Manager, and envy, all with the same results. Running under vesa at 640x480 works.

I've looked at http://www.nvnews.net/vbulletin/showthread.php?t=99456 and http://www.nvnews.net/vbulletin/showthread.php?t=99693, but I don't have the same issue with older drivers being loaded or the "PCI: Failed to allocate mem resource" problem.

Any ideas?

Thanks,
Gad

Other info:
OS: Ubuntu Gutsy amd64, kernel 2.6.22-14-generic
Video: ASUS EN8500GT
Mobo: ASUS M2N-E SLI (nForce 500 chipset)
CPU: AMD 64 5200+
Attached Files
File Type: log nvidia-bug-report.log (142.9 KB, 148 views)
bugchong is offline   Reply With Quote
Old 10-28-07, 12:03 AM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Ubuntu Gutsy amd64 with 8500GT = black screen

In your X log I see:
(II) NVIDIA(GPU-0): No display devices connected; falling back to: CRT-0
(WW) NVIDIA(GPU-0): Unable to read EDID for display device CRT-0

However, I don't see anything to suggest that the system hung. How did you make this determination?
netllama is offline   Reply With Quote
Old 10-28-07, 12:24 AM   #3
bugchong
Registered User
 
Join Date: Oct 2007
Posts: 4
Default Re: Ubuntu Gutsy amd64 with 8500GT = black screen

I don't know if it's crashed or not, because the monitor is in standby (no signal). The num lock works, alt-sysrq works, and ctrl-alt-del works sometimes. Otherwise, I can't do anything like go to the console with ctrl-alt-f1.
bugchong is offline   Reply With Quote
Old 10-28-07, 12:43 AM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Ubuntu Gutsy amd64 with 8500GT = black screen

The monitor is in standby because its not getting detected. You should verify that you're cabling isn't at fault.
netllama is offline   Reply With Quote
Old 10-28-07, 12:57 AM   #5
bugchong
Registered User
 
Join Date: Oct 2007
Posts: 4
Default Re: Ubuntu Gutsy amd64 with 8500GT = black screen

Thanks for replying.

The same monitor+cables (dvi) work fine under the vesa driver.
bugchong is offline   Reply With Quote
Old 10-28-07, 01:02 AM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Ubuntu Gutsy amd64 with 8500GT = black screen

The vesa driver doesn't probe for an EDID, or anything else. It just fires off a generic mode, and hopes for the best. In other words, just because vesa works doesn't mean that you don't have faulty hardware.
netllama is offline   Reply With Quote
Old 10-28-07, 02:08 AM   #7
bugchong
Registered User
 
Join Date: Oct 2007
Posts: 4
Default Re: Ubuntu Gutsy amd64 with 8500GT = black screen

That was it!

Using the DVI cable, the monitor was not being identified (came up as "Generic Monitor" when configuring X). I changed the cable from DVI to VGA, and the monitor is correctly identified and thus the NVIDIA driver runs correctly.

Thanks netllama!

Cheers,
Gad
bugchong is offline   Reply With Quote
Old 11-11-07, 03:45 PM   #8
Hakura
Registered User
 
Join Date: Nov 2007
Posts: 3
Default Re: Ubuntu Gutsy amd64 with 8500GT = black screen

Well here my driver isn't detected, it shows some stuff when I turn on the computer, kind of retries 3 times and then the Low Graphics settings are activated... I set up "NVIDIA -> GeForce 8 Series" but it still loads as Low Graphics and I can't use apps like Google Earth.

When I type #glxinfo | grep rendering
to check if the GLX is working, it says it's missing...

My xorg.conf looks fine...
Restrict hardware is enable and bla bla bla

Any idea of what's happening?

I'm new to ubuntu/linux but my friend helped me, we tried everything and it still didn't work... If anyone could help..
Hakura is offline   Reply With Quote

Old 11-11-07, 04:30 PM   #9
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Ubuntu Gutsy amd64 with 8500GT = black screen

See the forum sticky posts.
netllama is offline   Reply With Quote
Old 11-13-07, 02:44 AM   #10
tuxie_
Registered User
 
tuxie_'s Avatar
 
Join Date: Nov 2007
Posts: 1
Unhappy Re: Ubuntu Gutsy amd64 with 8500GT = black screen

Hello, These are my system's specs:

AMD 64 X2 6000+
mother board Gigabyte GA-M57SLI-S4
graphics card PCI-E Gigabyte Nvidia geforce 8500GT 512 Mb

I installed the comfusion distro, which has ubuntu+compiz+fusion already installed. I tried to install the nvidia driver using envy (in this case, the aplication didn't find the driver), automatix and downloading the driver directly from the nvidia web page. After installing the driver (with automatix or by following the instructions from nvidia's site), I restart the system, but there's an error and I have to restore the old configuration(running dpkg -reconfigure -phigh xserver-xorg) in order to continue. I attached the log. Hope you can help me. Thanks!
Attached Files
File Type: log nvidia-bug-report.log (122.3 KB, 159 views)
tuxie_ is offline   Reply With Quote
Old 11-13-07, 11:06 AM   #11
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Ubuntu Gutsy amd64 with 8500GT = black screen

You have the 1.0-9755 nvidia kernel module loaded with the 100.14.19 X driver. This is an Ubuntu bug, and is documented in the forum sticky posts.
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
GT240M - black screen with newer drivers > 275.33 and win 7 doktor5000 NVIDIA GeForce 200 Series 1 07-08-12 12:17 PM
[9800gt] Xorg black screen after installing nvidia driver HacKurx NVIDIA Linux 1 06-07-12 02:29 PM
Black screen after switching between graphical virtual consoles five times rrr-wtf NVIDIA Linux 1 05-21-12 05:40 PM
Black screen and lockup on startx. redmoose NVIDIA Linux 4 09-18-02 12:53 PM
kernel 2.4.19 and 2960 -> black screen osterhase NVIDIA Linux 7 08-22-02 07:24 PM

All times are GMT -5. The time now is 10:26 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.