Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-14-03, 08:35 PM   #1
Nu2Linux
Registered User
 
Join Date: Apr 2003
Posts: 1
Send a message via AIM to Nu2Linux
Default Installing video drivers in Slackware 9.0

I'm fairly new to Linux and brand new to Slackware. I tried to install the latest nVidia video card drivers under Slackware 9.0 and the installer gave me an error message stating that no precompiled kernel interface was found. it tried to connect to the nvidia FTP to download one and it couldn't find one. Could you please tell me what I can do to fix this?

Computer Spects:
GeForce4 MX440
Slackware 9.0
Video Bios Revision: 4.17.00.45.00
AthlonXP 2100+ (O/C to 2.173 ghz if that matters)
MSI KT4 Ultra-SR

Any help you could give would be greatly appericated. Thank You!
Attached Files
File Type: log xfree86.0.log (51.8 KB, 131 views)
Nu2Linux is offline   Reply With Quote
Old 04-14-03, 09:16 PM   #2
sKuNk-xXx-
Registered User
 
Join Date: Dec 2002
Location: whitehorse
Posts: 6
Default

You need to get your kernel source code:
it should be in /usr/src/linux/ if you don't have it, you need to download them from the website.
then when you run your nv installer
add the line:
-kernel-include-dir=/usr/src/linux/
and it should do the trick.
sKuNk-xXx- is offline   Reply With Quote
Old 04-15-03, 02:23 AM   #3
CSlayeR
Registered User
 
Join Date: Mar 2003
Location: Romania
Posts: 26
Send a message via Yahoo to CSlayeR
Default

Bahamot !!
I think nvidia will forgot about real speakers and all other fancy stuff available under linux. Will see.
CSlayeR is offline   Reply With Quote
Old 04-16-03, 03:58 AM   #4
douglass
Registered User
 
Join Date: Apr 2003
Location: SouthEast
Posts: 13
Default

Slackware only comes with uncompiled kernel sources. What you should do is this
cp /boot/config /usr/src/linux/.config (note the dot)
cd /usr/src/linux
make oldconfig dep bzImage modules

Go get a snack.

Install your nVidia kernel driver again.
-Chris

If you don't happen to have /boot/config or /boot/config-(installed-kernel) , then you can get a generic one off the Slackware CD at <mount_point>/kernels/bare.i/config.
douglass is offline   Reply With Quote
Old 04-16-03, 02:33 PM   #5
jerome69
Registered User
 
Join Date: Apr 2003
Posts: 2
Default

i followed your directions and when i "make oldconfig dep bzImage modules" i get "make: *** No rule to make target `oldconfig'. Stop."

i am using slack9.
jerome69 is offline   Reply With Quote
Old 04-16-03, 04:01 PM   #6
douglass
Registered User
 
Join Date: Apr 2003
Location: SouthEast
Posts: 13
Default

Verify that you are in the directory /usr/src/linux
and that this directory is a symlink to /usr/src/linux-2.4.20 (this is the default if you installed the kernel-sources package).
It should look something like this:
lrwxrwxrwx 1 root root 12 Mar 31 10:38 linux -> linux-2.4.20
drwxr-xr-x 14 root root 4096 Mar 31 14:37 linux-2.4.20

(should not be in red. Red means broken link)

Make oldconfig is not a Slackware specific command, it's a make target in the kernel. If you are in the correct directory you should be able to issue this command:

grep oldconfig Makefile

and get this result:

oldconfig: symlinks

You should be root when you do this.
This definitely works (in fact, copying your .config file from the old kernel to the new and using make oldconfig is the best way to upgrade, because you only have to answer questions on changed options).

There is another option for Slackware. The kernel headers package has the files needed, but they are in a place nVidia does not look. Sooo....

1) You can also try to do this:
export CFLAGS="-I/usr/include/linux" <enter>
and the build the nVidia driver.

OR

2) Remove the symlink 'linux' (rm /usr/src/linux)

mkdir -p /usr/src/linux/include

ln -s /usr/include/linux /usr/src/linux/include

and try that. I'm not sure if that will work, because I don't know for sure that the nVidia module does not need anything from the asm includes in the kernel tree.

I would strongly recommend that you get the kernel rebuilt.

-Chris

1) ABIT NF7-S
Corsair PC2700-XMS CAS2 (2x512)
Radeon 9700Pro
Barton XP2500
Slackware 9

2) ABIT NV-133r
Corsair PC2700-XMS CAS2 (2x512)
Gainward GeForce3 Ti200 Golden Sample
Athlon XP2000+
Slackware 8.1
douglass is offline   Reply With Quote
Old 04-16-03, 04:04 PM   #7
sKuNk-xXx-
Registered User
 
Join Date: Dec 2002
Location: whitehorse
Posts: 6
Default

With slack 9 the kernel headers and sources are not installed by default, and are not on the cd (iso from web). They are on the website in the k package sources. The headers are not enough I have tried this. GET the kernel source form the website! You will need it to compile a new kernel which you should do anyways.
sKuNk-xXx- is offline   Reply With Quote
Old 04-16-03, 04:09 PM   #8
douglass
Registered User
 
Join Date: Apr 2003
Location: SouthEast
Posts: 13
Default

That would explain it! I pulled the whole tree and made my own ISO, and I always do full installs.
You can check what packages you have installed by looking at /var/log/packages/*

Good Luck.
-Chris
douglass is offline   Reply With Quote

Old 04-16-03, 04:40 PM   #9
sKuNk-xXx-
Registered User
 
Join Date: Dec 2002
Location: whitehorse
Posts: 6
Default

Douglas
This is a little off the nv topic, any tips you could give to get my sound working? I have a kt400 via 8235 south bridge. I have tried the via drivers (which they only have for suse, mandrake, redhat) and alsa with no luck. Any tips would be appreciated
Thanks!
sKuNk-xXx- is offline   Reply With Quote
Old 04-17-03, 04:21 AM   #10
douglass
Registered User
 
Join Date: Apr 2003
Location: SouthEast
Posts: 13
Default

I'll do what I can; but I have never worked with that particular chipset before.

It looks like kernel 2.4.21-pre7 addresses your issue:

via82cxxx_audio.c:

* Support for VIA 82Cxxx Audio Codecs
* Copyright 1999,2000 Jeff Garzik
*
+ * Updated to support the VIA 8233/8235 audio subsystem
+ * Alan Cox <alan@redhat.com> (C) Copyright 2002 Red Hat Inc
+ *
* Distributed under the GNU GENERAL PUBLIC LICENSE (GPL) Version 2.
* See the "COPYING" file distributed with this software for more info.
+ * NO WARRANTY
*
* For a list of known bugs (errata) and documentation,
* see via-audio.pdf in linux/Documentation/DocBook.
* If this documentation does not exist, run "make pdfdocs".

So...

Download patch: ftp://ftp.us.kernel.org/pub/linux/ke...2.4.21-pre7.gz

(as root) move the file to /usr/src/, and then go to that directory.

Make a backup of your curent kernel tree:
mkdir /usr/src/2.4.20-backup
cd /usr/src/linux-2.4.20
tar cf - * | (cd ../2.4.20-backup ; tar xvf - )

Apply Patch:

cd /usr/src

zcat patch-2.4.21-pre7.gz | patch -p0

(if this starts asking "What file do you want to patch" type questions, you may want to go into the linux-2.4.20 directory and run patch with -p1)

Fix directories:

cd /usr/src
mv linux-2.4.20 linux-2.4.21-pre7
mv 2.4.20-backup linux-2.4.20
rm linux
ln -s linux-2.4.21-pre7 linux

Build:

cd linux
cp ../linux-2.4.20/.config .
make oldconfig

(Appropriately decide on any new options that are available to you).

make dep bzImage modules modules_install

Install the kernel:

cp System.map /boot/System.map-2.4.21-pre7
cp arch/i386/boot/bzImage /boot/linux-2.4.21-pre7

pico /etc/lilo.conf

Go down to the "linux bootable" section, use CTRL-K to cut the stanza used to boot your machine (first line should start with "image", last line should say "read-only", might have an "append" in there too, I guess.)

Use CTRL-U twice to place the block back and make another copy. Change the image line to read /boot/linux-2.4.21-pre7
Change the label line to read something like "Linux-2.4.21-pre7"

Exit lilo.conf (CTRL-X). Run lilo -v and make sure everything looks good.
Reboot. Hopefully, listen to something.
You need to edit /etc/rc.d/rc.modules and uncomment the appropriate lines (when I don't know which module depends to use, I add a -a to the modprobe statement on what I want. So you could put /sbin/modprobe -a via82xxx).

BTW- I don't know if you compile your own stuff (you ARE running Slackware ), but you need to get a current version of gnome-common under slack9 and compile it or you can't make gnome apps correctly (there is no gnome-autogen.sh in the stock distro).

Good Luck, post some errors if it doesn't work.
-Chris
douglass is offline   Reply With Quote
Old 04-17-03, 04:49 AM   #11
douglass
Registered User
 
Join Date: Apr 2003
Location: SouthEast
Posts: 13
Default

BTW, it looks like 2.4.21-pre7-ac1 makes an attempt at AGP for KT400, you might want to try it. That would leave only us nForce2 guys with no AGP. Yea.
-Chris
douglass is offline   Reply With Quote
Old 04-17-03, 11:00 AM   #12
jerome69
Registered User
 
Join Date: Apr 2003
Posts: 2
Default

thanks douglass. i tried:

1) You can also try to do this:
export CFLAGS="-I/usr/include/linux" <enter>
and the build the nVidia driver.

OR

2) Remove the symlink 'linux' (rm /usr/src/linux)

mkdir -p /usr/src/linux/include

ln -s /usr/include/linux

i did both and then pointed the driver installer to /usr/src/linux/include and it worked.
jerome69 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake 9.0 and drivers KramitDfrog NVIDIA Linux 2 10-06-02 05:14 PM
Nvidia drivers won't compile with Slackware 8.0 z28Power NVIDIA Linux 6 09-18-02 06:20 PM
nvidia drivers and slackware 9.0 pbrennen NVIDIA Linux 5 09-16-02 06:57 AM
Installing nForce drivers on Debian 3.0 Doink NVIDIA Linux 4 09-14-02 08:34 PM
Closing Xwindows, RH73, for installing nV drivers redigjohn NVIDIA Linux 1 09-06-02 11:26 AM

All times are GMT -5. The time now is 03:47 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.