Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-04-07, 09:20 AM   #1
iwanevans
Registered User
 
Join Date: Nov 2007
Posts: 1
Default Incorrect refresh rate with flat panel scaling

I'm driving my Samsung M8640 1080p LCD panel with a GF6200 over a DVI->HDMI cable. By default, the picture outputs at the correct resolution, but overscans so that I miss about 50 pixels on each side of the display.

I can correct this by going to nvidia-settings and ticking "Force Full GPU Scaling" and setting "GPU Scaling Method" to "Stretched" (I can alos achieve the same thing by adding the following to Xorg.conf: Option "FlatPanelProperties" "Scaling = Scaled")

So, my problem. I want the refresh rate to be at 50Hz. When I start X, this is the refresh rate reported by the TV, so I think I've configured it correctly. BUT, when I open nvidia-settings to tick the box to get rid of the overscan, the refresh rate changes to 60Hz for some reason.

Does anybody know why this happens, and more importantly, is there any way of stopping it from happening and leaving the refresh rate at 50Hz?

BTW, you might wonder why this bothers me... I live in the UK so the TV here is at 25fps - I figure at 60Hz refresh rate there is some pull-down going to occur, and there is definitely something a tiny bit strange about the motion when I watch recordings in MythTV.


Thanks for any bright ideas you might have!
iwanevans is offline   Reply With Quote
Old 02-25-08, 11:33 AM   #2
timbba
Guest
 
Posts: n/a
Default Re: Incorrect refresh rate with flat panel scaling

Quote:
Originally Posted by iwanevans
I'm driving my Samsung M8640 1080p LCD panel with a GF6200 over a DVI->HDMI cable. By default, the picture outputs at the correct resolution, but overscans so that I miss about 50 pixels on each side of the display.

I can correct this by going to nvidia-settings and ticking "Force Full GPU Scaling" and setting "GPU Scaling Method" to "Stretched" (I can alos achieve the same thing by adding the following to Xorg.conf: Option "FlatPanelProperties" "Scaling = Scaled")

So, my problem. I want the refresh rate to be at 50Hz. When I start X, this is the refresh rate reported by the TV, so I think I've configured it correctly. BUT, when I open nvidia-settings to tick the box to get rid of the overscan, the refresh rate changes to 60Hz for some reason.

Does anybody know why this happens, and more importantly, is there any way of stopping it from happening and leaving the refresh rate at 50Hz?

BTW, you might wonder why this bothers me... I live in the UK so the TV here is at 25fps - I figure at 60Hz refresh rate there is some pull-down going to occur, and there is definitely something a tiny bit strange about the motion when I watch recordings in MythTV.


Thanks for any bright ideas you might have!
Bye the way, I have faced exactly the same problem. Anyone have a solution? I use 100.14.19 drivers.
  Reply With Quote
Old 03-03-08, 03:00 AM   #3
timbba
Guest
 
Posts: n/a
Default Re: Incorrect refresh rate with flat panel scaling

So nobody knows? So GPU scaling is always 60hz? Or does it use edid information? I have 1024x768@60 as native and the edid gives same as preferred. Is there any way how to get GPU scaling work in 50hz mode?
  Reply With Quote
Old 03-03-08, 11:16 AM   #4
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Incorrect refresh rate with flat panel scaling

GPU scaling will always scale to the preferred mode listed in the EDID.
AaronP is offline   Reply With Quote
Old 03-04-08, 02:56 AM   #5
timbba
Guest
 
Posts: n/a
Default Re: Incorrect refresh rate with flat panel scaling

Quote:
Originally Posted by AaronP
GPU scaling will always scale to the preferred mode listed in the EDID.
Thanks for clarification. At least now I know that GPU scaling won't work to fix my problem.
  Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem connecting Pioneer VSX-S300 to Nvidia Ion - flat panel scaling solves it? wild_oscar NVIDIA Linux 3 06-17-12 07:18 AM
New 40.41 refresh rate fix ???? Smokey NVIDIA Windows Graphics Drivers 8 08-30-02 01:32 PM
Flat Panel performance? covener NVIDIA Linux 1 08-08-02 10:42 AM
Refresh rate not fixed in SP3 Creole Microsoft Windows XP And Vista 2 08-03-02 11:32 AM
Multi monitor refresh rate problem ascully General Hardware 6 07-31-02 02:56 PM

All times are GMT -5. The time now is 03:25 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.