Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-07-07, 02:34 PM   #1
hpslim
Registered User
 
Join Date: Nov 2007
Posts: 1
Default Linux reboot issue

I have a HP Slimline s3200z PC that uses nVidia motherboard and graphics card. I installed Linux CentOS 4.4 64-bit (a clone of RedHat 4) on it. The problem is when I reboot via "reboot" or "shutdown -r now", the system goes through the reboot process, but does not actually reboot. It just displays a message saying wait for system to reboot, but it doesn't power off and power back up. I have to manually press and hold the power button to power it off and back on. The "halt" or "shutdown now" works fine -- the system actually powers off as expected. I suspect this is a motherboard compatibility issue. I have installed both the nvlan and GeForce drivers for Linux. I have looked in the BIOS, but didn't see any relevant settings. I have attached the lspci and lsmod dumps:

lspci
00:00.0 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:04.0 PCI bridge: nVidia Corporation MCP61 PCI bridge (rev a1)
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
00:06.0 IDE interface: nVidia Corporation MCP61 IDE (rev a2)
00:07.0 Ethernet controller: nVidia Corporation MCP61 Ethernet (rev a2)
00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:09.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0d.0 VGA compatible controller: nVidia Corporation: Unknown device 03d0 (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:05.0 FireWire (IEEE 1394): Agere Systems FW323 (rev 70)

lsmod
Module Size Used by
nls_utf8 3393 1
parport_pc 29185 0
lp 15089 0
parport 43981 2 parport_pc,lp
autofs4 24009 0
sunrpc 175545 1
ds 21449 0
yenta_socket 22977 0
pcmcia_core 69329 2 ds,yenta_socket
ipt_REJECT 8641 1
ipt_state 3265 9
ip_conntrack 53657 1 ipt_state
iptable_filter 4417 1
ip_tables 21569 3 ipt_REJECT,ipt_state,iptable_filter
dm_multipath 21841 0
button 9057 0
battery 11209 0
ac 6729 0
md5 5696 1
ipv6 282913 14
usb_storage 70921 0
ohci_hcd 24273 0
ehci_hcd 33605 0
nvidia 7021816 24
i2c_core 28609 1 nvidia
forcedeth 63504 0
sr_mod 20581 1
dm_snapshot 19073 0
dm_zero 3649 0
dm_mirror 32465 0
ext3 137809 2
jbd 69105 1 ext3
dm_mod 68097 9 dm_multipath,dm_snapshot,dm_zero,dm_mirror
sata_nv 12357 3
libata 78473 1 sata_nv
sd_mod 19393 3
scsi_mod 141457 4 usb_storage,sr_mod,libata,sd_mod

Thanks
hpslim is offline   Reply With Quote
Old 11-10-07, 02:11 PM   #2
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: Linux reboot issue

Try downloading another distro live cd - small if you like - to see if the problem is specific to CentOS 4.4.
whig is offline   Reply With Quote
Old 11-28-07, 05:13 AM   #3
Wolfhound
Moving to new home
 
Wolfhound's Avatar
 
Join Date: Jan 2005
Location: Spain
Posts: 1,358
Send a message via MSN to Wolfhound Send a message via Yahoo to Wolfhound
Default Re: Linux reboot issue

Try to activate acpi on kernel parameters with acpi=on and see if it helps.
__________________
Intel Quad Core Q6600 @ 3,4 | 4Gigs (2x2) OCZ Reaper PC-8500 | Gigabyte P35-DS3R | Western Digital 500G Caviar SE16 SATA2 NCQ | Seagate160 Gig 7200.9 SATA NCQ | Maxtor 300Gig SATA NCQ | Asus Geforce 260GTX | Samsung Syncmaster 930BF 19'' | BeQuiet Straight Power 700W | Cooler Master CM690 |Windows Vista x64 SP2 |Windows XP SP3 [Deceased PSU, no money for new one, stucked with laptop and XBOX 360]

Macbook Pro 13': 4gigs | Core2 Duo 2,53Mhz | 250Gigs HDD |geforce 9400M| aluminium unibody | Mac OS X 10.6.2 Snow Leopard |gentoo Linux 2.631 kernel


Wolfhound´s Brute: http://wolfhound77.mybrute.com
Wolfhound is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA Responds to Reports of Kepler V-Sync Stuttering Issue Rieper NVIDIA GeForce 600 Series 13 03-03-13 10:56 PM
295.59 (long-lived branch release) for Linux x86/x86_64 released artem NVIDIA Linux 0 06-11-12 11:25 AM
nVidia Linux drivers with Linux on Mac, help? Thetargos NVIDIA Linux 0 05-13-12 12:52 PM
Mandrake Linux 9.0 (Dolphin) now available | comments? volt General Linux 10 10-19-02 10:13 PM
Linux VS. Windows XP! XP wins! dostler NVIDIA Linux 20 09-15-02 03:47 PM

All times are GMT -5. The time now is 01:35 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.