Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-12-07, 12:53 AM   #1
unebaguettesvp
Registered User
 
Join Date: Nov 2007
Posts: 7
Default gnome-screensaver on ubuntu gutsy 64 bit

hi! i tried searching for this issue on this forum but couldn't seem to find it.

i just switched from ati to nvidia on my computer. i now have a geforce 6200 and everything works great except for the gnome-screensaver. this never happened before. in the past, after 10 minutes, the screensaver would activate. now, after installing the new nvidia card, the screen just goes black!

i'm not 100% sure that this is related to the nvidia binary driver (downloaded using envy). but the only thing that has changed is the video card and my xorg.conf. and here it is:

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder26)  Thu Oct  4 10:48:30 PDT 2007

# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"

	# Uncomment if you have a wacom tablet
	#	InputDevice     "stylus"	"SendCoreEvents"
	#	InputDevice     "cursor"	"SendCoreEvents"
	#	InputDevice     "eraser"	"SendCoreEvents"
    Identifier     "Default Layout"
    Screen         "Default Screen" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
EndSection

Section "Files"
EndSection

Section "Module"
	Load "bitmap"
	Load "dbe"
	Load "ddc"
	Load "extmod"
	Load "freetype"
	Load "glx"
	Load "int10"
	Load "record"
	Load "type1"
	Load "vbe"
EndSection

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "us"
EndSection

Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "mouse"
    Option         "CorePointer"
    Option         "Device" "/dev/input/mice"
    Option         "Protocol" "ImPS/2"
    Option         "ZAxisMapping" "4 5"
    Option         "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
    Identifier     "stylus"
    Driver         "wacom"
    Option         "Device" "/dev/input/wacom"
    Option         "Type" "stylus"
    Option         "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
    Identifier     "eraser"
    Driver         "wacom"
    Option         "Device" "/dev/input/wacom"
    Option         "Type" "eraser"
    Option         "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
    Identifier     "cursor"
    Driver         "wacom"
    Option         "Device" "/dev/input/wacom"
    Option         "Type" "cursor"
    Option         "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Monitor"
    # 1280x720 @ 60.00 Hz (GTF) hsync: 44.76 kHz; pclk: 74.48 MHz
    Identifier     "LCD MONITOR"
    HorizSync       30.0 - 70.0
    VertRefresh     50.0 - 87.0
    ModeLine       "1280x720_60.00" 74.5 1280 1308 1444 1664 720 721 724 746 -hsync +vsync
    Option         "DPMS"
EndSection

Section "Device"
	Identifier "nVidia Corporation NV34 [GeForce FX 5500] (rev a1)"
	Driver "nvidia"
	BusID "PCI:1:0:0"
	Option "NoDCC"
	Option "VideoOverlay" "on"
	Option "OpenGLOverlay" "off"
	Option "UseInternalAGPGART" "no"
	Option "NvAGP" "3"
	Option "RenderAccel" "true"
	Option "Coolbits" "1"
	Option "NoLogo"
	VideoRam 262144
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "nVidia Corporation NV34 [GeForce FX 5500] (rev a1)"
    Monitor        "LCD MONITOR"
    DefaultDepth    24
    Option         "AddARGBVisuals" "True"
    Option         "AddARGBGLXVisuals" "True"
    SubSection     "Display"
        Virtual     1280 720
        Depth       24
        Modes      "1280x720_60.00"
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Enable"
EndSection
i know gnome-screensaver is running because if i lightly tap the mouse, the black screen disappears and i can see a screensaver theme. i tried changing the screensaver to come on after 5 minutes. i let gnome-screensaver do it's thing and after 5 minutes, it appears! but then after another 5 minutes (10 minutes total), the black screen comes back.

could this be a problem with the nvidia binary? is there an option i need to enable in xorg.conf? or a module? any help would be appreciated. thank you!
unebaguettesvp is offline   Reply With Quote
Old 11-12-07, 12:32 PM   #2
unebaguettesvp
Registered User
 
Join Date: Nov 2007
Posts: 7
Default Re: gnome-screensaver on ubuntu gutsy 64 bit

fixed it! i added this to my xorg.conf:

Code:
Section "ServerFlags"
	Option "blank time" "0"
	Option "standby time" "0"
	Option "suspend time" "0"
	Option "off time" "0"
	Option "screen blank" "0"
EndSection
i found this here:

http://ubuntuforums.org/showthread.php?t=341617

it seems to be a problem with xgl! sorry for wasting your bandwidth.
unebaguettesvp is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:18 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.