Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-11-07, 12:16 PM   #1
bamapookie
Registered User
 
Join Date: Nov 2007
Posts: 3
Default Unable to use 1600x1200 display mode (Resolved)

I'm running Gentoo and Windows XP on a dual boot system with a 7600. I use 1600x1200 in Windows, but cant get it to go over 1280x1024 in X. I have found other threads here and here. I tried adding the options to the xorg.conf, but they did not work.

Attached is the bug report run with startx -logverbose 6
Below is the output from nvidia-xconfig --query-gpu-info
Code:
bailey ~ # nvidia-xconfig --query-gpu-info
Number of GPUs: 1

GPU #0:
  Name      : GeForce 7600 GS
  PCI BusID : PCI:1:0:0

  Number of Display Devices: 1

  Display Device 0 (DFP-0):
     EDID Name             : Envision EN2028
     Minimum HorizSync     : 30.000 kHz
     Maximum HorizSync     : 83.000 kHz
     Minimum VertRefresh   : 55 Hz
     Maximum VertRefresh   : 75 Hz
     Maximum PixelClock    : 170.000 MHz
     Maximum Width         : 1600 pixels
     Maximum Height        : 1200 pixels
     Preferred Width       : 1280 pixels
     Preferred Height      : 1024 pixels
     Preferred VertRefresh : 60 Hz
     Physical Width        : 400 mm
     Physical Height       : 300 mm
EDIT: Note that the entries for the horizontal and vertical refresh rates in the xorg.conf file are the ones given by the monitor documentation. The ones listed above appear to be wrong.

EDIT2: Replaced the bug report with a new version that includes the verbose output. It is gzipped, because of the forum attachment size limit.
Attached Files
File Type: gz nvidia-bug-report.log.gz (29.8 KB, 110 views)
__________________
Shawn K.
Running nVidia 7600 on Gentoo Linux with 100.14.19 drivers

Last edited by bamapookie; 11-11-07 at 02:04 PM. Reason: Adding resolved to title.
bamapookie is offline   Reply With Quote
Old 11-11-07, 12:28 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Unable to use 1600x1200 display mode

The attached bug report does not include a verbose X log.
netllama is offline   Reply With Quote
Old 11-11-07, 12:44 PM   #3
bamapookie
Registered User
 
Join Date: Nov 2007
Posts: 3
Default Re: Unable to use 1600x1200 display mode

Sorry about that. I replaced that attachment above with one with the correct verbosity. (don't forget the -- in startx -- -logverbose 6)
__________________
Shawn K.
Running nVidia 7600 on Gentoo Linux with 100.14.19 drivers
bamapookie is offline   Reply With Quote
Old 11-11-07, 01:08 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Unable to use 1600x1200 display mode

Try adding the following to xorg.conf:
Option "ModeValidation" "NoDFPNativeResolutionCheck"
netllama is offline   Reply With Quote
Old 11-11-07, 02:03 PM   #5
bamapookie
Registered User
 
Join Date: Nov 2007
Posts: 3
Default Re: Unable to use 1600x1200 display mode

That did it. Thanks.

I was also able to remove all of the other added options,so the NoDFPNativeResolutionCheck was all that was needed.
__________________
Shawn K.
Running nVidia 7600 on Gentoo Linux with 100.14.19 drivers
bamapookie is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
320.17 can't detect video modes on Lenovo laptop tadawson NVIDIA Linux 13 07-14-12 02:40 AM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 07:45 AM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 11:46 PM
Nvidia GF4 MX 440 + Mandrake tomchristopher NVIDIA Linux 3 08-18-02 10:42 AM
nVidia drivers + Red Hat Linux 7.3 Error404 NVIDIA Linux 17 08-16-02 12:34 PM

All times are GMT -5. The time now is 11:07 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.