Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-18-07, 09:27 AM   #1
mmorgan27
Registered User
 
Join Date: May 2007
Posts: 9
Default 100.14.19 install on Ubuntu 7.10 failure

I have a NVidia 6800 Ultra that was working perfectly with a previous install of Ubuntu (7.04) and NVidia installer (1.0-9755). When I upgraded to the latest Ubuntu (7.10), the video driver stopped working.

I tried installing the latest NVidia driver (100.14.19) and I needed to build the kernel module, but the kernel module could not be loaded because of a version issue with struct_module.

Does anyone know why this is happening?

thanks,
Mike
Attached Files
File Type: bz2 nvidia-installer.log.bz2 (5.2 KB, 98 views)
File Type: txt lsmod.txt (3.5 KB, 99 views)
mmorgan27 is offline   Reply With Quote
Old 11-18-07, 12:02 PM   #2
mmorgan27
Registered User
 
Join Date: May 2007
Posts: 9
Default Re: 100.14.19 install on Ubuntu 7.10 failure

I'm guessing this is a Ubuntu problem. It looks like the headers do not match up with the installed kernel.
mmorgan27 is offline   Reply With Quote
Old 11-18-07, 12:21 PM   #3
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: 100.14.19 install on Ubuntu 7.10 failure

Yes, it looks like the kernel development files you built the driver against do not match the running kernel:
[ 5356.932390] nvidia: no version for "struct_module" found: kernel tainted.
[ 5356.932405] nvidia: version magic '2.6.22.9 mod_unload PENTIUM4 ' should be '2.6.22-14-386 mod_unload 486 '
[11084.734074] nvidia: disagrees about version of symbol struct_module
zander is offline   Reply With Quote
Old 11-18-07, 02:18 PM   #4
phelin
Registered User
 
Join Date: Jan 2006
Posts: 30
Default Re: 100.14.19 install on Ubuntu 7.10 failure

Quote:
Originally Posted by mmorgan27
When I upgraded to the latest Ubuntu (7.10), the video driver stopped working.

I tried installing the latest NVidia driver (100.14.19) and I needed to build the kernel module, but the kernel module could not be loaded because of a version issue with struct_module.
Ubuntu 7.10 has 100.14.19 already in the repository: http://packages.ubuntu.com/gutsy/misc/nvidia-glx-new
phelin is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mageia 2 Cannot Install 71.86.15 for Riva TNT/TNT2 kbulgrien NVIDIA Linux 3 06-29-12 08:27 AM
nForce + RedHat 7.3 Success Story rtz NVIDIA Linux 47 02-15-03 02:20 AM
Red Hat null(limbo beta 3), guide to install Nvidia Drivers utiel NVIDIA Linux 21 09-30-02 05:32 PM

All times are GMT -5. The time now is 12:15 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.