Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-19-07, 05:24 AM   #1
pigeon
Registered User
 
Join Date: Jul 2004
Posts: 57
Default 169.04, same Composite + offscreen Xid issue

Hi,

Recently I've reported this issue:

http://www.nvnews.net/vbulletin/showthread.php?t=100464

And I can still reproduce the problem with 169.04:

Code:
NVRM: Xid (0001:00): 13, 0000 01013900 00000039 00000328 00000000 00000080
NVRM: Xid (0001:00): 36,  L1 -> L0
NVRM: Xid (0001:00): 9, Channel 00000020 Instance 00000000 Intr 00100000
NVRM: Xid (0001:00): 36,  L0 -> L0
nvidia-bug-report.log attached

Thanks.


Pigeon.
Attached Files
File Type: log nvidia-bug-report.log (120.8 KB, 89 views)
__________________
Geforce 6600 256MB RAM
Geforce Go 7400 256MB RAM
Geforce 9300M GS 256MB RAM (ASUS N10J)
ION 512MB RAM (Acer Revo)
GTX 460 1G RAM x 2
GeForce GT 335M (Alienware M11X R2)
pigeon is offline   Reply With Quote
Old 11-20-07, 02:42 PM   #2
pigeon
Registered User
 
Join Date: Jul 2004
Posts: 57
Default Re: 169.04, same Composite + offscreen Xid issue

Just a very quick follow up.

I can reproduce the issue with vlc and totem with different video output (e.g. xv, SDL, caca)

I cannot reproduce the issue with xine.
__________________
Geforce 6600 256MB RAM
Geforce Go 7400 256MB RAM
Geforce 9300M GS 256MB RAM (ASUS N10J)
ION 512MB RAM (Acer Revo)
GTX 460 1G RAM x 2
GeForce GT 335M (Alienware M11X R2)
pigeon is offline   Reply With Quote
Old 11-20-07, 04:09 PM   #3
mooninite
Registered User
 
Join Date: May 2006
Posts: 477
Default Re: 169.04, same Composite + offscreen Xid issue

An Xid message is typically not caused by the software driver. Just an FYI.
mooninite is offline   Reply With Quote
Old 11-21-07, 05:50 AM   #4
pigeon
Registered User
 
Join Date: Jul 2004
Posts: 57
Default Re: 169.04, same Composite + offscreen Xid issue

Yeah, well according to the doco Xid indicates a GPU error that could be caused by the driver. And now somehow a user space process is triggering it.

Maybe the driver could catch the scenario so that it won't crashes the system, or maybe the driver is not checking possible bad conditions before invoking certain instructions the GPU.
__________________
Geforce 6600 256MB RAM
Geforce Go 7400 256MB RAM
Geforce 9300M GS 256MB RAM (ASUS N10J)
ION 512MB RAM (Acer Revo)
GTX 460 1G RAM x 2
GeForce GT 335M (Alienware M11X R2)
pigeon is offline   Reply With Quote
Old 11-21-07, 12:13 PM   #5
mooninite
Registered User
 
Join Date: May 2006
Posts: 477
Default Re: 169.04, same Composite + offscreen Xid issue

Let me rephrase what I said.

Most of the times that I've seen Xid errors it has been due to physical hardware problems (the cards ended up dying). However, the most recent time it was due to a driver bug (the Xv bug). The 169.04 driver fixed an Xv bug with non-Turbocache cards. Perhaps you have a new case of an Xv bug that nVidia is not familiar with yet.

Search this forum for nVidia's official explanation of an Xid error. This has been brought up countless times. It even started a huge thread where people started calling each other names. Don't let this thread become the same thing.
mooninite is offline   Reply With Quote
Old 11-21-07, 03:14 PM   #6
pigeon
Registered User
 
Join Date: Jul 2004
Posts: 57
Default Re: 169.04, same Composite + offscreen Xid issue

One thing to note though, in terms of mplayer I can reproduce the problem with -vo x11 and caca output. So I imagine this is not an Xv specific issue.

My wild guess is a mix of X + Composite issue.

Perhaps if possible I'll see if i can reproduce the same issue with a mininal X app.

I'm also curious if any of the NVIDIA guys has any comments with this issue. (Which so far they haven't replied

Thanks again.
__________________
Geforce 6600 256MB RAM
Geforce Go 7400 256MB RAM
Geforce 9300M GS 256MB RAM (ASUS N10J)
ION 512MB RAM (Acer Revo)
GTX 460 1G RAM x 2
GeForce GT 335M (Alienware M11X R2)
pigeon is offline   Reply With Quote
Old 11-21-07, 07:46 PM   #7
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 169.04, same Composite + offscreen Xid issue

I can't reproduce this problem. What else are you running besides your video app and xcompmgr? Also, what version of mplayer are you using?
AaronP is offline   Reply With Quote
Old 11-21-07, 11:15 PM   #8
pigeon
Registered User
 
Join Date: Jul 2004
Posts: 57
Default Re: 169.04, same Composite + offscreen Xid issue

mplayer 1.0rc2, specifically, it's the mplayer from debian-multimedia.org

I simply run mplayer -vo caca file.avi

However, I've just tested it using xcompmgr again, and I cannot reproduce the crash/lockup anymore. Instead, when I hit 'q' to quit mplayer, xcompmgr prints these:

Code:
error 3 request 20 minor 0 serial 40922
error 3 request 20 minor 0 serial 53494
(one line for each quit)

Perhaps 169 somehow fixes the issue with xcompmgr.

Now I can only only reproduce the issue under compiz.

Thanks for looking into this.
__________________
Geforce 6600 256MB RAM
Geforce Go 7400 256MB RAM
Geforce 9300M GS 256MB RAM (ASUS N10J)
ION 512MB RAM (Acer Revo)
GTX 460 1G RAM x 2
GeForce GT 335M (Alienware M11X R2)
pigeon is offline   Reply With Quote

Old 11-21-07, 11:29 PM   #9
pigeon
Registered User
 
Join Date: Jul 2004
Posts: 57
Default Re: 169.04, same Composite + offscreen Xid issue

Interestingly, I've just found out I can reproduce the crash with compiz and cacaview.
I simply run:

Code:
cacaview file.jpg
Then move it offscreen to the top left of the screen, then hit 'q' to quit cacaview.

As far as I know, cacaview (libcaca) currently draws only using plain Xlib stuff, it doesn't do anything fancy like Xshm yet.


Code:
NVRM: Xid (0001:00): 13, 0000 01013900 00000039 00000328 00000000 00000080
SysRq : SAK
NVRM: Xid (0001:00): 36,  L1 -> L0
NVRM: Xid (0001:00): 9, Channel 00000020 Instance 00000000 Intr 00100000
NVRM: Xid (0001:00): 36,  L0 -> L0
SAK: killed process 3972 (Xorg): process_session(p)==tty->session
SAK: killed process 3972 (Xorg): process_session(p)==tty->session
SAK: killed process 4075 (runsvdir): fd#0 opened to the tty
NVRM: Xid (0001:00): 8, Channel 00000020
NVRM: Xid (0001:00): 36,  L1 -> L0
NVRM: Xid (0001:00): 8, Channel 00000020
NVRM: Xid (0001:00): 36,  L0 -> L0
NVRM: Xid (0001:00): 9, Channel 00000020 Instance 00000000 Intr 00100000
NVRM: Xid (0001:00): 9, Channel 00000020 Instance 00000000 Intr 00100000
__________________
Geforce 6600 256MB RAM
Geforce Go 7400 256MB RAM
Geforce 9300M GS 256MB RAM (ASUS N10J)
ION 512MB RAM (Acer Revo)
GTX 460 1G RAM x 2
GeForce GT 335M (Alienware M11X R2)
pigeon is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA Responds to Reports of Kepler V-Sync Stuttering Issue Rieper NVIDIA GeForce 600 Series 13 03-03-13 10:56 PM
Screen freeze NVRM: Xid error ciancaroll NVIDIA Linux 0 06-05-12 01:05 PM

All times are GMT -5. The time now is 05:43 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.