Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-20-07, 10:13 PM   #1
winggndm
Registered User
 
Join Date: Feb 2005
Posts: 8
Default 169.04 video resizing problem with compiz

2 things to report, one with xv and one with opengl, but they seem to both be caused by exhausted video memory.

If i have multiple windows open and start playing a video with Xv output, i cannot increase the size or fullscreen of the video. The window is just black. mplayer starts spitting out this when this happens.
X11 error: BadAlloc (insufficient resources for operation)

If i do the same with the gl or gl2 output in mplayer with multiple windows already open, the video becomes extremely laggy. This also happens with mythtv with using opengl for the frontend.

I can still open more windows with out problems even when mplayer just shows a black window.

Probably left over stuff from the black window bug.

Edit:
Forgot to mention, this only happens when using compiz.
Attached Files
File Type: log nvidia-bug-report-bad-alloc.log (109.0 KB, 102 views)
winggndm is offline   Reply With Quote
Old 11-27-07, 09:14 AM   #2
winggndm
Registered User
 
Join Date: Feb 2005
Posts: 8
Default Re: 169.04 video resizing problem with compiz

Bumping these bugs so they doesn't get lost in the wave after wave of posts.

So did any one from nvidia read this post? Has it been confirmed? Has any one else come into this issue with the beta drivers?
winggndm is offline   Reply With Quote
Old 11-27-07, 11:41 AM   #3
piotrq__
Registered User
 
Join Date: Jan 2006
Posts: 193
Default Re: 169.04 video resizing problem with compiz

It seems to me that what you're having is the old, known "out of vram" problem.
You can try this little trick here: http://smspillaz.wordpress.com/2007/...ur-video-card/
It should decrease video memory consumption with mplayer's XV vo driver.
It has few other advantages as well :-)

I saw in your bug report that you're using Gentoo there, so here you go:
http://www.piotrkow.net.pl/~scrat/ge...999-r17.ebuild
An ebuild for MPlayer svn, shich includes the patch mentioned above and also sports the coolest vo driver you'll ever see - matrixview!
Everything goes to media-video category.

Enjoy!
piotrq__ is offline   Reply With Quote
Old 11-27-07, 12:52 PM   #4
winggndm
Registered User
 
Join Date: Feb 2005
Posts: 8
Default Re: 169.04 video resizing problem with compiz

Ah the almighty video plugin for compiz. Always wanted to try it out, guess not its a good time as any. Wonder if it will ever make it into upstream. But i'm still wondering why the nvidia drivers isn't freeing up memory in this case. I can still open up more windows with out problem even when mplayer reports that error.

Also wondering about the problem with opengl apps when there are too many windows open. Mythtv set to opengl basically takes for ever to just start up. I literally see it drawing each frame.

Oh well, I'll just switch to the compiz video plugin and forget mythtv. I'll just set up/create a script for mplayer to use my remote. <-- only reason why i use mythtv anyways.

Thanks for the help, and the ebuild. It will make my life easier.
winggndm is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
IOGEAR 3D Complete+ 4-Port HDMI Switcher with 2D/3D Video Processor News Archived News Items 0 06-28-12 05:40 PM

All times are GMT -5. The time now is 12:19 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.