Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-25-07, 07:02 PM   #1
Jan Simonson
Registered User
 
Join Date: Nov 2007
Posts: 2
Post Full resolution on a SyncMaster 244T

Hello,

My Fedora 8 system is running on an AMD Athlon 2200+ with a Samsung SyncMaster 244T connected to a GeForce 5200 via a DVI cable. The monitor has a native resolution of 1920x1200. When using the xorg nv driver I'm able to use the full 1920x1200 display. However, as the nvidia driver makes the display much faster and also makes it possible to use Google Earth I installed it (version 100.14.19).

The nvidia driver works ok and Google Earth is very fast, BUT for some reason this driver limits the display to 1600x 1200. As I want to use my full resolution I have tried to correct this by inserting a modeline into the xorg.conf file like this:
Modeline "1920x1200" 154.00 1920 1968 2000 2080 1200 1203 1209 1235

Unfortunately this didn't help (but didn't break anything either). I've also looked in the Xorg.0.log both when using the nv and the nvidia drivers. The 1920x1200 is missing in the one from nvidia, but I don't understand why. Is there a maximum of 1600x1200 hardcoded into the nvidia driver? If so, is it possible to get around this limitation in some way? Both the graphics-card and the monitor are definitely capable of displaying 1920x1200 as they do so with the nv driver.

Any help would be most a appreciated.

Jan
Jan Simonson is offline   Reply With Quote
Old 11-25-07, 09:19 PM   #2
bearoso
Registered User
 
Join Date: Sep 2003
Posts: 57
Default Re: Full resolution on a SyncMaster 244T

You're requesting a reduced-blanking mode. The line should be
Modeline "1920x1200" 154.00 1920 1968 2000 2080 1200 1203 1209 1235 +hsync -vsync

If that doesn't fix your problem, you'll probably need to add
Option "ModeValidation" "NoMaxPClkCheck"
to the appropriate device section of your xorg.conf.

I'm pretty sure the GeForce 5200 isn't supposed to be able to handle this resolution, despite it working in the nv driver.
bearoso is offline   Reply With Quote
Old 11-26-07, 01:51 AM   #3
mc42
Registered User
 
Join Date: May 2006
Posts: 4
Lightbulb Re: Full resolution on a SyncMaster 244T

Quote:
Originally Posted by Jan Simonson
Hello,
My Fedora 8 system is running on an AMD Athlon 2200+ with a Samsung SyncMaster 244T connected to a GeForce 5200 via a DVI cable. The monitor has a native resolution of 1920x1200.
Jan
Try this:

Code:
startx -- -logverbose 5
and look in /var/log/Xorg.0.log for lines like
Code:
(--) NVIDIA(0): LG L204WT (DFP-0): 135.0 MHz maximum pixel clock
(--) NVIDIA(0): LG L204WT (DFP-0): Internal Single Link TMDS
(--) NVIDIA(0): LG L204WT (DFP-0): Native FlatPanel Scaling is supported
(--) NVIDIA(0): LG L204WT (DFP-0): DFP modes are limited to 60 Hz refresh
(--) NVIDIA(0):     rate
Here is 135 Mhz the detected maximum clock for a TMDS encoder on the nvidia card and
Code:
(--) NVIDIA(0): EDID maximum pixel clock     : 150.0 MHz
is the maximum clock reported by the monitor.

You must check that the fist value in your modeline is below the smaler one of the both clock values (here it is 135 Mhz) or you are risking a hardware damage of your card or monitor.

Then tell the nvidia driver to accept your modeline
Code:
Option "ExactModeTimingsDVI" "true"
If you are sure your modeline clock is fine and the nvidia driver is still
rejecting the resolution, you can try
Code:
Option "ModeValidation" "NoDFPNativeResolutionCheck"
Nvidia doesn't publish any documentation for their cards and the option
Code:
Option "ModeValidation" "NoMaxPClkCheck"
allows to overclock the TMDS encoder on your DVI card
output
But if the resolution works fine with the nv driver, then probably the maximal clock detection mechanism in the nvidia driver is broken.
:P
mc42 is offline   Reply With Quote
Old 11-29-07, 04:32 AM   #4
Jan Simonson
Registered User
 
Join Date: Nov 2007
Posts: 2
Default Re: Full resolution on a SyncMaster 244T

Quote:
Originally Posted by bearoso
You're requesting a reduced-blanking mode. The line should be
Modeline "1920x1200" 154.00 1920 1968 2000 2080 1200 1203 1209 1235 +hsync -vsync
I tried this, but it didn't make any change.


Quote:
Originally Posted by bearoso
If that doesn't fix your problem, you'll probably need to add
Option "ModeValidation" "NoMaxPClkCheck"
to the appropriate device section of your xorg.conf.
This did it! Now I have the full 1920x1200 also with the Nvidia driver.


Quote:
Originally Posted by bearoso
I'm pretty sure the GeForce 5200 isn't supposed to be able to handle this resolution, despite it working in the nv driver.
When booting into WindowsXP on the same computer I also have the full 1920x1200 display. So it seems as if the Nvidia Linux driver is a bit too pessimistic about the GeForce 5200 abilities.

Anyhow, thanks for a very speedy and helpful answer!
Jan
Jan Simonson is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
8800 GT and Ubuntu - Plymouth low resolution legluondunet NVIDIA Linux 3 06-24-12 03:22 PM
Opinions on 1280x1024 resolution skipparoo NVIDIA GeForce 7, 8, And 9 Series 103 06-22-12 11:38 PM
Full HD Autosterescopic 3D Displays are Coming Soonâ?¦ Probably News Archived News Items 0 06-15-12 12:30 AM
What resolution do you all run Unreal2003 retail version at with all details on max.? imtim83 Gaming Central 9 10-04-02 10:17 AM
30.82 and 40.41 resolution + monitor OSD. Max3D NVIDIA Windows Graphics Drivers 2 09-05-02 02:15 AM

All times are GMT -5. The time now is 07:18 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.