Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-06-07, 11:46 AM   #1
Eversor
Registered User
 
Join Date: Mar 2005
Posts: 19
Default Slow 3d with composite on

Hi!
I've noticed that while composition effects work well, 3D on top of it runs at about 1/3 of the normal performance.
I'm using the regular Composite extension and Kwin as the composite manager.
I still don't know if this is some bug on the nvidia driver or it I'm doing something wrong. Ideas?
Eversor is offline   Reply With Quote
Old 12-06-07, 12:15 PM   #2
Linuxhippy
Registered User
 
Join Date: Feb 2004
Posts: 585
Default Re: Slow 3d with composite on

How do you measure "3D performance"?

If you are using glxgears, use something more representative like quake3-timedemo (don't know wether openarena also has timedemos).

lg Clemens
Linuxhippy is offline   Reply With Quote
Old 12-06-07, 12:46 PM   #3
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: Slow 3d with composite on

I guess you are indeed talking about a simple app like glxgears. Anyway the performance with composite on is supposed to be less. The idea behind composite is that all windows (including 3d ones) are not rendered directly to the screen but to offscreen memory. It is then the task of the composite manager to draw the desktop using the offscreen windows as 'textures'. This causes less performance.
Thunderbird is offline   Reply With Quote
Old 12-06-07, 02:54 PM   #4
Eversor
Registered User
 
Join Date: Mar 2005
Posts: 19
Default Re: Slow 3d with composite on

Quote:
Originally Posted by Thunderbird
I guess you are indeed talking about a simple app like glxgears. Anyway the performance with composite on is supposed to be less. The idea behind composite is that all windows (including 3d ones) are not rendered directly to the screen but to offscreen memory. It is then the task of the composite manager to draw the desktop using the offscreen windows as 'textures'. This causes less performance.
Yes, it was with glxgears.
But even fullscreen, like unreal tournament 2004, I get this kind of performance drop.
But with AIGLX, for example, working fine, isn't the performance supposed to be the same?
Eversor is offline   Reply With Quote
Old 12-06-07, 04:40 PM   #5
mooninite
Registered User
 
Join Date: May 2006
Posts: 477
Default Re: Slow 3d with composite on

Could you post real benchmark numbers? We have nothing to base your claim over. Run the timed demos from UT 2004, Quake 4, or ET: QW.

What video card and driver are you using? What Linux distribution?

This post won't do much good without some more specifics.
mooninite is offline   Reply With Quote
Old 12-06-07, 05:44 PM   #6
Linuxhippy
Registered User
 
Join Date: Feb 2004
Posts: 585
Default Re: Slow 3d with composite on

so are you using XGL or AIGLX?
Both have some overhead, but AIGLX will be better with nvidia cards.

lg Clemens
Linuxhippy is offline   Reply With Quote
Old 12-08-07, 10:57 AM   #7
Eversor
Registered User
 
Join Date: Mar 2005
Posts: 19
Default Re: Slow 3d with composite on

Quote:
Originally Posted by mooninite
Could you post real benchmark numbers? We have nothing to base your claim over. Run the timed demos from UT 2004, Quake 4, or ET: QW.

What video card and driver are you using? What Linux distribution?

This post won't do much good without some more specifics.
I can post even screenshots if you want.
But, quickly, it's like this:

glxgears without transparency on: ~10000FPS
" with : ~3500FPS
UT2004 without : ~100FPS
UT2004 with : ~ 35FPS

UT's performance changes a lot, but top FPS with transparency on is like 60 instead of 150FPS and it obviously also reflects on the minimum FPS which is also like 20 instead of 50-60.

The computer is a ASUS P5N-E SLI with core 2 duo E6400 @ 2.66GHz and a 7600GT.
Distribution is gentoo linux with all stable packages.

The performance drop is on the fly, I don't need to restart the X server, if I go to KDE's window properties and turn on Transparency, it starts working and performance drops immediately.
I'm just using the composite extension and Option "AllowGLXWithComposite" "true".
Eversor is offline   Reply With Quote
Old 12-16-07, 03:30 AM   #8
Eversor
Registered User
 
Join Date: Mar 2005
Posts: 19
Default Re: Slow 3d with composite on

Ideas please...
No one has any clue if this is a bug in the driver or the software?
best regards.
Eversor is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia 173.14.35: Fedora 17 x86 terribly slow Mr Wolf NVIDIA Linux 25 07-02-12 01:44 AM
Gnome3 with composite is very slow on Geforce FX 5200 with 173.14.31 driver Artox NVIDIA Linux 0 05-26-12 10:33 AM
Slow Jogging Just a Few Times a Week Can Add Years to Your Life [Health] News Archived News Items 0 05-04-12 12:40 PM
Very slow X startup Jeremy NVIDIA Linux 96 05-23-03 10:11 AM

All times are GMT -5. The time now is 10:19 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.