Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-10-07, 07:51 PM   #1
skub
Registered User
 
Join Date: Dec 2007
Location: Germany
Posts: 6
Default 8600 GT - TV-Out problems - X hangs - SOLVED

Hello folks,

i spent dozens of hours reading readmes, howtos and hacking xorg.conf.

I encounter a strange error when enabling tv-out in any way (even without TwinView and TV-only)

I always end up with a blank screen after X has started (before NVidia-Logo).
Looking through ssh on the machine, i see that the X server takes 100% CPU, gdm claims to be starded as well, but most of the other x-specific processes are (still?) not running.

I have no errors in Xorg.0.log... there are even no interesting warnings..., last line says
Code:
(II) NVIDIA(0): Initialized GART.
(II) NVIDIA(0): Setting mode "CRT-0:800x600,TV-0:800x600"
(--) NVIDIA(0): No video decoder detected
(II) Loading extension NV-GLX
after this line i would expect some stuff like my CRT-only gives me:
Code:
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
[...]
(II) Loading extension NV-CONTROL
(==) RandR enabled
(II) Initializing built-in extension [...]
[...]
The X-Server is not killable after this, sending kill -9 makes it a zombie (child of init) i have to reboot (which takes enormous time and a couple of "beeps", until kernel kicks this zombie) after reboot there are still no new entries in Xorg.log last one: "(II) Loading extension NV-GLX"


What i tried:

- Option "UseEDID" "false" - no effect
- 169.04 (? latest beta driver) - complains that due to hardware constraints TV-0 will be disabled
- Option "ConnectedMonitor" "CRT, TV" - to skip any kind of "autodetection" - no effect
- 100.14.23 - guess what: no effect...
- tv only
- booting without TV and pluging it in later
- setting SVideo or Composite
- sleeping one night, and trying everything again ;-)

i attach my conf, log and a verbose lspci
for whatever reason the card is detected as "01:00.0 VGA compatible controller: nVidia Corporation Unknown device 0402 (rev a1) (prog-if 00 [VGA])"

the box says: "MSI nx8600gt" but i cant find the exact matching card on the msi-page, as my one is a "Low Profile"-Modell here you find some german infos about exactly the same card.



X-killing-action:
Code:
sofa:~# ps aux | grep X
USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND
root      3292 98.8  2.3  17888 12020 tty7     RLs+ 02:31   3:23 /usr/bin/X :0 -audit 0 -auth /var/lib/gdm/:0.Xauth -nolisten tcp vt7
sofa:~# kill -9 3292
sofa:~# ps aux | grep X
USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND
root      3292 99.0  0.0      0     0 ?        Rs   02:31   3:43 [Xorg]
sofa:~# tail -n 5 /var/log/Xorg.0.log
        [40] 0  0       0x000003c0 - 0x000003df (0x20) IS[b](OprU)
(II) NVIDIA(0): Initialized GART.
(II) NVIDIA(0): Setting mode "CRT-0:800x600,TV-0:800x600"
(--) NVIDIA(0): No video decoder detected
(II) Loading extension NV-GLX
it takes roughly 5 minutes until the X process stops... after the complete stop i also created a nvidia-bug-report which is also attached

every help or hint would be greatly appreciated... you know... changing the TV and the simple to-use receiver in the living room into a pc and a clumsy CRT monitor and spending couple of days until 2 am to get this working _GREATLY_ reduces the WAF (http://en.wikipedia.org/wiki/WAF)... help me not loosing my face ;-)

greetings...
...skub
Attached Files
File Type: txt lspci.txt (17.7 KB, 95 views)
File Type: gz nvidia-bug-report.log.gz (23.5 KB, 105 views)
File Type: log xorg-tvonly.0.log (26.3 KB, 102 views)
File Type: txt xorg-tvonly.conf.txt (3.8 KB, 102 views)

Last edited by skub; 12-17-07 at 03:59 AM. Reason: solved
skub is offline   Reply With Quote
Old 12-11-07, 09:26 AM   #2
skub
Registered User
 
Join Date: Dec 2007
Location: Germany
Posts: 6
Default Re: 8600 GT - TV-Out problems - X hangs

as i am out of ideas, i will try with a fresh debian (stable) installation.
i will update this post if things change... (or dont change)

greetings...
...skub
skub is offline   Reply With Quote
Old 12-12-07, 03:11 PM   #3
skub
Registered User
 
Join Date: Dec 2007
Location: Germany
Posts: 6
Thumbs down Re: 8600 GT - TV-Out problems - X hangs

unfortunately it has nothing to do with a weired configuration on my site.
so again spend a couple of hours for nothing...

i installed debain 4.0 (stable) with only the minimum of needed packages to only compile NVIDIA drivers and run X with gdm.
i only altered one config file from base-installation, xorg.conf (and of course /etc/apt/sources.list) and added this options:
Code:
    Option "MetaModes" "CRT-0: 800x600, TV-0: 800x600; CRT-0: 640x400, TV-0: 640x400"
    Option "HorizSync" "CRT-0: 30-115; TV-0: 30-50"
    Option "VertRefresh" "CRT-0: 50-160; TV-0: 60"
    Option "TVStandard" "PAL-B" 
    Option "TVOutFormat" "SVIDEO"
All other configuration files are "debian-default". (beside the ones the NVIDIA-installer altered during installation)


Again i run into the problem that as soon as i enable any TV-related configurations within xorg.conf i get an 100% CPU load X server with black screen.

this time i created the nvidia bugreport while the xserver was running...
the attached log is created with:
Code:
X -logverbose 6 -verbose 6
additionally i attached the output of "dpkg --list" with all my installed packages and version. as you see i installed only the bare minimum...

i hope someone can give me some hints... i am completely out of ideas now...

tv-out and hdmi (where i currently have no tv for) are the basic reasons why i bought this card... i am afraid that i have to send the newly acquired nvidia card back to the retailer... as i have no windows where i could use this device...

BTW: someone interested in a nearly new 8600 GT Low Profile (fits nicely into small HTPC's) with HDMI and TV-Out? with a bunch of cables and adapters for D-SUB for example. ;-)

greetings...
...skub
Attached Files
File Type: log nvidia-bug-report.log (109.3 KB, 103 views)
File Type: txt dpkg--list.txt (34.3 KB, 82 views)
skub is offline   Reply With Quote
Old 12-14-07, 05:08 AM   #4
skub
Registered User
 
Join Date: Dec 2007
Location: Germany
Posts: 6
Default Re: 8600 GT - TV-Out problems - X hangs

.
skub is offline   Reply With Quote
Old 12-17-07, 03:59 AM   #5
skub
Registered User
 
Join Date: Dec 2007
Location: Germany
Posts: 6
Cool SOLVED

Issue solved,

resoultion was quite simple:
- send card back to the retailer you bought it.
- buy a ATI card instead.

NVIDIA lost a customer... and for sure i will multiply my opinion among other HTPC users...

So Long, and Thanks for All the Fish...
...skub
skub is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 16, GTX 550Ti, random X hangs, "Attempted to yield the CPU..." MquwIBUO NVIDIA Linux 7 06-12-12 03:39 PM
GT9800 (and previously a 8600 GTS) randomly hangs X, more frequently under load robsims NVIDIA Linux 1 06-12-12 04:21 AM
Driver versions above 275.43 causing Xorg hangs with Quadro 130m ApeironTsuka NVIDIA Linux 2 05-13-12 03:42 PM
Graphic errors and hangs after standby reini122 NVIDIA Linux 4 05-07-12 03:37 AM
DirectX 8 problems with GeForce4 Derwin NVIDIA GeForce 7, 8, And 9 Series 19 08-20-02 01:23 AM

All times are GMT -5. The time now is 07:52 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.