Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-08-07, 12:49 PM   #1
cere88
Registered User
 
Join Date: Dec 2007
Posts: 4
Default 8600M GT+Compiz=Slow Animations and Black Window Bug

Hello all. Sorry for my bad english, i'll try to be as clear as possible.
I got a Acer Aspire 5920G Laptop, with a nVidia Ge Force 8600M GT. I'm running Ubuntu Gutsy (7.10), Compiz Fusion (0.6.2), and the 169.04 nVidia Drivers.
My laptop and my videocard are pretty new, so I should not have problem with animations and any kind of effects in Compiz

Well some effects (such as the minimize/maximize animations) are some times slow and they don't go fluenty (also some effects with Kiba-Dock are not fluenty, that's why I think it's a videocard's problem and not a compiz's one) and when I maximize some windows (such as Mozzila Firefox or Evolution) I see them half black for a moment, and this is pretty annoying.

I tryed also with 100.14.11 or 100.14.23 Drivers, but nothing changes.
I disabled the sync to vblank, some animations less slow but it doesn't solve the issue.

I hope you got a solution for this problem that i can't solve :-(
Here there is my xorg.conf and the bug report
Thanks
Davide.
Attached Files
File Type: log nvidia-bug-report.log (123.7 KB, 97 views)
File Type: txt xorg.conf.txt (3.8 KB, 113 views)
cere88 is offline   Reply With Quote
Old 12-09-07, 03:26 AM   #2
cere88
Registered User
 
Join Date: Dec 2007
Posts: 4
Default Re: 8600M GT+Compiz=Slow Animations and Black Window Bug

Anyone can help?
cere88 is offline   Reply With Quote
Old 12-09-07, 06:26 PM   #3
LostinSpacetime
Registered User
 
LostinSpacetime's Avatar
 
Join Date: Mar 2007
Posts: 53
Default Re: 8600M GT+Compiz=Slow Animations and Black Window Bug

Hi, I believe the behavior you described is just "normal". I have a completely different system and I experience the same. I believe the nVidia developers have more important things to do, like implementing support for the 8900 GT. I think the black window bug is still there, because the driver isn't able to use the system ram. Actually there are systems (like mine) where the this bug shows himself at his worst, meaning I'm getting black windows after the video ram is full. I tried to find out if there are any plans to really solve this problem, but I didn't get any answer .
Good Luck!
LostinSpacetime is offline   Reply With Quote
Old 12-09-07, 10:40 PM   #4
shaundennie
Registered User
 
Join Date: Nov 2006
Posts: 79
Default Re: 8600M GT+Compiz=Slow Animations and Black Window Bug

It's possible (and it sounds like) you are seeing the effects of the video card frequency scaling. You could verify this by opening a terminal and letting the machine idle for a minute or two and then typing "nvidia-settings -q all | grep Current" (note the values) and then typing "nvidia-settings" and then "nvidia-settings -q all | grep Current" again. If the values of the first and last numbers differ then this is probably what you are seeing (the middle nvidia-settings is just to produce enough spam in the terminal to force the card to jump to the highest frequency).

On many of the 7 series mobile cards you can disable the frequency scaling (it's VERY annoying with a composited desktop) but, I'm not sure about the 8 series cards. You can search for PerfLevelSrc on these forums for more information but, I don't know if the "hack" will work on an 8600GT.

Hope that helps.
shaundennie is offline   Reply With Quote
Old 12-10-07, 02:54 AM   #5
cere88
Registered User
 
Join Date: Dec 2007
Posts: 4
Default Re: 8600M GT+Compiz=Slow Animations and Black Window Bug

Thanks for the answers :-)

Well, I tryed as you told me shaundennie, but just opening nvidia-settings the values of nvidia-settings -q all | grep Current don't change. (the values are 275,200 - 1 - 2)
cere88 is offline   Reply With Quote
Old 12-10-07, 10:01 PM   #6
shaundennie
Registered User
 
Join Date: Nov 2006
Posts: 79
Default Re: 8600M GT+Compiz=Slow Animations and Black Window Bug

Those numbers sound very low. You can actually just check the default speed (which is the max on my laptop at least) using "nvidia-settings -q all | grep Default3D". My 7900GS has 100/100 as the lowest clock speeds and 375/500 as the maximum so I'd be surprised if 275/200 was the highest clock speed.
shaundennie is offline   Reply With Quote
Old 12-11-07, 02:58 AM   #7
cere88
Registered User
 
Join Date: Dec 2007
Posts: 4
Default Re: 8600M GT+Compiz=Slow Animations and Black Window Bug

Quote:
Originally Posted by shaundennie
Those numbers sound very low. You can actually just check the default speed (which is the max on my laptop at least) using "nvidia-settings -q all | grep Default3D". My 7900GS has 100/100 as the lowest clock speeds and 375/500 as the maximum so I'd be surprised if 275/200 was the highest clock speed.
Here is the output:

Code:
cere@cere-laptop:~$ nvidia-settings -q all | grep Default3D
  Attribute 'GPUDefault3DClockFreqs' (cere-laptop:0.0): 475,400.
    'GPUDefault3DClockFreqs' is a packed integer attribute.
    'GPUDefault3DClockFreqs' is a read-only attribute.
    'GPUDefault3DClockFreqs' can use the following target types: X Screen,
What can I do? :-(
cere88 is offline   Reply With Quote
Old 12-11-07, 04:19 AM   #8
LostinSpacetime
Registered User
 
LostinSpacetime's Avatar
 
Join Date: Mar 2007
Posts: 53
Default Re: 8600M GT+Compiz=Slow Animations and Black Window Bug

Hi cere88, shaundennie believes that your problems come from the fact that your driver tells the card to lower the clock frequencies when there view to do for it. You can check if this is the case by adding the line

options nvidia NVreg_RegistryDwords="PerfLevelSrc=0x2222"

in your /etc/modprobe.d/nvidia-kernel-nkc file. BUT BE CAREFUL!!! If you do that, then your card will work at maximum clock frequency all the time, what means it will consume a lot and get very hot. Actually I would do it only for testing. On my system it didn't change (almost) anything. As I already said, I believe the black window issue is related to the amount of ram on your card and fact that the driver isn't using the system ram. By the way, if you can change it in bios (shared) than use the maximum. This might help.

Regarding your performance problems. Have you tried to disable the vertical synchronization for compiz? If you experience an improvement (and I believe you will) and you want back the synchronization, you can do it over the nvidia-settings. It's not exactly the same, but it's doing the job.
LostinSpacetime is offline   Reply With Quote

Old 12-11-07, 05:18 AM   #9
shaundennie
Registered User
 
Join Date: Nov 2006
Posts: 79
Default Re: 8600M GT+Compiz=Slow Animations and Black Window Bug

The PerfLevelSrc hack is only a semi-magic incantation. It's actually stolen from the vendor supplied Windows drivers for many laptop cards. I think the author of nvclock speculated on the meaning of the "0x2222" but, no one from nvidia has officially said what it means. On 7xxx mobile cards (using < 169.* drivers) it effectively disables gpu frequency scaling but, it's not clear what else it might do.

On mobile 7xxx cards, without the PerfLevelSrc hack, a composited desktop is painful on the eyes (though, newer drivers are MUCH better than they used to be when getting the card to scale to full gpu speed nearly took an act of god).

I don't know enough about this stuff to claim to be an authority but, basically, the nvidia driver can't (at the time of this writing (I see it coming in +169.*)) give sane default clock speeds for AC/battery power so, if the PerfLevelSrc hack won't work on 8xxx series cards, illogically, your best bet for a smooth composited desktop is probably to generate enough activity on the video card to force it to constantly be at the highest possible frequency. Oddly enough, you can probably do this by playing around with the compiz benchmark plugin, forcing it to sync to vblank and putting it completely offscreen.

A few other things to try would be to reset all the nvidia-settings stuff to default (few of the settings jive well with the 7xxx series of cards), go into the compiz settings manager, check General Options->Display Settings and deselect "Detect Refresh Rate" and then manually move the slider to your laptops refresh rate. It used to the be the case that some laptops would be detected as having a refresh rate of 59.9Hz and it would get rounded down to 50Hz. Needless to say, the desktop was not pleasant at that refresh rate.
shaundennie is offline   Reply With Quote
Old 12-11-07, 05:31 AM   #10
LostinSpacetime
Registered User
 
LostinSpacetime's Avatar
 
Join Date: Mar 2007
Posts: 53
Default Re: 8600M GT+Compiz=Slow Animations and Black Window Bug

On my card (5900XT) "0x2222" locks the performance level at maximum. However, it didn't change much. I got the best performance disabling "sync to vblank" at all in compiz (beryl) and enabling the driver's synchronization.
LostinSpacetime is offline   Reply With Quote
Old 12-11-07, 05:53 AM   #11
shaundennie
Registered User
 
Join Date: Nov 2006
Posts: 79
Default Re: 8600M GT+Compiz=Slow Animations and Black Window Bug

Quote:
Originally Posted by LostinSpacetime
On my card (5900XT) "0x2222" locks the performance level at maximum. However, it didn't change much. I got the best performance disabling "sync to vblank" at all in compiz (beryl) and enabling the driver's synchronization.
It's been a long time since I've checked this out but, you may be getting better performance at much higher CPU usage. I'm not an OpenGL expert but, long ago, looking at the main render routine for compiz, it would sit and sleep for a vblank if that option was set and then compute the next frame. If it wasn't set it would just shove it to the video card and keep computing and the video card would presumably drop many of those refreshes on the floor as it waited for a vblank. (Though, I admit I only glanced at the code and didn't take the time to fully understand it).

Are you sure that it wasn't simply an issue of having your laptops refresh rate being detected wrong?

Quote:
check General Options->Display Settings and deselect "Detect Refresh Rate" and then manually move the slider to your laptops refresh rate. It used to the be the case that some laptops would be detected as having a refresh rate of 59.9Hz and it would get rounded down to 50Hz. Needless to say, the desktop was not pleasant at that refresh rate.
Keep in mind that once you've set/unset the VBlank setting in nvidia-settings you are essentially looking at a reboot (or maybe just a module reload) before you have "purged" the old settings. In my experience, the default nvidia settings are NOT to be touched when using a composited desktop on a laptop (every slider, no matter how enticing, has made my life hard). Set them to default and then fiddle with the compiz settings until it works nicely.
shaundennie is offline   Reply With Quote
Old 12-11-07, 06:40 AM   #12
LostinSpacetime
Registered User
 
LostinSpacetime's Avatar
 
Join Date: Mar 2007
Posts: 53
Default Re: 8600M GT+Compiz=Slow Animations and Black Window Bug

Quote:
Originally Posted by shaundennie
you may be getting better performance at much higher CPU usage.
U are perfectly right. It's exactly what happens and it's a waste of frames, but it doesn't hurt that much and the performance gain was pretty big for me. Setting the refresh rate manually at maximum in compiz improved the situation a little, but not as much as disabling sync to vblank.

Quote:
Originally Posted by shaundennie
Keep in mind that once you've set/unset the VBlank setting in nvidia-settings you are essentially looking at a reboot (or maybe just a module reload) before you have "purged" the old settings.
I'm loading the driver settings at boot up via "nvidia-setting -l" with a script just before I load compiz-manager and it works perfectly for me.

And sorry for the misunderstanding.. my system is a desktop computer .
LostinSpacetime is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:00 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.