Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-17-07, 04:10 PM   #1
XVampireX
Dark Penguin
 
Join Date: Oct 2007
Location: Israel
Posts: 13
Send a message via MSN to XVampireX Send a message via Skype™ to XVampireX
Default ubuntu nvidia compile error

Heya, posting here to let you know that I am having deep issues installing t he nvidia drivers through nvidia official script. The problem is not just with 1 version of the nvidia drivers but with ALL of them. And I don't even think it's distro related.

Basically I'm trying to compile the 169.04 beta driver on my geforce 8800GTX and ubuntu gutsy gibbon system with a Quad Core 2.4ghz system and 2gb of ram. However, it gives me that error that I'm posting as an attachment.

If anyone can help me I would really appreciate it.

By the way, when I install the drivers via Envy, they work... just that envy doesn't support the latest beta driver yet which I need for the kernel I'm using.
Attached Files
File Type: txt nvidia-installer.txt (10.9 KB, 287 views)
XVampireX is offline   Reply With Quote
Old 12-17-07, 07:15 PM   #2
Lithorus
Registered User
 
Lithorus's Avatar
 
Join Date: Sep 2004
Posts: 783
Default Re: ubuntu nvidia compile error

The driver doesn't seem to support your kernel either. You might want to try a non-Xen one.
Lithorus is offline   Reply With Quote
Old 12-17-07, 09:17 PM   #3
sphincter
Registered User
 
sphincter's Avatar
 
Join Date: Mar 2003
Posts: 154
Default Re: ubuntu nvidia compile error

Quote:
Originally Posted by XVampireX
Heya, posting here to let you know that I am having deep issues installing t he nvidia drivers through nvidia official script. The problem is not just with 1 version of the nvidia drivers but with ALL of them. And I don't even think it's distro related.

Basically I'm trying to compile the 169.04 beta driver on my geforce 8800GTX and ubuntu gutsy gibbon system with a Quad Core 2.4ghz system and 2gb of ram. However, it gives me that error that I'm posting as an attachment.

If anyone can help me I would really appreciate it.

By the way, when I install the drivers via Envy, they work... just that envy doesn't support the latest beta driver yet which I need for the kernel I'm using.

uhm, first, you're running the xen kernel, not supported. second, here's one critical error:
/linux-headers-2.6.24-rc5-zen0-x86/arch/x86/Makefile_32: Too many open files

you ran out of file handles. has nothing to do with the nvidia package. but you are right that this isn't distro-specific
__________________
It never gets easier, you just go faster. - Greg Lemond
sphincter is offline   Reply With Quote
Old 12-19-07, 12:09 AM   #4
XVampireX
Dark Penguin
 
Join Date: Oct 2007
Location: Israel
Posts: 13
Send a message via MSN to XVampireX Send a message via Skype™ to XVampireX
Default Re: ubuntu nvidia compile error

I'm using the Zen Kernel, which is not the Xen kernel... Also it doesn't matter what kernel I'm using, like I said, it even does something similar on my ubuntu stock kernel...
XVampireX is offline   Reply With Quote
Old 12-19-07, 02:34 AM   #5
Lithorus
Registered User
 
Lithorus's Avatar
 
Join Date: Sep 2004
Posts: 783
Default Re: ubuntu nvidia compile error

Quote:
Originally Posted by XVampireX
I'm using the Zen Kernel, which is not the Xen kernel... Also it doesn't matter what kernel I'm using, like I said, it even does something similar on my ubuntu stock kernel...
Could you post a log from when you compile with Ubuntu's stock kernel?
Lithorus is offline   Reply With Quote
Old 12-19-07, 05:51 PM   #6
sphincter
Registered User
 
sphincter's Avatar
 
Join Date: Mar 2003
Posts: 154
Default Re: ubuntu nvidia compile error

Sorry, typo, I meant zen, not xen. But the fact remains that zen is an experiemental branch, and therefore, not supported. You need to A) fix the issue with too many open files, and B) try posting a log from the ubuntu kernel, as has been requested.
__________________
It never gets easier, you just go faster. - Greg Lemond
sphincter is offline   Reply With Quote
Old 12-20-07, 11:41 AM   #7
XVampireX
Dark Penguin
 
Join Date: Oct 2007
Location: Israel
Posts: 13
Send a message via MSN to XVampireX Send a message via Skype™ to XVampireX
Default Re: ubuntu nvidia compile error

Ok, I'm sorry, I just compiled the driver in ubuntu stock kernel and... it works :O !!!!! It was so easy too...

But it's weird, I don't understand it... I'm gonna go complain to the Zen kernel people :P
XVampireX is offline   Reply With Quote
Old 12-20-07, 03:55 PM   #8
ilikenwf
Registered User
 
Join Date: Dec 2007
Posts: 7
Default Re: ubuntu nvidia compile error

Guys, there is a difference between the Xen and the Zen kernel. Please take note that the Zen kernel is what we're talking about here, and it is based on 2.6.24 with some useful patches....and for the record, the driver compiles fine for me under zen...I just get interesting "fuzziness" if that's what you could call it when I drop to console, or shake xserver out of a screensaver.
ilikenwf is offline   Reply With Quote

Old 12-20-07, 04:28 PM   #9
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: ubuntu nvidia compile error

It looks like the problem here may be related to a known problem with Linux 2.6.24 kernels built with separate output directories; the 169.07 Linux graphics driver release should build fine against such kernels.
zander is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Regression with 295.33 and GeForce GT 240 maro NVIDIA Linux 16 06-29-12 06:47 PM
295.40 295 cannot be compiled on 3.2 kernel delta32 NVIDIA Linux 4 05-27-12 09:47 PM
Mandrake 9 and nVidia drivers HunterA3 NVIDIA Linux 9 10-09-02 02:54 AM
Mandrake 8.2 Nvidia src.rpm problems Mr_Malcontent NVIDIA Linux 8 09-11-02 09:53 PM

All times are GMT -5. The time now is 07:29 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.