Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-20-07, 12:44 PM   #1
lattensepp
Registered User
 
Join Date: Dec 2005
Posts: 12
Default How to setup X for 1024x768@50Hz ???

Hi!

I tried to setup the X for 1024x768@50Hz. I search the whoole day, but find not a solution for the setup

My xorg.conf

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "Module"
Load "glx"
Load "extmod"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "de"
Option "XkbVariant" "nodeadkeys"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "BENQ MP770"
HorizSync 31.5 - 48.5
VertRefresh 40.0 - 60.0
Option "dpms"
EndSection

Section "Device"
Option "DPI" "75 x 75"
# Option "ModeValidation" "NoEdidModes"
# Option "NoLogo" "TRUE"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8600 GTS"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "UseEDIDFreqs" "FALSE"
SubSection "Display"
Depth 24
EndSubSection
EndSection


When I setup Refresh Rate 50.0 i become 640x480 ???

What have I to change to become 1024x768@50Hz??? I use my pc with Linux vdr software (www.vdr.de) & tvtime.

Distribution: CentOS 5
lattensepp is offline   Reply With Quote
Old 12-20-07, 01:06 PM   #2
bacon12
Registered User
 
bacon12's Avatar
 
Join Date: Jul 2007
Posts: 3,532
Default Re: How to setup X for 1024x768@50Hz ???

You can try searching for the mode lines for your display.There is also a mode line calculator, it is in a lot of distor's repos. Sorry can't remember the package name atm.

Myth site has lots of them, and most will be in a google search.


I don't use cent but I had to create a sub section "Display" under the "Screen" section, and add them in manually.
bacon12 is offline   Reply With Quote
Old 12-20-07, 03:22 PM   #3
kanalje
Registered User
 
Join Date: Aug 2004
Posts: 3
Default Re: How to setup X for 1024x768@50Hz ???

Having the nvidia driver to use any refreshrate but 60hz seems impossible for DFP:s.
I've been dabbling with xorg.conf to get 1600x1200 50hz but it always reverts to "nvidia-auto-select" even though my DFP supports that resolution and refreshrate.
i find the nvidia driver buggy and far from user friendly.
kanalje is offline   Reply With Quote
Old 12-21-07, 07:08 AM   #4
lattensepp
Registered User
 
Join Date: Dec 2005
Posts: 12
Default Re: How to setup X for 1024x768@50Hz ???

My question is? Is it possible to become 1024x768@50Hz ? If yes I will search more and try more, but I aslo don't find a posibility under Windows.
I can also create Modeline with xvidtune.

best regards & sorry for my bad english!
lattensepp is offline   Reply With Quote
Old 12-21-07, 07:26 AM   #5
CME
Registered User
 
Join Date: Dec 2007
Posts: 20
Default Re: How to setup X for 1024x768@50Hz ???

it is possible
try
Option "ModeValidation" "NoDFPNativeResolutionCheck"
Option "ExactModeTimingsDVI" "True"
in Device section and use the following modeline:

Modeline "1024x768_50.00" 51.89 1024 1064 1168 1312 768 769 772 791 -HSync +Vsync
CME is offline   Reply With Quote
Old 12-21-07, 07:29 AM   #6
lattensepp
Registered User
 
Join Date: Dec 2005
Posts: 12
Default Re: How to setup X for 1024x768@50Hz ???

@ cme!

Thanks, I will try it later!

best regards

EDIT:

IT DOESN'T WORK !!!

My xorg.conf now:

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "Module"
Load "glx"
Load "extmod"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "de"
Option "XkbVariant" "nodeadkeys"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "BENQ MP770"
HorizSync 31.5 - 48.5
VertRefresh 40.0 - 60.0
Modeline "1024x768_50.00" 51.89 1024 1064 1168 1312 768 769 772 791 -HSync +Vsync
Option "dpms"
EndSection

Section "Device"
Option "DPI" "75 x 75"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8600 GTS"
Option "ModeValidation" "NoDFPNativeResolutionCheck"
Option "ExactModeTimingsDVI" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "UseEDIDFreqs" "FALSE"
SubSection "Display"
Depth 24
EndSubSection
EndSection

If I have VertRefresh 50.0 the X starts with 640x480 @ 60Hz (benq projector says 59Hz)

If I change to VertRefresh 40.0 - 60.0 the X starts with 60Hz (Benq says 59Hz) and when I start xvidtune, xvidtune "says" 60Hz.

Any Ideas ????

thanks
lattensepp is offline   Reply With Quote
Old 12-21-07, 11:05 AM   #7
lattensepp
Registered User
 
Join Date: Dec 2005
Posts: 12
Default Re: How to setup X for 1024x768@50Hz ???

push !!
lattensepp is offline   Reply With Quote
Old 12-21-07, 11:16 AM   #8
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default Re: How to setup X for 1024x768@50Hz ???

Why don't you read the sticky posts and provide a usable bugreport instead of an x config file?
That seems more useful than writing "push".
pe1chl is offline   Reply With Quote

Old 12-21-07, 11:59 AM   #9
zbiggy
Registered User
 
Join Date: Sep 2002
Posts: 623
Default Re: How to setup X for 1024x768@50Hz ???

Quote:
Originally Posted by kanalje
Having the nvidia driver to use any refreshrate but 60hz seems impossible for DFP:s.
I've been dabbling with xorg.conf to get 1600x1200 50hz but it always reverts to "nvidia-auto-select" even though my DFP supports that resolution and refreshrate.
i find the nvidia driver buggy and far from user friendly.
I have NEC LCD1560NX and on Geforce 6150 via full DVI-D cable I always get FH: 60.0 kHz and FV: 75.0 Hz so theory about Nvidia Linux driver being fixed to 60 Hz is not true. Check if your DVI-D cable have full grid of pins.

In KDE control center->peripheral devices->Screen I can choose between 60,70,75 Hz for my panel.

The 50Hz vertical refresh is not possible on my DFP because of LCD hardware limitation. DDC/EDID reports valid vertical refresh in range 55-75Hz. The same is in panel's driver in Windows XP or paper manual.
zbiggy is offline   Reply With Quote
Old 12-21-07, 12:21 PM   #10
lattensepp
Registered User
 
Join Date: Dec 2005
Posts: 12
Default Re: How to setup X for 1024x768@50Hz ???

Hi!

I installed the nvidia 169.07 driver today. I had the xorg.conf from above. X startet at 60Hz and when I opened the "NVIDIA X Server Settings" Tool and switched to 50Hz, then "apply" it works. Then I killed X, and the same, 60hz. I openet the X Server Settings Tool, switched from 50 to 60hz, then "apply", one more time I switched back to 50Hz and I had one more time 50Hz, after reboot, it dosn't work anymore.

???????????????
Attached Files
File Type: log Xorg.0.log (25.5 KB, 85 views)
lattensepp is offline   Reply With Quote
Old 12-21-07, 01:25 PM   #11
CME
Registered User
 
Join Date: Dec 2007
Posts: 20
Default Re: How to setup X for 1024x768@50Hz ???

you also have to add this to the screen section
Section "Screen"
[...]
SubSection "Display"
Modes "1024x768" "1024x768_50.00" "720x576_60.00" "720x576_50.00" "768x576_60.00" "768x576_50.00" "800x600" "640x480"
EndSubSection
[...]
EndSection

you see the "1024x768_50.00" in there (that are the modes for my notebook)?

edit: put it at the first, so it should use it when starting X
CME is offline   Reply With Quote
Old 12-21-07, 01:49 PM   #12
lattensepp
Registered User
 
Join Date: Dec 2005
Posts: 12
Default Re: How to setup X for 1024x768@50Hz ???

Hi!

Thanks, but didn't work. The BENQ say 59Hz, but when I start xvidtune, i have 50.01 Hz. When I switch with the "X Server Settigns" Application between 50 & 60 Hz I haven't any changes on the Projector ? ? ? Normaly the Picture is for 1-2 sec gone, when changing.

best regards
Attached Files
File Type: log Xorg.0.log (26.0 KB, 88 views)
File Type: log xorg.conf.log (2.1 KB, 77 views)
lattensepp is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Toshiba Sat 1950 screen setup beaulieu NVIDIA Linux 7 06-13-03 03:17 PM
UT 2003 single player setup error HunterA3 NVIDIA Linux 6 10-07-02 12:14 AM
how to setup agp4x damogran2 NVIDIA Linux 1 09-27-02 12:04 PM

All times are GMT -5. The time now is 09:33 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.