Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-15-07, 07:11 PM   #1
sarumont
Registered User
 
Join Date: Jul 2005
Posts: 13
Default 7.0-BETA2 nvidia-driver signedness compilation issues

Has anyone seen anything like the following when compiling nvidia-driver under 7.0-BETA2? The only remotely close references I can find are from the Linux nvidia-driver and are a few years old. Thanks.

Code:
cc1: note: obsolete option -I- used, please use -iquote instead
cc1: warnings being treated as errors
nvidia_os.c: In function 'os_dbg_init':
nvidia_os.c:370: warning: pointer targets in passing argument 3 of 'rm_read_registry_dword' differ in signedness
nvidia_os.c:370: warning: pointer targets in passing argument 4 of 'rm_read_registry_dword' differ in signedness
nvidia_os.c: In function 'os_string_compare':
nvidia_os.c:510: warning: pointer targets in passing argument 1 of 'strcmp' differ in signedness
nvidia_os.c:510: warning: pointer targets in passing argument 2 of 'strcmp' differ in signedness
nvidia_os.c: In function 'os_string_copy':
nvidia_os.c:518: warning: pointer targets in passing argument 1 of 'strcpy' differ in signedness
nvidia_os.c:518: warning: pointer targets in passing argument 2 of 'strcpy' differ in signedness
nvidia_os.c:518: warning: pointer targets in return differ in signedness
nvidia_os.c: In function 'os_string_length':
nvidia_os.c:523: warning: pointer targets in passing argument 1 of 'strlen' differ in signedness
*** Error code 1

Stop in /usr/ports/x11/nvidia-driver/work/NVIDIA-FreeBSD-x86-100.14.19/src.
*** Error code 1

Stop in /usr/ports/x11/nvidia-driver/work/NVIDIA-FreeBSD-x86-100.14.19.
*** Error code 1

Stop in /usr/ports/x11/nvidia-driver.
*** Error code 1

Stop in /usr/ports/x11/nvidia-driver.
sarumont is offline   Reply With Quote
Old 11-15-07, 07:51 PM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: 7.0-BETA2 nvidia-driver signedness compilation issues

I hadn't seen this before, but will take a closer look. Does this happen outside of the ports/ tree? The simplest workaround for now probably is to add '-Wno-sign-compare' to the CFLAGS of the NVIDIA kernel module Makefile.
zander is offline   Reply With Quote
Old 11-16-07, 08:19 AM   #3
sarumont
Registered User
 
Join Date: Jul 2005
Posts: 13
Default Re: 7.0-BETA2 nvidia-driver signedness compilation issues

I get the same results in ports and with the tarball from the downloads section. Also, -Wno-sign-compare did not have any effect. :-\
sarumont is offline   Reply With Quote
Old 11-16-07, 10:01 PM   #4
sarumont
Registered User
 
Join Date: Jul 2005
Posts: 13
Default Re: 7.0-BETA2 nvidia-driver signedness compilation issues

Looking at it a bit more closely, -Werror is in the cc command. I can't figure out where it is being added to my CFLAGS, though. It's present in both the port and the source version.
sarumont is offline   Reply With Quote
Old 11-17-07, 07:40 PM   #5
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: 7.0-BETA2 nvidia-driver signedness compilation issues

@ sarumont: the only way I could make this happen on FreeBSD 7.0-BETA2 was by editing /usr/share/mk/bsd.sys.mk and explicitely adding '-Wpointer-sign' to CWARNFLAGS; you may be able to fix your problem by editing the same file and making sure that '-Wno-pointer-sign' is added to CWARNFLAGS last.
zander is offline   Reply With Quote
Old 11-19-07, 08:51 AM   #6
sarumont
Registered User
 
Join Date: Jul 2005
Posts: 13
Default Re: 7.0-BETA2 nvidia-driver signedness compilation issues

Zander: Thanks a lot! -Wno-pointer-sign was being added conditionally ( if GCC3 ). I moved it to be added unconditionally, and nvidia-driver builds. I won't be able to test it until tonight, but I don't anticipate any problems.

Thanks for throwing some time at this.
sarumont is offline   Reply With Quote
Old 11-21-07, 11:57 AM   #7
sarumont
Registered User
 
Join Date: Jul 2005
Posts: 13
Default Re: 7.0-BETA2 nvidia-driver signedness compilation issues

Unfortunately, no testing is required. kldload fails stating that there is no such file or directory as nvidia, but I suspect the real problem is what ends up in my logs:

Code:
Nov 21 10:38:39 illusion kernel: link_elf: symbol cv_wait undefined
The only things I've been able to find referring to cv_wait and the FreeBSD nvidia-driver were those related to it being called with the wrong mutex. I also tried the beta drivers you posted, but I had the same results.

Any ideas on this one?
sarumont is offline   Reply With Quote
Old 11-21-07, 01:17 PM   #8
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: 7.0-BETA2 nvidia-driver signedness compilation issues

cv_wait() didn't go away, as far as I know, and the right set of header files should be included. Can you post the complete set of build time messages?
zander is offline   Reply With Quote

Old 11-21-07, 06:24 PM   #9
sarumont
Registered User
 
Join Date: Jul 2005
Posts: 13
Default Re: 7.0-BETA2 nvidia-driver signedness compilation issues

Sure thing. I'm attaching the build output from the ports version and the beta.
Attached Files
File Type: txt nvidia-driver-beta.txt (7.3 KB, 178 views)
File Type: txt nvidia-driver-ports.txt (10.6 KB, 175 views)
sarumont is offline   Reply With Quote
Old 11-27-07, 09:36 AM   #10
sarumont
Registered User
 
Join Date: Jul 2005
Posts: 13
Default Re: 7.0-BETA2 nvidia-driver signedness compilation issues

Call off the hounds! In attempting to determine was up with the (apparent) linking problem, I thought to update and rebuild my world. I had been building in /usr/7.0/src rather than /usr/src. Moving to /usr/src seems like it has fixed something.

Mergemaster was noisier this time around, and I finally saw the "FreeBSD version not supported" error when compiling the beta drivers. Now, though, everything builds, installs, loads and runs. I've never been more delighted to see the nVidia splash screen.

Looking back at it, though, I think that everything stemmed from me not using the -m option to mergemaster. I guess I expected it to automagically determine from whence my sources came. Moving them to /usr/src and rebuilding accomplished the same thing as mergemaster -m /usr/7.0/src (only with a lot more time and headaches).

Thanks for your time, zander. Sorry for wasting it due to my oversight.

P.S - Hope you had a good Thanksgiving.
sarumont is offline   Reply With Quote
Old 11-27-07, 11:43 AM   #11
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: 7.0-BETA2 nvidia-driver signedness compilation issues

That's good to hear; thanks for the update!
zander is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia driver compilation for kernel.org source kernel GJAOUEN NVIDIA Linux 0 06-03-12 02:59 PM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 09:35 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 09:49 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-02-02 12:58 AM
Nvidia driver 1.0-3123 VIA 4x issues. dcstimm NVIDIA Linux 8 09-29-02 09:34 PM

All times are GMT -5. The time now is 10:39 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.