Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-21-07, 05:04 AM   #1
ciotti
Registered User
 
Join Date: Dec 2007
Posts: 5
Default nvidia driver load failure - evga 7150/630i 10.3 suse

driver fails to load. have to use vesa driver. prefer to use nvidia driver, but really only absolutely require 1680x1050 resolution, but get errors setting any screen size above 1024x768 (complains about frame buffer limitations).

any help appreciated... error out follows.
Attached Files
File Type: log nvidia-bug-report.log (112.7 KB, 137 views)
ciotti is offline   Reply With Quote
Old 12-21-07, 01:50 PM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: nvidia driver load failure - evga 7150/630i 10.3 suse

Here's your error:
Code:
Dec 20 14:26:41 jicama kernel: NVRM: The NVIDIA probe routine was not called for 1 device(s).
Dec 20 14:26:41 jicama kernel: NVRM: This can occur when a driver such as rivafb, nvidiafb or
Dec 20 14:26:41 jicama kernel: NVRM: rivatv was loaded and obtained ownership of the NVIDIA
Dec 20 14:26:41 jicama kernel: NVRM: device(s).
Dec 20 14:26:41 jicama kernel: NVRM: Try unloading the rivafb, nvidiafb or rivatv kernel module
Dec 20 14:26:41 jicama kernel: NVRM: (and/or reconfigure your kernel without rivafb/nvidiafb
Dec 20 14:26:41 jicama kernel: NVRM: support), then try loading the NVIDIA kernel module again.
Dec 20 14:26:41 jicama kernel: NVRM: No NVIDIA graphics adapter probed!
You need to make sure that rivafb and nvidiafb are not loaded.
AaronP is offline   Reply With Quote
Old 12-21-07, 02:12 PM   #3
ciotti
Registered User
 
Join Date: Dec 2007
Posts: 5
Default Re: nvidia driver load failure - evga 7150/630i 10.3 suse

I saw that. lsmod does not show that those modules are loaded.
ciotti is offline   Reply With Quote
Old 12-21-07, 04:04 PM   #4
ciotti
Registered User
 
Join Date: Dec 2007
Posts: 5
Default Re: nvidia driver load failure - evga 7150/630i 10.3 suse

I removed all the modules from /lib/..../rivafb (etc). no change in error. I then decided to compile from sources.
That changed the error message to RmInitAdapter failed...

any clue?
Attached Files
File Type: log nvidia-bug-report.log (139.1 KB, 114 views)
ciotti is offline   Reply With Quote
Old 12-21-07, 04:38 PM   #5
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: nvidia driver load failure - evga 7150/630i 10.3 suse

1.0-9755 is obsolete. Does this problem reproduce with the 169.07 driver released yesterday?
AaronP is offline   Reply With Quote
Old 12-21-07, 05:15 PM   #6
ciotti
Registered User
 
Join Date: Dec 2007
Posts: 5
Default Re: nvidia driver load failure - evga 7150/630i 10.3 suse

compiled/installed 169.07. And apparently - it worked!
Thanks Aaronp. My wife will be quite happy with her new
xmas present. . Secondary issue- I have the EGVA e-7150/630i
motherboard (I think evga refers to it as a NF77 board). On your forum, another user that had the RmInitAdaptor failed, you had requested to update bios. There is in fact a bio update available for the board, however the update utility requires windows to be installed on the system. Unfornately, EVGA said that the only update provided to them (they said that these come from nvidia) was the windows version. I notice that some bios updates for other nvidia based boards have a bootable .iso.
So the question is, how would I update to NV77V16.BIN bios without having to install windows? Again thanks for the help - and happy holidays.
ciotti is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 09:35 PM
Lucid rt kernel can't load latest nvidia driver module, but generic does. marcod NVIDIA Linux 0 05-02-12 07:23 AM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 09:49 AM
NVIDIA 3123 driver on SuSE 8.0 Ok , but slow to start X Gabolander NVIDIA Linux 3 09-27-02 08:41 AM
Trouble with SuSE 8 & NVIDIA latest driver bughill NVIDIA Linux 3 08-20-02 01:31 PM

All times are GMT -5. The time now is 08:41 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.