Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-22-08, 12:39 AM   #13
Maxim Levitsky
Registered User
 
Join Date: Dec 2007
Posts: 16
Default Re: Switching from X to console results in black console in 169.07

169.09 doesn't fix this.
Maxim Levitsky is offline   Reply With Quote
Old 01-22-08, 01:24 PM   #14
hussam
Registered User
 
Join Date: Sep 2007
Posts: 32
Default Re: Switching from X to console results in black console in 169.07

Sorry for spamming but at least for the time being, can someone from Nvidia simply acknowledge that they are aware of the bug?
hussam is offline   Reply With Quote
Old 02-04-08, 09:53 PM   #15
nael
Registered User
 
Join Date: Feb 2008
Posts: 2
Default Re: Switching from X to console results in black console in 169.07

Quote:
Originally Posted by hussam
Sorry for spamming but at least for the time being, can someone from Nvidia simply acknowledge that they are aware of the bug?
It's really annoying the absence of an answer with this bug
nael is offline   Reply With Quote
Old 02-19-08, 05:13 AM   #16
lloeki
Arch Linux
 
lloeki's Avatar
 
Join Date: Oct 2006
Posts: 122
Default Re: Switching from X to console results in black console in 169.07

I'd l'ike to report I'm hitting this bug too (or a variation of if).

- usually, VT switching works correctly.
- if I suspend and resume, I am 99% sure to have blank consoles, where I can blindly type stuff.
- if I init 3 and hibernate/thaw then consoles are back, even after init 5.
- I'm unsure what would happen if I let X run while hibernating, or if I hibernate again.

that's on a asus w7j with a go7400
Attached Files
File Type: log nvidia-bug-report.log (107.7 KB, 92 views)
lloeki is offline   Reply With Quote
Old 02-20-08, 06:51 AM   #17
lguerb
Registered User
 
Join Date: Feb 2008
Posts: 10
Default Re: Switching from X to console results in black console in 169.07

I do not know if nvidia developers are aware of this, even if it has discussed a hundred of times already. I have similar problems (GeForce Go 6100)

1) 100.14.19 works fine without framebuffer. If I have a framebuffer, then switching to vty's will result in some corrupted lines and such. Still readable but definitely not good.

2) 169.X work fine in X also, but switching to vty's results in totally corrupted fonts, moving like they where floating in water.. and this happens either with framebuffer or without it.

Also, this is not a Linux issue, since I have the same results in FreeBSD. It's definitely something in the driver that they think they're doing ok, but it's just not ok.

An answer from a developer, at least telling me what can I do for help, or what else information I can give for the bug, would be desirable at this point, since this is becoming annoying.
lguerb is offline   Reply With Quote
Old 02-20-08, 07:38 AM   #18
lloeki
Arch Linux
 
lloeki's Avatar
 
Join Date: Oct 2006
Posts: 122
Default Re: Switching from X to console results in black console in 169.07

I'll have to experiment more, but in the process to accelerate hibernation with vanilla kernel, I tried uswsusp.

along with s2disk, with it you also have s2ram (for obviously suspending to ram). out of curiosity, I tried it. it seems that its switch to console prior to suspending and back again makes console VTs not blank upon resume.
I'm using this right now (both s2disk and s2ram) to gether with opensuse-patched pm-utils (to support uswsusp instead of vanilla), and will report if I hit console blanking again.

still, if it happens to work reliably, this is only a workaround.
lloeki is offline   Reply With Quote
Old 02-20-08, 12:18 PM   #19
lguerb
Registered User
 
Join Date: Feb 2008
Posts: 10
Default Re: Switching from X to console results in black console in 169.07

I have some small news. Using the new uvesafb from the kernel 2.6.24, 100.14.19 works perfect with it, I can switch to console and see no corruption at all. This is good. (If it helps the developers, 100.14.19 worked good on the FreeBSD framebuffer too).

Nevertheless, 169.X drivers still corrupt everything. This is bad.
lguerb is offline   Reply With Quote
Old 02-20-08, 03:14 PM   #20
ohcibi
Registered User
 
Join Date: Feb 2008
Posts: 1
Default Re: Switching from X to console results in black console in 169.07

i'm experiencing the same problem without doing anything special.

i just boot my computer and once X is started, the ttys are not available anymore, even if i shut down X. ive talked with some people i know and they do not have this problem, but they have different nvidia-chipsets. so maybe it would help gathering the chipset on which the problem occurs...

i'm using geforce 6200 here.
ohcibi is offline   Reply With Quote

Old 02-21-08, 08:52 AM   #21
lloeki
Arch Linux
 
lloeki's Avatar
 
Join Date: Oct 2006
Posts: 122
Default Re: Switching from X to console results in black console in 169.07

bang. it's back. blackness after a suspend. (note that I'm currently using uvesafb, but it occured nonetheless with vesafb and with plain vga)
lloeki is offline   Reply With Quote
Old 03-18-08, 03:40 PM   #22
Maxim Levitsky
Registered User
 
Join Date: Dec 2007
Posts: 16
Default Re: Switching from X to console results in black console in 169.07

This bug is finally fixed in 169.12


Note that some reporters here were describing other bugs,
I was telling about a blank VT after I do a suspend to ram, and then restart X. otherwise the VTs did work here.
Maxim Levitsky is offline   Reply With Quote
Old 03-20-08, 04:32 PM   #23
codermotor
Registered User
 
Join Date: Jan 2007
Posts: 3
Default Re: Switching from X to console results in black console in 169.07

169.12 does not fix the problem for me. I reported to Nvidia with no response.

My symptoms are:
o After starting X (via startx), either switching to a console, or upon
exiting X, the console is black.
o The system is still responsive (i.e. the CLI works).
o Switching back to X (Alt+F7) displays GUI (desktop)
o Resolution: reboot system.
o Prevention: use NV driver

This is with an up-to-date Fedora 7, on an Asus Z71V, with GeForce Go 6600. This problem has existed for quite a few versions of the Nvidia driver.
codermotor is offline   Reply With Quote
Old 03-21-08, 08:11 AM   #24
Maxim Levitsky
Registered User
 
Join Date: Dec 2007
Posts: 16
Default Re: Switching from X to console results in black console in 169.07

Quote:
Originally Posted by Maxim Levitsky
This bug is finally fixed in 169.12


Note that some reporters here were describing other bugs,
I was telling about a blank VT after I do a suspend to ram, and then restart X. otherwise the VTs did work here.
Yes, on your system console doesn't work, but this isn't this bug.
On my system consoles did work always. I can switch to them after I start x, and if I stop X
I can switch to them even if I suspend to ram/disk

The only situation when they didn't work, and do work now, was when

I suspend system to ram, then restart X, and then consoles didn't work
Maxim Levitsky is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
AMD FX-8120 Black Edition CPU Review (with Asus M5A99X EVO) News Archived News Items 0 06-21-12 08:30 AM
Black screen after switching between graphical virtual consoles five times rrr-wtf NVIDIA Linux 1 05-21-12 04:40 PM
First monitor is black when going to virtual console, when using twinView zeBarbu NVIDIA Linux 2 09-07-03 09:35 PM
Official Linux driver 1.0-3123 thread bammbamm808 NVIDIA Linux 126 12-05-02 06:21 PM

All times are GMT -5. The time now is 05:46 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.