Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Thread Tools
Old 01-06-08, 10:40 AM   #1
Registered User
Join Date: Jan 2008
Posts: 4
Default Refresh rate with Ubuntu Restricted Driver

I have just installed Ubuntu 7.10 on a desktop with an nVidia 6800 XT. I need help in finding a way to control the refresh rate being sent to my monitor by the nVidia Restricted Driver for Ubuntu.

At certain times the Restricted Driver arbitrarily switches to a refresh rate of 50 Hz, but my monitor does not support this refresh rate. It needs a minimum of 56 Hz.

How can I prevent the Restricted Driver from using a refresh rate below 56 Hz?

Here are some details about what happened:

After installation, which went smoothly, I ran the Restricted Drivers Manager and enabled the NVIDIA accelerated graphics driver (latest cards). After installing the driver, this asked for a reboot. I waited until the system updates completed and then rebooted.

When I did, all went well until Ubuntu got to the login screen. At that point, my monitor complained that the signal it was receiving was not supported, and displayed nothing.

I unplugged the cable from the monitor and plugged it into another monitor. This monitor displayed the login screen, and i was able to log in.

I went to System/Preferences/Screen Resolution Preferences and found that the resolution was correct, at 1440x900, but the refresh rate was at 50 Hz. I switched the refresh rate to 56 Hz (the only other option here) and then switched the cable back to the original monitor. Now all seemed well.

However, then I tried to watch a movie using Totem, the movie player that came with Ubuntu. This worked until I switched to Full Screen mode. At that point the monitor went blank, again complaining that the signal was not supported.

Swapping to the other monitor, I found that the refresh rate had switched back to 50 Hz.

Apparently my monitor (a Dynex 19 inch LCD TV) does not support a refresh rate of 50 Hz. I need to keep the refresh rate at a minimum of 56 Hz in order for the monitor to work correctly.

I've done some experimenting, including playing with System/Screen and Graphics Preferences (which, incidentally, would not allow me to send a signal to a second monitor plugged into the other jack on the video card) and also duiong a sudo dpkg-reconfigure xserver-xorg. So far nothing's worked.

How can I keep the nVidia Restricted Driver from arbitrarily switching to a refresh rate of 50 Hz?

Thanks in advance for any help you can give me!

Here's my system configuration:

Asus A7N8 Deluxe motherboard
eVGA 6800 XT
Athlon XP 3000+ Barton
1 GB memory
Dynex DX-LCD-19 monitor (reports as HISENSE)
alisonnic is offline   Reply With Quote
Old 01-06-08, 01:18 PM   #2
NVIDIA Corporation
AaronP's Avatar
Join Date: Mar 2005
Posts: 2,487
Default Re: Refresh rate with Ubuntu Restricted Driver

Please see the forum sticky posts and also http://us.download.nvidia.com/XFree8...html#id2546809 ("Why is the refresh rate not reported correctly by utilities that use the XRandR X extension (e.g., the GNOME "Screen Resolution Preferences" panel, `xrandr -q`, etc)?")
AaronP is offline   Reply With Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
GT650M not recognized by 295.59 Driver on Ubuntu 12.04 hvontres NVIDIA Linux 13 06-22-12 01:33 PM
Refresh rate fix for all Detonator drivers AshG NVIDIA Windows Graphics Drivers 45 04-27-03 04:55 PM
New 40.41 refresh rate fix ???? Smokey NVIDIA Windows Graphics Drivers 8 08-30-02 01:32 PM
Refresh rate not fixed in SP3 Creole Microsoft Windows XP And Vista 2 08-03-02 11:32 AM
Multi monitor refresh rate problem ascully General Hardware 6 07-31-02 02:56 PM

All times are GMT -5. The time now is 08:17 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.