Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-23-03, 03:27 PM   #1
Timothy_Shawn
Registered User
 
Join Date: Apr 2003
Posts: 17
Default Suse 8.0 Geforce FX

Hey, i installed the driver as given in the manual from the Nvidia Home Page, but all aplications say that i have no 3D Accelerator Hardware.

My specifications

Suse 8.0
Geforce FX 5200
KDE
and the last Nvidia Driver

I havent installed the NForce Software, may it be the problem?
I also use the versin 4.2.0 of XFree.

My XF86Config

Section "Files"

ModulePath "/usr/X11R6/lib/modules"
RgbPath "/usr/X11R6/lib/X11/rgb"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail"
EndSection

Section "Module"
Load "type1"
Load "speedo"
Load "extmod"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"
Driver "Keyboard"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "de"
Option "XkbModel" "pc104"
Option "XkbRules" "xfree86"
Option "XkbVariant" "nodeadkeys"
EndSection


Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "ButtonNumber" "5"
Option "Device" "/dev/mouse"
Option "InputFashion" "Mouse"
Option "Name" "Autodetection"
Option "Protocol" "imps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
Option "CalcAlgorithm" "CheckDesktopGeometry"
DisplaySize 360 270
HorizSync 31-80
Identifier "Monitor[0]"
ModelName "1280X1024@75HZ"
Option "DPMS"
VendorName "--> VESA"
VertRefresh 50-75
UseModes "Modes[0]"
EndSection


Section "Modes"
Identifier "Modes[0]"
Modeline "1024x768" 66.29 1024 1040 1216 1400 768 768 775 802
Modeline "1024x768" 76.49 1024 1040 1216 1400 768 768 776 802
EndSection


Section "Screen"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "default"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection


Section "Device"
BoardName "unknown"
BusID "1:0:0"
Driver "fbdev"
Identifier "Device[0]"
Screen 0
VendorName "unknown"
EndSection


Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection


I hope someone can help me.
My XFree86.log is also attachet
Attached Files
File Type: log xfree86.0.log (30.7 KB, 135 views)
Timothy_Shawn is offline   Reply With Quote
Old 04-23-03, 04:32 PM   #2
Ralph Scharpf
Registered User
 
Join Date: Mar 2003
Location: Germany
Posts: 15
Default Wrong Driver?

Hi,

I think you should change the device driver in you XF86CONFIG.

My Device-Configuration looks like this:

Section "Device"
Identifier "Generic Video Card"
Driver "nvidia"
Option "NvAgp" "1"
EndSection

The Option "NvAgp" "1" should be used with nforce chipsets. See documentation for details. Perhaps it would be good to read the pdf-documentation. It can be found on the nvidia home page.

Ralph
Ralph Scharpf is offline   Reply With Quote
Old 04-23-03, 05:00 PM   #3
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Yes, you most definitely need to change "fbdev" to "nvidia", as the installer told you to do, and as the README also says to do.

If you installed from SuSE RPMs, then I believe (though I have no idea if this is actually the case or not; never used SuSE) that you can run switch2nvidia then switch2nvidiaglx, then start X up, to get the right drivers in place.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 04-24-03, 11:33 AM   #4
Timothy_Shawn
Registered User
 
Join Date: Apr 2003
Posts: 17
Default

Yeah thanks my Graphic Card is working now, but all applictions are still saying i have no 3D Acceleratin, some are running realy good, but some others arent running.
Timothy_Shawn is offline   Reply With Quote
Old 04-24-03, 01:09 PM   #5
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Which ones aren't running? Are they just being slow, or are they giving an error and exiting?

Which ones work, too?
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 04-24-03, 01:26 PM   #6
Timothy_Shawn
Registered User
 
Join Date: Apr 2003
Posts: 17
Default

I havent installed any other program now, but gl tron and tuxracer are running. Armagetron isnt running, all aplications say "No 3D Acceleration" and asks for cancel or continue.
Timothy_Shawn is offline   Reply With Quote
Old 04-26-03, 03:57 AM   #7
Timothy_Shawn
Registered User
 
Join Date: Apr 2003
Posts: 17
Default

Please help me!
Timothy_Shawn is offline   Reply With Quote
Old 04-26-03, 08:41 AM   #8
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

That appears to be a SuSE thing -- tuxracer and gltron both never did that in Mandrake or in LFS.

I'm compiling armagetron on LFS now, to see if it could possibly be something with it...

Yeah, armagetron isn't doing that for me. When it launches, it shows the GL vendor string, etc. (info from the driver), but it doesn't say anything about "you have no 3D".

In any case, you definitely do have 3D, regardless of what SuSE thinks. Maybe there's a way inside SuSE to turn these checks off? I don't know what it would be, unfortunately, but the SuSE people might.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote

Old 04-27-03, 02:35 AM   #9
Timothy_Shawn
Registered User
 
Join Date: Apr 2003
Posts: 17
Default

I checked my X86 log file and found the following lines:

(II) LoadModule: "glx"
(WW) Warning, couldn't open module glx
(II) UnloadModule: "glx"
(EE) Failed to load module "glx" (module does not exist, 0)

I installed the Kernel and GLX rpm, so how can it be that the file doesnt exist? Is it possible to write the complete path to the glx module and where is the module located?
Timothy_Shawn is offline   Reply With Quote
Old 04-27-03, 07:36 AM   #10
Slartibardfast
Registered User
 
Join Date: Apr 2003
Location: Ireland
Posts: 18
Default

Hi,
I had a simillar problem where opengl worked but SuSE would tell me that there was no 3D. I evently found this guide on suse's support pages, it helped me sort it out.

I discovered I had to run
switch2nvidia_glx

After which run 3Ddiag, it should report everything ok, unless the driver is not installed correctly, it took me a few goes to get it right.

Check out this guide anyway it might help
http://sdb.suse.de/en/sdb/html/wessels_3d.html

This guide is a NVIDIA installer howto for SuSE, also worth a look, In fact maybe you should uninstall the rpms you loaded and restart with reference to this howto?
ftp://ftp.suse.com/pub/suse/i386/sup...nstaller-HOWTO

Good Luck!!!
P.S. I also found an update for YaST2 specific to 3d configuration, but I don't know if it applies to 8.0? check it out with online updates it might help!
Slartibardfast is offline   Reply With Quote
Old 04-28-03, 11:19 AM   #11
Timothy_Shawn
Registered User
 
Join Date: Apr 2003
Posts: 17
Default

Hey its me again.

I tryed all the steps given in the several manuals but i had no luck.
I also tryed to install the driver with tar archives.

I also used the script switch2nvidia and i got this message:

------------------------------------------------------------------------
Switching the use of "nv" driver of XFree86 to "nvidia" driver of nVidia
------------------------------------------------------------------------

Creating symbolic links to the correct OpenGL library ... done
Patching /etc/X11/XF86Config ... done
linux:~ #

and there is only 1 warning in my XFree86.0.log :

(WW) NVIDIA(0): Option "CalcAlgorithm" is not used


My XF86Config looks like this:

Section "Module"
Load "glx"
Load "type1"
Load "speedo"
Load "extmod"
Load "freetype"
EndSection

Section "Device"
BoardName "unknown"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
Screen 0
VendorName "unknown"
EndSection

It is what the switch2nvidia script has done.

I hope you can help me, and thanks to all who are posteing and all who allready posted.

Tim
Timothy_Shawn is offline   Reply With Quote
Old 04-28-03, 01:52 PM   #12
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Have you run switch2nvidia_glx after that? AFAIK you need to...
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 02:50 PM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 10:28 AM
Geforce 440 Go, SuSE 8.0, and new Nvidia drivers loudawg NVIDIA Linux 4 06-01-04 01:54 AM
My SuSE 8.0 just totally BROKE. Help please!!! sephiroth762 NVIDIA Linux 6 10-09-02 03:30 PM
Suse Linux 8.0 - Geforce 4 TwinView TA00 NVIDIA Linux 8 08-30-02 04:24 AM

All times are GMT -5. The time now is 11:41 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.