Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-25-02, 12:18 AM   #1
crazyowl
Registered User
 
Join Date: Aug 2002
Posts: 13
Default athlon (t - bird) agp instability??

has anyone been affected by the athlon agp memory corruption bug .... all opengl games crash after 5 -10 minutes ... i have a 1.2g t-bird .... i have found a patch and a small amount of info .. but nothing on how to install the patch etc.. i have tried he mem = nopentium in grub but to no avail ......

Last edited by crazyowl; 08-26-02 at 01:49 AM.
crazyowl is offline   Reply With Quote
Old 08-25-02, 12:49 AM   #2
chazmati
ABit Siluro GF4 Ti4200
 
Join Date: Aug 2002
Posts: 9
Default

Did you check this post?

http://www.nvnews.net/vbulletin/show...=&threadid=922

I know it says SMP but this may work for uniprocessor systems too.

Chaz

PS - Are you running Red Hat? Tried 2.4.18-10 yet?
chazmati is offline   Reply With Quote
Old 08-25-02, 01:03 AM   #3
crazyowl
Registered User
 
Join Date: Aug 2002
Posts: 13
Default

yes this is on REd hat 7.3 ... 2.4.18-10 same problem as 2.4.18-3 original install ...
crazyowl is offline   Reply With Quote
Old 08-25-02, 03:42 AM   #4
DisAstro
Registered User
 
Join Date: Aug 2002
Posts: 4
Default

Very strange... I have RH 7.3 and an Athlon 1.2 Tb...
I have no problem with opengl games...
Maybe in combination with the mainboard, I have a MSI K7T Turbo with VIA KT133A Chipset...

I was using the 2.4.18-3 kernel, just upgraded, so it is still possible that it hangs now...

Try compiling the nvidia drivers yourself... just download the SRPM's and use the "rpm --rebuild " option...

Do you use Ximian-gnome? I had problems playing games in that... but that was with RH 7.2...
try playing it in KDE or so... maybe that helps... (it helped for me...)
DisAstro is offline   Reply With Quote
Old 08-25-02, 03:54 AM   #5
crazyowl
Registered User
 
Join Date: Aug 2002
Posts: 13
Default

i'm using KDE and i installed the drivers from the tar.gzips
.. are u suggesting i remove ximiam-gnome from the system??
crazyowl is offline   Reply With Quote
Old 08-25-02, 04:30 AM   #6
DisAstro
Registered User
 
Join Date: Aug 2002
Posts: 4
Default

no, thats not what I mean...
I had Ximian gnome, and there the games crashed, but when I switched to KDE - just log out and log in in KDE, the games didn't crash any more...
and now, with rh 7.3, I removed Ximian-gnome, and the games don't crash in gnome any more...
there must be a bug in the ximian-gnome packages...
DisAstro is offline   Reply With Quote
Old 08-25-02, 07:28 AM   #7
crazyowl
Registered User
 
Join Date: Aug 2002
Posts: 13
Default

ok i think i have it working now i got this reply from nvidia
that helped me .. i'll report back later to confirm that this fix works ...A few things pop into mind regarding your problems:

1) Known AGP issues. Do these symptoms disappear when you disable AGP
support? You can try this by adding the line

Option "NvAgp" "0"

to the appropriate Device section of your XF86Config-4 file.

2) The "streaky textures" suggest that you might have some stray Mesa libGL
files floating around. Are there any libGL.so files in /usr/X11R6/lib? If
so, does removing them fix your problem?

Thanks!
crazyowl is offline   Reply With Quote
Old 08-26-02, 01:48 AM   #8
crazyowl
Registered User
 
Join Date: Aug 2002
Posts: 13
Default

further update .. well ok it seems if i set nvagp 0 then opengl game run fine but konqueror crashes ...

i fixed this by setting nvagp 2 as advised on the KDE web site and now everything appears to be fine....

so anyone with an athlon (t bird) system with an nvidia card to solve agp instability try using
option nvagp 2

in your device section of your XFree86-4 config file...

im now going to see if the mem=nopentium option for lilo/grub
makes any difference i.e by removing it ...
crazyowl is offline   Reply With Quote

Old 08-26-02, 03:27 PM   #9
Anthaus
Registered User
 
Join Date: Jul 2002
Posts: 197
Default

Now that you mention it, I had that problem with my old motherboard (VIA KT133A). I had to use the nopentium trick, but I lost some performance.

Now I use a KT266A motherboard and guess what... I forgot to add the nopentium line at GRUB!! I hadn't noticed before precisely because my system is running rock solid. I switched to RH 7.3 from RH 7.2, as well. Perhaps that had something to do with it. But I've had no problems with the three kernels I've tried (2.4.18-3, 2.4.18-5 and 2.4.18-10).

I remember from a while back that nVidia and AMD blamed each other for this bug. It seems both pieces of hardware tend to fight overa certain part of the AGP texture memory, hence the hard-lockups.

No official fix has been released, AFAIK.
__________________
Use the source, Tux.
Anthaus is offline   Reply With Quote
Old 08-27-02, 12:17 AM   #10
jonabbey
Registered User
 
Join Date: Aug 2002
Location: Austin, TX
Posts: 8
Default AGP bug KT 133a

I've also seen major stability problems with Red Hat 7.3 out-of-the-box on a 1ghz Athlon system.

I've turned off the AGP support as advised here, and things seem to be better. Thank goodness.. my system has been completely unstable when I do any OpenGL stuff.

Has there been any definitive word whether RedHat's 7.3-18 Kernel fixes this issue? Any word on whether a future version of the NVidia driver can do anything about this stability problem on Athlon AGP?
jonabbey is offline   Reply With Quote
Old 08-27-02, 12:18 AM   #11
jonabbey
Registered User
 
Join Date: Aug 2002
Location: Austin, TX
Posts: 8
Default

Quote:
Originally posted by crazyowl
further update .. well ok it seems if i set nvagp 0 then opengl game run fine but konqueror crashes ...

i fixed this by setting nvagp 2 as advised on the KDE web site and now everything appears to be fine....

so anyone with an athlon (t bird) system with an nvidia card to solve agp instability try using
option nvagp 2

in your device section of your XFree86-4 config file...

im now going to see if the mem=nopentium option for lilo/grub
makes any difference i.e by removing it ...
What does nvagp 2 do?
jonabbey is offline   Reply With Quote
Old 08-27-02, 12:49 AM   #12
jonabbey
Registered User
 
Join Date: Aug 2002
Location: Austin, TX
Posts: 8
Default argh

Well, Quake 3 relatively quickly crashed for me even with NvAgp option set to 0. This is with the latest NVidia drivers, and RedHat 2.4.18-3. I'm using an 1ghz Athlon mb with a KT133A motherboard.

Downloading RedHat 2.4.18-18 now.
jonabbey is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gentoo and agp trouble john36 NVIDIA Linux 2 09-12-02 10:36 PM
How much heat can a GeForce4 Ti 4600 handle? Velkator NVIDIA GeForce 7, 8, And 9 Series 4 09-03-02 04:41 PM
Antialiasing bug in 31.00 drivers? Mark_fox NVIDIA Windows Graphics Drivers 7 08-26-02 02:48 PM
X freezes when agp 4x is enabled jinksed NVIDIA Linux 1 08-07-02 04:56 PM
Will AGP 8X increase performance over AGP 4X? sancheuz NVIDIA GeForce 7, 8, And 9 Series 10 07-29-02 08:37 PM

All times are GMT -5. The time now is 05:13 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.