Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-24-03, 07:05 PM   #1
thezub
Registered User
 
Join Date: Apr 2003
Posts: 2
Default kernel module loading

i am a bit confused at the moment, i previously had a mandrake installation and used my geforce 2 ultra card without problems using the old glx and kernel files

i recently installled debian (steep learning curve) on my machine and downlowed the latest single file from the website :

dell dimension 8100
1.5Ghz Pentium 4
Nvidia Geforce 2 ultra (64meg)
Debian woody 3.0r1
Xfree version 4.01
driver version 1.0-4363

i installed the file after installing the kernel headers, it seemed to work fine having to compile its own interface with the kernel etc

anyway when i rebooted, i found the error "(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!"

i read the answer in the README file and now im totally confused, i tried '/sbin/lsmod' sure enough there is no mention of any nvidia related modules

i have no idea what to do with "insmod" but i tried "insmod nvidia" in all my stupidity but there were no complaints and nvidia turned up in /sbim/lsmod, i rebooted to see if i had done anything useful but the same error comes up. im sure i downloaded the correct kernel headers from the debian website, i havnt upgraded by kernel.

oh well, any suggestions are welcome people, i await your replies oh knowledgable ones
thezub is offline   Reply With Quote
Old 04-24-03, 09:10 PM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Rebooting clears out the modules in your kernel. It clears memory; therefore, it must effectively unload all modules.

The problem is that you need to modprobe (or insmod; with this module, they do the same thing) the nvidia module, then, without rebooting startx.

If it still doesn't work, then look in syslog (or the output of dmesg) for the reason why. More often than not, it's because you need to disable PnP OS, or enable Assign IRQ to VGA, in your BIOS. But most likely, the problem is that after you reboot, the module still isn't loaded.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 04-25-03, 09:47 AM   #3
thezub
Registered User
 
Join Date: Apr 2003
Posts: 2
Default sorted mate, thanks

thanks alot man, not rebooting worked a peach
erm, is there any way of having it load automatically so ican log in and perhaps chose my desktop manager??

i remember the /etc/modules.conf file but i dont know how to put stuff in it, im not even sure if this is the right way of going about it.

erm anyway, lol, thanks for the help man, twas nice to get the pretty gui up.
thezub is offline   Reply With Quote
Old 04-25-03, 05:06 PM   #4
Noth
Registered User
 
Join Date: Nov 2002
Posts: 44
Default

Look at /etc/modules.

That file is a list of modules to load at boot-up.
Noth is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 10:46 PM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 08:23 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 10:16 PM

All times are GMT -5. The time now is 04:02 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.