Go Back   nV News Forums > Hardware Forums > General Hardware

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-11-08, 05:01 AM   #1
litri
Update Machine
 
litri's Avatar
 
Join Date: Jul 2003
Location: Frankfurt, Germany
Posts: 106
Unhappy What's wrong with my PSU?

Hi there,

A few days ago I bought an Asus Striker II Formula and Thermaltake Toughpower 1500W PSU as soon i'm going to get a third GTX for my rig in order to have some 3-way SLI fun.

I installed the mobo, put all the screws and so on (hardware in my sig) and then i turned on the switch on the back of the PSU to on, everything was working (the ROG logo light, the lcd poster, etc). I turned the PC on and started setting the bios and so on. I didn't install the OS as I wanted to add some fans to the case.

The day after I put those two new fans and conected them, but to my surprise when I switched on the PSU, the fuse of my living room went down and I lost all the electricity current. Evety time I went to the box and i switched the fuse up and tried to turn on the PSU switch the fuse was going down.

I disconected the extra fans I added and the problem persisted, so I decided to unplug eveything and try things separately. I took the PSU out of the case and tried it without anything conected and it works (the fan does not spin, oddly enough, perhaps because no power is drawn)!!

What do you guys think it is?? Which steps should i take?

Thanks a lot!
__________________
AMD Phenom II X6 1055t @3,6ghz
Noctua NH-D14
8GB Geil Dragon Quadkit (800mhz) 5-5-5-13
Asus M4A79 Deluxe
2x VTX3D 4850 1GB
1x WD Raptor 450 GB
1x WD Raptor 300 GB
1x WD Caviar se 160 GB
1x Plextor Premium CD-R\RW 52x/32x/52x
1x Plextor DVD-R\RW PX-760SA
Coolermaster CM690-II Advanced
Super Flower SF-1000P14HE Amazon 80plus

Last edited by litri; 02-13-08 at 07:35 AM.
litri is offline   Reply With Quote
Old 02-11-08, 07:16 AM   #2
Revs
Registered User
 
Join Date: May 2007
Location: UK
Posts: 6,365
Default Re: What's wrong with my PSU?

Just return it. Sounds like a bad-un. You haven't trapped any wires while building the PC have you??
Revs is offline   Reply With Quote
Old 02-11-08, 07:27 AM   #3
litri
Update Machine
 
litri's Avatar
 
Join Date: Jul 2003
Location: Frankfurt, Germany
Posts: 106
Default Re: What's wrong with my PSU?

As I'm currently at work i can't try it again but soon as I get home I will try the mobo again, maybe there was something shortcircuiting it, but it is very strange that one day is working and just the one after is not.

What if i really trapped some cables?? Re-building it again should fix it, shouldn't it?

Thx, dude.
__________________
AMD Phenom II X6 1055t @3,6ghz
Noctua NH-D14
8GB Geil Dragon Quadkit (800mhz) 5-5-5-13
Asus M4A79 Deluxe
2x VTX3D 4850 1GB
1x WD Raptor 450 GB
1x WD Raptor 300 GB
1x WD Caviar se 160 GB
1x Plextor Premium CD-R\RW 52x/32x/52x
1x Plextor DVD-R\RW PX-760SA
Coolermaster CM690-II Advanced
Super Flower SF-1000P14HE Amazon 80plus
litri is offline   Reply With Quote
Old 02-11-08, 08:04 AM   #4
Madpistol
It's a wittle baby!
 
Madpistol's Avatar
 
Join Date: Jan 2007
Location: United States
Posts: 4,554
Send a message via AIM to Madpistol
Default Re: What's wrong with my PSU?

1500 watts... isn't that about the same capacity as a hair dryer?
__________________
http://bfbc2.statsverse.com/sig/deta...d%20Pistol.png


MadPistol's Rig

AMD Phenom II X4 965 BE (RB-C3) @ 4Ghz, 1.425 Vcore, 1.25V NB VID
Thermalright Ultra 120 Extreme (w/ Scythe Gentle Typhoon 120mm fan)
Gigabyte UD3H AM3 790GX motherboard
XFX Radeon HD 5870
PNY XLR8 2x2GB CL8 DDR3 1600
G.Skill Ripjaws 2x2GB CL8 DDR3 1600
Soundblaster X-Fi Fatality Titanium
OCZ Vertex II 120GB SSD (OS drive)
Western Digital 500GB Caviar (black)
Western Digital 640GB Blue
Samsung DVD burner
Logitech MX performance mouse
Logitech G15 keyboard
Corsair HX 750-watt Modular PSU
Antec Nine Hundred case
Windows 7 Home Premium x64
ASUS MK241 24" LCD
ACER X241W 24" LCD - RIP
Madpistol is offline   Reply With Quote
Old 02-11-08, 08:10 AM   #5
guessunevahadit
*BANNED*
 
Join Date: Feb 2008
Posts: 52
Default Re: What's wrong with my PSU?

Quote:
Originally Posted by litri

Thermaltake Toughpower


THERMALCRAP. NOUGH SAID.
guessunevahadit is offline   Reply With Quote
Old 02-11-08, 08:20 AM   #6
litri
Update Machine
 
litri's Avatar
 
Join Date: Jul 2003
Location: Frankfurt, Germany
Posts: 106
Default Re: What's wrong with my PSU?

Quote:
Originally Posted by Madpistol
1500 watts... isn't that about the same capacity as a hair dryer?
I'm using it to power my small neighbourhood as well, xDD.
__________________
AMD Phenom II X6 1055t @3,6ghz
Noctua NH-D14
8GB Geil Dragon Quadkit (800mhz) 5-5-5-13
Asus M4A79 Deluxe
2x VTX3D 4850 1GB
1x WD Raptor 450 GB
1x WD Raptor 300 GB
1x WD Caviar se 160 GB
1x Plextor Premium CD-R\RW 52x/32x/52x
1x Plextor DVD-R\RW PX-760SA
Coolermaster CM690-II Advanced
Super Flower SF-1000P14HE Amazon 80plus
litri is offline   Reply With Quote
Old 02-11-08, 08:29 AM   #7
EciDemon
Registered User
 
EciDemon's Avatar
 
Join Date: Nov 2002
Location: Sweden
Posts: 1,423
Send a message via ICQ to EciDemon
Default Re: What's wrong with my PSU?

humm, make sure that the beast is on its own power outlet, dont share with monitor , speaker system, x360 etc etc..
EciDemon is offline   Reply With Quote
Old 02-11-08, 08:37 AM   #8
litri
Update Machine
 
litri's Avatar
 
Join Date: Jul 2003
Location: Frankfurt, Germany
Posts: 106
Default Re: What's wrong with my PSU?

Quote:
Originally Posted by EciDemon
humm, make sure that the beast is on its own power outlet, dont share with monitor , speaker system, x360 etc etc..
When I tried it yesterday, TV, home cinema, dvd player... even the damn telephone charge station were disconected and the fuse was still going down.
__________________
AMD Phenom II X6 1055t @3,6ghz
Noctua NH-D14
8GB Geil Dragon Quadkit (800mhz) 5-5-5-13
Asus M4A79 Deluxe
2x VTX3D 4850 1GB
1x WD Raptor 450 GB
1x WD Raptor 300 GB
1x WD Caviar se 160 GB
1x Plextor Premium CD-R\RW 52x/32x/52x
1x Plextor DVD-R\RW PX-760SA
Coolermaster CM690-II Advanced
Super Flower SF-1000P14HE Amazon 80plus
litri is offline   Reply With Quote

Old 02-11-08, 08:45 AM   #9
Tr1cK
not coming back
 
Join Date: Nov 2004
Posts: 4,872
Default Re: What's wrong with my PSU?

Quote:
Originally Posted by guessunevahadit
THERMALCRAP. NOUGH SAID.
Get lost, troll.

I would take it out of the case and connect it to only a few bare essentials to see if the system will power up at all. The fan not spinning could be because there is no load on the PSU.
Tr1cK is offline   Reply With Quote
Old 02-11-08, 08:56 AM   #10
EciDemon
Registered User
 
EciDemon's Avatar
 
Join Date: Nov 2002
Location: Sweden
Posts: 1,423
Send a message via ICQ to EciDemon
Default Re: What's wrong with my PSU?

Quote:
Originally Posted by litri
When I tried it yesterday, TV, home cinema, dvd player... even the damn telephone charge station were disconected and the fuse was still going down.
Dang, ive blown fuses a coupple of times with me old rig back when it had a 350psu i belive. That particular psu later broke on me, I dont think it was any special brand as it came in my Nobless mirror chassi. With later more powerfull PSUs there's been no problems, but this might be unrelated.

Im begining to suspect as posters here, it might be a faulty psu to begin with, think about it.. good powerfull vaccumcleaners can be close to 1500w ... my harman kardon reciever peaks at 1250w according to specs, puter at 600w, brothers puter 500w with old 19inch crt and his stereo reciever plus some other things all in my livingroom on at the same time (you better belive we dont need any radiators in there )
EciDemon is offline   Reply With Quote
Old 02-11-08, 09:09 AM   #11
guessunevahadit
*BANNED*
 
Join Date: Feb 2008
Posts: 52
Default Re: What's wrong with my PSU?

Quote:
Originally Posted by Tr1cK
Get lost, troll.
Im just pointing out the obvious, if you dont like it then maybe you should be the one to get lost
Quote:
Originally Posted by Tr1cK
The fan not spinning could be because there is no load on the PSU.
Or because as I stated earlier...... its a THERMALCRAP.
guessunevahadit is offline   Reply With Quote
Old 02-11-08, 11:37 AM   #12
Revs
Registered User
 
Join Date: May 2007
Location: UK
Posts: 6,365
Default Re: What's wrong with my PSU?

Tuningmaster? Is that you??
Revs is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
PC Power and Cooling Silencer MkII 750W PSU review News Archived News Items 0 05-14-12 05:20 AM
Quake3 won't utdeom2003 works fine! what could be wrong with q3? dante_uk NVIDIA Linux 5 09-27-02 06:34 AM
wrong kernel version athel NVIDIA Linux 1 08-15-02 09:23 PM

All times are GMT -5. The time now is 05:47 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.