Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-12-08, 08:35 PM   #1
milky-wayz
Registered User
 
Join Date: Feb 2007
Posts: 4
Default Need help with Direct Rendering (1.0-9639)

Here is my Xorg.0.log
it seems everything load fine but not direct rendering. thankful for every hint. I left some stuff out of the log because it was to long.
Code:
X Window System Version 7.2.0
Release Date: 22 January 2007
X Protocol Version 11, Revision 0, Release 7.2
Build Operating System: FreeBSD 6.2-RELEASE i386 
Current Operating System: FreeBSD unknown 6.2-RELEASE FreeBSD 6.2-RELEASE #0: Fri Jan 12 10:40:27 UTC 2007     root@dessler.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC i386
Build Date: 11 September 2007
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Feb 13 02:21:17 2008
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "X.org Configured"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(**) |   |-->Device "Card0"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(WW) `fonts.dir' not found (or not valid) in "/usr/local/lib/X11/fonts/75dpi/".
	Entry deleted from font path.
	(Run 'mkfontdir' on "/usr/local/lib/X11/fonts/75dpi/").
(**) FontPath set to:
	/usr/local/lib/X11/fonts/misc/,
	/usr/local/lib/X11/fonts/freefont-ttf/,
	/usr/local/lib/X11/fonts/TTF/,
	/usr/local/lib/X11/fonts/OTF/,
	/usr/local/lib/X11/fonts/Type1/,
	/usr/local/lib/X11/fonts/100dpi/
(**) RgbPath set to "/usr/local/share/X11/rgb"
(**) ModulePath set to "/usr/local/lib/xorg/modules"
(II) Loader magic: 0x819e340
(II) Module ABI versions:
	X.Org ANSI C Emulation: 0.3
	X.Org Video Driver: 1.1
	X.Org XInput driver : 0.7
	X.Org Server Extension : 0.3
	X.Org Font Renderer : 0.5
(II) Loader running on freebsd
(II) LoadModule: "pcidata"
(II) Loading /usr/local/lib/xorg/modules//libpcidata.so
(II) Module pcidata: vendor="X.Org Foundation"
	compiled for 7.2.0, module version = 1.0.0
	ABI class: X.Org Video Driver, version 1.1
(--) Using syscons driver with X support (version 2.0)
(--) using VT number 9



(II) PCI: End of PCI scan
(II) Host-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (0,0,1), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 0 I/O range:
	[0] -1	0	0x00000000 - 0x0000ffff (0x10000) IX[b]
(II) Bus 0 non-prefetchable memory range:
	[0] -1	0	0x00000000 - 0xffffffff (0x0) MX[b]
(II) Bus 0 prefetchable memory range:
	[0] -1	0	0x00000000 - 0xffffffff (0x0) MX[b]
(II) PCI-to-PCI bridge:
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x000b (VGA_EN is set)
(II) Bus 1 non-prefetchable memory range:
	[0] -1	0	0xfca00000 - 0xfeafffff (0x2100000) MX[b]
(II) Bus 1 prefetchable memory range:
	[0] -1	0	0xe7f00000 - 0xf7efffff (0x10000000) MX[b]
(II) PCI-to-ISA bridge:
(II) Bus -1: bridge is at (0:17:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(--) PCI:*(1:0:0) nVidia Corporation NV11 [GeForce2 MX/MX 400] rev 178, Mem @ 0xfd000000/24, 0xe8000000/27, BIOS @ 0xfeaf0000/16



(II) LoadModule: "extmod"
(II) Loading /usr/local/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
	compiled for 7.2.0, module version = 1.0.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 0.3
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "record"
(II) Loading /usr/local/lib/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
	compiled for 7.2.0, module version = 1.13.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 0.3
(II) Loading extension RECORD
(II) LoadModule: "dbe"
(II) Loading /usr/local/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
	compiled for 7.2.0, module version = 1.0.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 0.3
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/local/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
	compiled for 4.0.2, module version = 1.0.9639
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "xtrap"
(II) Loading /usr/local/lib/xorg/modules/extensions//libxtrap.so
(II) Module xtrap: vendor="X.Org Foundation"
	compiled for 7.2.0, module version = 1.0.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 0.3
(II) Loading extension DEC-XTRAP
(II) LoadModule: "freetype"
(II) Loading /usr/local/lib/xorg/modules/fonts//libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
	compiled for 7.2.0, module version = 2.1.0
	Module class: X.Org Font Renderer
	ABI class: X.Org Font Renderer, version 0.5
(II) Loading font FreeType
(II) LoadModule: "type1"
(II) Loading /usr/local/lib/xorg/modules/fonts//libtype1.so
(II) Module type1: vendor="X.Org Foundation"
	compiled for 7.2.0, module version = 1.0.2
	Module class: X.Org Font Renderer
	ABI class: X.Org Font Renderer, version 0.5
(II) Loading font Type1
(II) LoadModule: "nvidia"
(II) Loading /usr/local/lib/xorg/modules/drivers//nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
	compiled for 4.0.2, module version = 1.0.9639
	Module class: X.Org Video Driver
(II) LoadModule: "mouse"
(II) Loading /usr/local/lib/xorg/modules/input//mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
	compiled for 7.2.0, module version = 1.1.1
	Module class: X.Org XInput Driver
	ABI class: X.Org XInput driver, version 0.7
(II) LoadModule: "kbd"
(II) Loading /usr/local/lib/xorg/modules/input//kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
	compiled for 7.2.0, module version = 1.1.0
	Module class: X.Org XInput Driver
	ABI class: X.Org XInput driver, version 0.7
(II) NVIDIA dlloader X Driver  1.0-9639  Mon Apr 16 19:34:05 PDT 2007
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(--) Chipset NVIDIA GPU found
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/local/lib/xorg/modules//libfb.so
(II) Module fb: vendor="X.Org Foundation"
	compiled for 7.2.0, module version = 1.0.0
	ABI class: X.Org ANSI C Emulation, version 0.3
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Loading /usr/local/lib/xorg/modules//libramdac.so
(II) Module ramdac: vendor="X.Org Foundation"
	compiled for 7.2.0, module version = 0.1.0
	ABI class: X.Org Video Driver, version 1.1
(II) resource ranges after xf86ClaimFixedResources() call:
	
(II) Setting vga for screen 0.
(==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NoLogo" "true"
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): NVIDIA GPU GeForce2 MX/MX 400 at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 65536 kBytes
(--) NVIDIA(0): VideoBIOS: 03.11.01.48.00
(II) NVIDIA(0): Detected AGP rate: 4X
(--) NVIDIA(0): Interlaced video modes are not supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce2 MX/MX 400 at
(--) NVIDIA(0):     PCI:1:0:0:
(--) NVIDIA(0):     Chuntex (CRT-0)
(--) NVIDIA(0): Chuntex (CRT-0): 350.0 MHz maximum pixel clock
(II) NVIDIA(0): Assigned Display Device: CRT-0
(WW) NVIDIA(0): No valid modes for "1024x786_85"; removing.
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):     "1280x1024_85"
(II) NVIDIA(0): Virtual screen size determined to be 1280 x 1024
(--) NVIDIA(0): DPI set to (90, 96); computed from "UseEdidDpi" X config
(--) NVIDIA(0):     option
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC?  No, I don't.
(II) resource ranges after preInit:
	[0] 0	0	0xe8000000 - 0xefffffff (0x8000000) MX[b]
	[1] 0	0	0xfd000000 - 0xfdffffff (0x1000000) MX[b]
	[2] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
	[3] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[b]
	[4] -1	0	0x000c0000 - 0x000effff (0x30000) MX[b]
	[5] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[b]
	[6] -1	0	0xfebffc00 - 0xfebfffff (0x400) MX[b]E
	[7] -1	0	0xfebff800 - 0xfebffbff (0x400) MX[b]E
	[8] -1	0	0xf8000000 - 0xf7ffffff (0x0) MX[b]EO
	[9] -1	0	0xfeaf0000 - 0xfeafffff (0x10000) MX[b](B)
	[10] -1	0	0xe8000000 - 0xefffffff (0x8000000) MX[b](B)
	[11] -1	0	0xfd000000 - 0xfdffffff (0x1000000) MX[b](B)
	[12] 0	0	0x000a0000 - 0x000affff (0x10000) MS[b](OprD)
	[13] 0	0	0x000b0000 - 0x000b7fff (0x8000) MS[b](OprD)
	[14] 0	0	0x000b8000 - 0x000bffff (0x8000) MS[b](OprD)
	[15] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[b]
	[16] -1	0	0x00000000 - 0x000000ff (0x100) IX[b]
	[17] -1	0	0x0000e800 - 0x0000e8ff (0x100) IX[b]E
	[18] -1	0	0x0000ec00 - 0x0000ecff (0x100) IX[b]E
	[19] -1	0	0x0000e400 - 0x0000e4ff (0x100) IX[b]E
	[20] -1	0	0x0000e000 - 0x0000e0ff (0x100) IX[b]E
	[21] -1	0	0x0000dc00 - 0x0000dcff (0x100) IX[b]E
	[22] -1	0	0x0000fc00 - 0x0000fcff (0x100) IX[b]E
	[23] -1	0	0x0000c400 - 0x0000c4ff (0x100) IX[b]E
	[24] -1	0	0x0000c800 - 0x0000c8ff (0x100) IX[b]E
	[25] -1	0	0x0000cc00 - 0x0000ccff (0x100) IX[b]E
	[26] -1	0	0x0000d000 - 0x0000d0ff (0x100) IX[b]E
	[27] -1	0	0x0000d400 - 0x0000d4ff (0x100) IX[b]E
	[28] -1	0	0x0000d800 - 0x0000d8ff (0x100) IX[b]E
	[29] 0	0	0x000003b0 - 0x000003bb (0xc) IS[b](OprU)
	[30] 0	0	0x000003c0 - 0x000003df (0x20) IS[b](OprU)
(II) NVIDIA(0): Setting mode "1280x1024_85"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension XAccessControlExtension
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(II) Initializing extension GLX
(**) Option "Protocol" "auto"
(**) Mouse0: Device: "/dev/sysmouse"
(**) Mouse0: Protocol: "auto"
(**) Option "CorePointer"
(**) Mouse0: Core Pointer
(**) Option "Device" "/dev/sysmouse"
(==) Mouse0: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "4 5 6 7"
(**) Mouse0: ZAxisMapping: buttons 4, 5, 6 and 7
(**) Mouse0: Buttons: 11
(**) Option "CoreKeyboard"
(**) Keyboard0: Core Keyboard
(**) Option "Protocol" "standard"
(**) Keyboard0: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) Keyboard0: XkbRules: "xorg"
(**) Option "XkbModel" "pc105"
(**) Keyboard0: XkbModel: "pc105"
(**) Option "XkbLayout" "de"
(**) Keyboard0: XkbLayout: "de"
(**) Option "XkbVariant" "nodeadkeys"
(**) Keyboard0: XkbVariant: "nodeadkeys"
(**) Option "XkbOptions" "lv3:ralt_switch,keypad:legacy,altwin:super_win,eurosign:e"
(**) Keyboard0: XkbOptions: "lv3:ralt_switch,keypad:legacy,altwin:super_win,eurosign:e"
(**) Option "CustomKeycodes" "off"
(**) Keyboard0: CustomKeycodes disabled
(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
(II) Mouse0: SetupAuto: hw.iftype is 4, hw.model is 0
(II) Mouse0: SetupAuto: protocol is SysMouse
milky-wayz is offline   Reply With Quote
Old 02-12-08, 09:02 PM   #2
milky-wayz
Registered User
 
Join Date: Feb 2007
Posts: 4
Default Re: Need help with Direct Rendering (1.0-9639)

dmesg gives me this:

Code:
NVRM: API mismatch: the client has the version 1.0-9629, but
NVRM: this kernel module has the version 1.0-9639.  Please
NVRM: make sure that this kernel module and all NVIDIA driver
NVRM: components have the same version.
so i need to clean the old version, but what is the client?
milky-wayz is offline   Reply With Quote
Old 02-12-08, 10:31 PM   #3
milky-wayz
Registered User
 
Join Date: Feb 2007
Posts: 4
Default Re: Need help with Direct Rendering (1.0-9639)

Okay, i found a solution.

I have removed all nvidia libs (exspecially thos in /compat/linux//lib//usr/lib and others and make installed the driver again, even libGL where i founnd them with $locate kldunloaded the module, deleted the module. Direct Rendering is now working.
milky-wayz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
[GeForce 8800 GTS] 2D rendering regression (extreme slowdown) introduced with 295.49 Seb L. NVIDIA Linux 0 06-22-12 07:48 AM
Remote rendering???? nVIDIOT@NASA NVIDIA Linux 1 08-16-02 02:00 PM

All times are GMT -5. The time now is 09:52 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.