Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-17-08, 08:55 AM   #1
mzuckman6
Registered User
 
Join Date: Feb 2008
Posts: 3
Default FX5200 works with LCD in CRT mode, not in DFP mode

I recently purchased a HP w2207 LCD display, native display 1680x1050 @60hz

I have a video card based on the FX 5200

I am running a gentoo kernel 2.6.20-r7
I am using xorg X11.
The nvidia driver I am using is 1.0.6111.

If I omit the UseDisplayDevice DFP option in xorg.conf and use the vga cable, the display works fine.

If I try to use the DVI cable and specify UseDisplayDevice DFP in an otherwise unchanged xorg.conf, the flat panel is generally black, although it will occasional provide a brief flicker view of output.

If I interpret Xorg.0.log correctly, the driver is not finding an appropriate display mode. The default mode selected (whatever that is) apparently does not function properly.

Prior to starting X, the LCD display does produce normal output as the boot process is taking place. The display reports operating in native mode resolution and timings at that time.
The output of nvidia-bug-report is attached. Included in this report are some old logs derived from a long-ago abandoned use of XFREE86. The current log is also included.
Attached Files
File Type: gz nvidia-bug-report.log.gz (33.5 KB, 127 views)
mzuckman6 is offline   Reply With Quote
Old 02-17-08, 12:22 PM   #2
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default Re: FX5200 works with LCD in CRT mode, not in DFP mode

Your bugreport was made with CRT, not DVI, so it is not possible to derive info from it.
However, in most cases the problem you report is because of the low limit on pixelclock with DVI output on 5200 cards. The display probably requests a pixel clock that is above the limit.
You can turn of the max pixel clock check using a configuration file option:
Option "ModeValidation" "NoMaxPClkCheck"
pe1chl is offline   Reply With Quote
Old 02-18-08, 07:24 AM   #3
mzuckman6
Registered User
 
Join Date: Feb 2008
Posts: 3
Default Re: FX5200 works with LCD in CRT mode, not in DFP mode

Quote:
Originally Posted by pe1chl
Your bugreport was made with CRT, not DVI, so it is not possible to derive info from it.
However, in most cases the problem you report is because of the low limit on pixelclock with DVI output on 5200 cards. The display probably requests a pixel clock that is above the limit.
You can turn of the max pixel clock check using a configuration file option:
Option "ModeValidation" "NoMaxPClkCheck"
I'm surprised and embarassed that the bug report is for the CRT. I thought the specfication of DFP-0 with the UseDisplay.. option would select the lcd dvi mode. The Xorg.0.log that is included in the bug report seemed to indicate that configuration was attempted with the flat panel. Did I make a mistake by leaving the lcd off while starting X?

If I disable ModeValidation, don't I risk sending potentially harmful output to the lcd?

Thank you very much for the feedback.
mzuckman6 is offline   Reply With Quote
Old 02-18-08, 10:56 AM   #4
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default Re: FX5200 works with LCD in CRT mode, not in DFP mode

The debug output is about CRT-0, which is normal when that is the connected device.
Disabling this validation may be a risk for the card (the DVI output is overclocked).
When you don't want that, you probably need to replace your card with something newer.
(a DVI output with 155 MHz maximum clock)
pe1chl is offline   Reply With Quote
Old 02-18-08, 01:48 PM   #5
mooninite
Registered User
 
Join Date: May 2006
Posts: 477
Default Re: FX5200 works with LCD in CRT mode, not in DFP mode

mzuckman6, I highly recommend upgrading to the 169.09 driver. It will still work with your 5200 (I have one) but will provide slight performance increases for 2D for this already slow card.

My 5200 will not work with my DVI LCD either. I'm forced to use a RGB converter. It's a company machine, otherwise I'd be putting a more powerful card in it.
mooninite is offline   Reply With Quote
Old 02-19-08, 08:11 PM   #6
mzuckman6
Registered User
 
Join Date: Feb 2008
Posts: 3
Default Re: FX5200 works with LCD in CRT mode, not in DFP mode

Quote:
Originally Posted by mzuckman6
I'm surprised and embarassed that the bug report is for the CRT. I thought the specfication of DFP-0 with the UseDisplay.. option would select the lcd dvi mode. The Xorg.0.log that is included in the bug report seemed to indicate that configuration was attempted with the flat panel. Did I make a mistake by leaving the lcd off while starting X?

If I disable ModeValidation, don't I risk sending potentially harmful output to the lcd?

Thank you very much for the feedback.
I decided to try running the lcd with the ModeValidation option that you suggested. Disabling the Maximum Pixel clock check produces stable monitor output. I can't honestly say that the DVI output is distinctly superior to the VGA output, but then I can't really view them side by side so meaningful comparisons are difficult.
For my purposes, I'm satisfied that the lcd that I just purchased functions properly (i.e. the display problem is not caused by a monitor defect), which was one of my primary concerns. Since I really don't like the idea of demanding a piece of hardware to exceed its design specifications, I'm going to revert back to the VGA mode.
mzuckman6 is offline   Reply With Quote
Old 04-23-08, 08:23 AM   #7
faba
Registered User
 
Join Date: May 2004
Posts: 16
Default Re: FX5200 works with LCD in CRT mode, not in DFP mode

You may still use your LCD-monitor's resolution 1680x1050 with reduced blanking without exceeding FX5200's maximum pixel clock 135 MHz. Just add the following modeline option into your xorg.conf file's Monitor-section:

Code:
# cvt -r -v 1680 1050 60
# 1680x1050 59.88 Hz (CVT 1.76MA-R) hsync: 64.67 kHz; pclk: 119.00 MHz
Modeline "1680x1050R"  119.00  1680 1728 1760 1840  1050 1053 1059 1080 +hsync -vsync
and the following into Device-section:

Code:
Option "ExactModeTimingsDVI"
faba is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
320.17 can't detect video modes on Lenovo laptop tadawson NVIDIA Linux 13 07-14-12 01:40 AM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 10:46 PM
Nvidia GF4 MX 440 + Mandrake tomchristopher NVIDIA Linux 3 08-18-02 09:42 AM
nVidia drivers + Red Hat Linux 7.3 Error404 NVIDIA Linux 17 08-16-02 11:34 AM

All times are GMT -5. The time now is 05:45 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.