Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-21-08, 07:44 PM   #1
mscott
Registered User
 
Join Date: Feb 2008
Posts: 5
Angry XFX GeForce 8600 GT XXX with Fedora 8

I originally posted this to the wrong area I guess (sorry, noob here).
I didn't realize there was a forum dedicated to Linux issues and I posted to the area for my card.
=============
I am having no luck getting the proprietary drivers to work with my 8600 GT running under Fedora 8.
I have tried the drivers in Fedora, the drivers on the nVidia website and the yum method described on fedorafaq.org all with no joy.
I either get a message telling me nvidia-x11-drv conflicts with xorg-x11-drv-nvidia or the X server won't start and it defaults back to the open source nv driver with no 3D support.
Can somebody point me in the right direction?
mscott is offline   Reply With Quote
Old 02-21-08, 08:00 PM   #2
xbobmx
Registered User
 
Join Date: May 2003
Posts: 191
Default Re: XFX GeForce 8600 GT XXX with Fedora 8

http://us.download.nvidia.com/XFree8...DME/index.html
xbobmx is offline   Reply With Quote
Old 02-21-08, 08:52 PM   #3
allnamestaken
Registered User
 
Join Date: Feb 2008
Posts: 11
Default Re: XFX GeForce 8600 GT XXX with Fedora 8

run nvidia-bug-report.sh and attach the output file here. does your computer reboot or just X? What kind of motherboard chipset do you have?
allnamestaken is offline   Reply With Quote
Old 02-22-08, 06:06 PM   #4
mscott
Registered User
 
Join Date: Feb 2008
Posts: 5
Default Re: XFX GeForce 8600 GT XXX with Fedora 8

I will read the info, thanks. As for the install, as I said I have tried several different methods with different results.

The method using YUM (from FedoraFAQ) just runs the script and errors out with the final message that there is a conflict. The drivers I have tried in Fedora either give the conflict message, or I get a text screen saying that X can't start and I have to go into the configuration program with the result being it defaults back to the OSS nv driver and no 3D.

For the script, do I run that from another console when X bombs (before I run the config)?

More hardware details; the video card is an XFX GeForce 8600 GT and the mobo is an nVidia XFX nForce680i SLI (though I only have a single GPU) with an Intel Core2 Duo (E2180) 2.0GHz CPU and 2G PC6400 RAM.

Here is what I get using the YUM method (http://www.fedorafaq.org/#nvidia).
which was recommended by someone who claims it works for him:

[root@path ~]# yum install kmod-nvidia
Loading "priorities" plugin
125 packages excluded due to repository priority protections
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package kmod-nvidia.i686 0:169.09-7.lvn8 set to be updated
--> Processing Dependency: kmod-nvidia-2.6.23.15-137.fc8 = 169.09-7.lvn8
for package: kmod-nvidia
--> Running transaction check
---> Package kmod-nvidia-2.6.23.15-137.fc8.i686 0:169.09-7.lvn8 set to
be updated
--> Processing Dependency: nvidia-kmod-common >= 169.09 for package:
kmod-nvidia-2.6.23.15-137.fc8
--> Running transaction check
---> Package xorg-x11-drv-nvidia.i386 0:169.09-4.lvn8 set to be updated
--> Processing Dependency: livna-config-display for package:
xorg-x11-drv-nvidia
--> Processing Dependency: libGLcore.so.1 for package:
xorg-x11-drv-nvidia
--> Processing Dependency: /usr/lib/nvidia/libGL.so.169.09 for package:
xorg-x11-drv-nvidia
--> Processing Dependency: xorg-x11-drv-nvidia-libs = 169.09-4.lvn8 for
package: xorg-x11-drv-nvidia
--> Processing Dependency: livna-config-display for package:
xorg-x11-drv-nvidia
--> Running transaction check
---> Package livna-config-display.noarch 0:0.0.20-1.lvn8 set to be
updated
---> Package xorg-x11-drv-nvidia-libs.i386 0:169.09-4.lvn8 set to be
updated
---> Package nvidia-x11-drv.i386 0:169.07-1.fc8 set to be updated
--> Processing Dependency: dkms for package: nvidia-x11-drv
--> Running transaction check
---> Package dkms.noarch 0:2.0.17.5-1.fc8 set to be updated
--> Processing Conflict: nvidia-x11-drv conflicts xorg-x11-drv-nvidia
--> Finished Dependency Resolution
Error: nvidia-x11-drv conflicts with xorg-x11-drv-nvidia
mscott is offline   Reply With Quote
Old 02-22-08, 06:17 PM   #5
edgan
Registered User
 
Join Date: Jun 2006
Posts: 24
Default Re: XFX GeForce 8600 GT XXX with Fedora 8

Looks like you have conflicting repositories.

nvidia-x11-drv is trying to come from rpmforge
xorg-x11-drv-nvidia is trying to come from linva

yum --disablerepo=rpmforge install xorg-x11-drv-nvidia
edgan is offline   Reply With Quote
Old 02-23-08, 12:54 PM   #6
mscott
Registered User
 
Join Date: Feb 2008
Posts: 5
Default Re: XFX GeForce 8600 GT XXX with Fedora 8

Well, I get a bit farther, but end up in the same place:

[root@path ~]# yum --disablerepo=rpmforge install xorg-x11-drv-nvidia
Loading "priorities" plugin
adobe 100% |=========================| 951 B 00:00
livna 100% |=========================| 2.1 kB 00:00
fedora 100% |=========================| 2.1 kB 00:00
kde-redhat-all 100% |=========================| 951 B 00:00
kde-redhat 100% |=========================| 1.1 kB 00:00
freshrpms 100% |=========================| 2.1 kB 00:00
updates 100% |=========================| 2.3 kB 00:00
125 packages excluded due to repository priority protections
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package xorg-x11-drv-nvidia.i386 0:169.09-6.lvn8 set to be updated
--> Processing Dependency: livna-config-display for package: xorg-x11-drv-nvidia
--> Processing Dependency: nvidia-kmod >= 169.09 for package: xorg-x11-drv-nvidia
--> Processing Dependency: nvidia-kmod >= 169.09 for package: xorg-x11-drv-nvidia
--> Processing Dependency: xorg-x11-drv-nvidia-libs = 169.09-6.lvn8 for package: xorg-x11-drv-nvidia
--> Processing Dependency: livna-config-display for package: xorg-x11-drv-nvidia
--> Running transaction check
---> Package livna-config-display.noarch 0:0.0.20-1.lvn8 set to be updated
---> Package kmod-nvidia.i686 0:169.09-7.lvn8 set to be updated
--> Processing Dependency: kmod-nvidia-2.6.23.15-137.fc8 = 169.09-7.lvn8 for package: kmod-nvidia
---> Package xorg-x11-drv-nvidia-libs.i386 0:169.09-6.lvn8 set to be updated
--> Running transaction check
---> Package kmod-nvidia-2.6.23.15-137.fc8.i686 0:169.09-7.lvn8 set to be updated
--> Processing Conflict: nvidia-x11-drv conflicts xorg-x11-drv-nvidia
--> Finished Dependency Resolution
Error: nvidia-x11-drv conflicts with xorg-x11-drv-nvidia
mscott is offline   Reply With Quote
Old 02-25-08, 12:51 PM   #7
edgan
Registered User
 
Join Date: Jun 2006
Posts: 24
Default Re: XFX GeForce 8600 GT XXX with Fedora 8

I would guess you already have nvidia-x11-drv installed then. yum remove nvidia-x11-drv ; yum --disablerepo=rpmforge xorg-x11-drv-nvidia
edgan is offline   Reply With Quote
Old 02-25-08, 01:02 PM   #8
kwizart
Registered User
 
Join Date: Feb 2005
Location: Paris, France
Posts: 129
Default Re: XFX GeForce 8600 GT XXX with Fedora 8

You should not mix packages from livna with well known incompatible repositories (such as rpmforge atrpms). rpmforge would better to remains disabled and packages from it removed or replaced by the livna version...
kwizart is offline   Reply With Quote

Old 03-17-08, 06:02 AM   #9
mscott
Registered User
 
Join Date: Feb 2008
Posts: 5
Default Re: XFX GeForce 8600 GT XXX with Fedora 8

I finally did a clean install of Ubuntu 7.10.
It detected right away that there were closed-source drivers and offered to install them. I let it and everything seems to be working.
It was probably the result of me using the "kitchen sink" approach in Fedora, but I like Ubuntu better anyway.
The only thing that doesn't seem to be working now is the power save, so I have to remember to turn off the power on my LCD or it just runs the screensaver.
mscott is offline   Reply With Quote
Old 03-17-08, 11:10 AM   #10
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: XFX GeForce 8600 GT XXX with Fedora 8

Quote:
Originally Posted by mscott
The only thing that doesn't seem to be working now is the power save, so I have to remember to turn off the power on my LCD or it just runs the screensaver.
Make sure the "extmod" X module is being loaded.
AaronP is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia GeForce 301.42 WHQL drivers DSC NVIDIA Windows Graphics Drivers 5 05-29-12 10:12 PM
Enhance Max Payne 3, Diablo III with GeForce R300 Drivers News Archived News Items 0 05-22-12 06:30 PM
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 01:50 PM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 09:28 AM

All times are GMT -5. The time now is 07:22 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.