Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-23-08, 12:12 AM   #1
Floppie
Registered User
 
Join Date: Mar 2007
Posts: 15
Default Hardware-Accelerated 3D

Hey Community,

I can't seem to get hardware-accelerated 3D working. I have a 7300GS, and it seems that no matter what I do, I just can't get the thing to render 3D. glxgears gets roughly 1400FPS, but using gnome-system-monitor, I can clearly see it tying up the entirety of one of my CPUs (can provide screenshot if necessary). According to glxinfo (output attached), direct rendering is on, but the GPU simply isn't doing the rendering.

I've attached a copy of my xorg.conf, and have tried making all sorts of changes - all to no avail. I've tried enabling/disabling dri, Composite/AllowGLXWithComposite, RenderAccel (I knew disabling it wouldn't help, but figured why not try), and even simply moving the options to different sections. At one point I managed to lower my frame rate in glxgears, but it still tied up the CPU.

My xorg.conf was freshly generated with `nvidia-xconfig --no-xinerama --twinview --render-accel --render-extension --allow-glx-with-composite --composite`. Maybe I'm missing something simple - here's hoping

EDIT: Oh yeah - I've tried with both the 1.0-9762 and 169.09 driver packages. Currently running 169.09. I have both those and 100.14.19 available to install without having to download.
Attached Files
File Type: gz xorg.conf.gz (1.2 KB, 100 views)
File Type: txt glxinfo.txt (13.1 KB, 117 views)
Floppie is offline   Reply With Quote
Old 02-23-08, 06:42 AM   #2
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: Hardware-Accelerated 3D

First glxgears isn't benchmark.
Second glxgears using 100% cpu is normal.
Third glxgears 1400 fps means that the gpu does the rendering.
Try a real 3D app like ppracer. Without direct rendering it should not be playable at all.
Dragoran is offline   Reply With Quote
Old 02-23-08, 08:20 AM   #3
tx2rx
Registered User
 
Join Date: Jun 2005
Posts: 18
Default Re: Hardware-Accelerated 3D

Try running the command: glxinfo | grep direct

If you see this in the output then you have acceleration.
direct rendering: Yes
tx2rx is offline   Reply With Quote
Old 02-23-08, 09:07 AM   #4
tier
Registered User
 
Join Date: Sep 2007
Posts: 118
Default Re: Hardware-Accelerated 3D

Quote:
Originally Posted by tx2rx
Try running the command: glxinfo | grep direct

If you see this in the output then you have acceleration.
direct rendering: Yes
Read his posting again.
tier is offline   Reply With Quote
Old 02-23-08, 02:16 PM   #5
Floppie
Registered User
 
Join Date: Mar 2007
Posts: 15
Default Re: Hardware-Accelerated 3D

Quote:
Originally Posted by Dragoran
First glxgears isn't benchmark.
Second glxgears using 100% cpu is normal.
Third glxgears 1400 fps means that the gpu does the rendering.
Try a real 3D app like ppracer. Without direct rendering it should not be playable at all.
A friend of mine also runs a 7300GS - and gets 2200+ in glxgears, without tying up a heavy amount of CPU time (let alone 100%). I've tried making an exact copy of his xorg.conf, to no avail.

Just installed and tried ppracer - with the FPS counter on, I'm getting between 8 and 10 average, with default settings (minus fullscreen).
Floppie is offline   Reply With Quote
Old 02-23-08, 03:32 PM   #6
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: Hardware-Accelerated 3D

OK, can you post the output of
Code:
ldd `which glxgears`
?
Dragoran is offline   Reply With Quote
Old 02-23-08, 11:59 PM   #7
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: Hardware-Accelerated 3D

glxgears is almost completly cpu based.

It is also highly unreliable. You can't compare the glxgears fps of two systems. Even the tiniest differences (different wm, different xorg version, different driver, different cpu-governor) has HUGE impacts.

Please ignore glxgears.

And the 100% cpu load is absolutly normal.
energyman76b is offline   Reply With Quote
Old 02-26-08, 02:11 AM   #8
Floppie
Registered User
 
Join Date: Mar 2007
Posts: 15
Default Re: Hardware-Accelerated 3D

Quote:
Originally Posted by Dragoran
OK, can you post the output of
Code:
ldd `which glxgears`
?
Code:
# ldd `which glxgears`
        libGL.so.1 => /usr/lib64/libGL.so.1 (0x00002aae8addf000)
        libXext.so.6 => /usr/lib64/libXext.so.6 (0x00002aae8afad000)
        libX11.so.6 => /usr/lib64/libX11.so.6 (0x00002aae8b1be000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00002aae8b4f9000)
        libm.so.6 => /lib64/libm.so.6 (0x00002aae8b714000)
        libc.so.6 => /lib64/libc.so.6 (0x00002aae8b96a000)
        libGLcore.so.1 => /usr/lib64/libGLcore.so.1 (0x00002aae8bcad000)
        libnvidia-tls.so.1 => /usr/lib64/tls/libnvidia-tls.so.1 (0x00002aae8c865000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00002aae8c966000)
        libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6 (0x00002aae8cb6b000)
        libXau.so.6 => /usr/lib64/libXau.so.6 (0x00002aae8cd71000)
        /lib64/ld-linux-x86-64.so.2 (0x00002aae8abc1000)
Quote:
Originally Posted by energyman76b
glxgears is almost completly cpu based.

It is also highly unreliable. You can't compare the glxgears fps of two systems. Even the tiniest differences (different wm, different xorg version, different driver, different cpu-governor) has HUGE impacts.

Please ignore glxgears.

And the 100% cpu load is absolutly normal.
That's all fine and well, but it doesn't solve my problem
Floppie is offline   Reply With Quote

Old 02-26-08, 02:15 AM   #9
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: Hardware-Accelerated 3D

and your problem is?

low glxgears fps? or ppracer?

btw: the modes, really needed?

as an example, my xorg.conf:
Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
RgbPath "/usr/lib64/X11/rgb"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
Load "evdev"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "evdev"
# Driver "mouse"
Option "CorePointer"
# Option "Device" "/dev/input/mice"
# Option "Protocol" "ExplorerPS/2"
# Option "Buttons" "14"
# Option "ZAxisMapping" "4 5 6 7"
# Option "Emulate3Buttons" "true"
Option "Resolution" "800"

Option "Name" "Logitech, Inc. MX610 Laser Cordless Mouse"
Option "evBits" "+1-2"
Option "keyBits" "~272-287"
Option "relBits" "~0-2 ~6 ~8"

EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "evdev"
Option "AutoRepeat" "500 30"
Option "XkbRules" "xorg"
Option "XkbModel" "evdev"
Option "XkbLayout" "de"
Option "Device" "/dev/input/event2"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection
energyman76b is offline   Reply With Quote
Old 03-01-08, 09:18 PM   #10
Floppie
Registered User
 
Join Date: Mar 2007
Posts: 15
Default Re: Hardware-Accelerated 3D

My problem, yeah, is a low frame rate in any 3D apps I run...from Everquest, to WoW, to compiz-fusion, to ppracer - as suggested above (and, yes, glxgears).

Any 3D app I run loads the CPU up higher than it should - this makes itself obvious. And the frame rate ends up considerably lower than it should be (e.g. WoW/ppracer). Running under Windoze on this same box, I can get WoW to 60+ FPS on minimum settings, with ~70% CPU usage on one core; in Linux I get 20-30 with 85%+. Some of that could (depending on who you talk to) be attributed to kernel differences and WINE overhead, but not half the frame rate.
Floppie is offline   Reply With Quote
Old 03-02-08, 08:25 AM   #11
Tub
Registered User
 
Join Date: Nov 2006
Posts: 95
Default Re: Hardware-Accelerated 3D

you do NOT get 20 fps in WoW unless hardware acceleration is working. Your hardware acceleration is fine.

you might try disabling the composite extension and replacing compiz though, it can have quite a bit of impact on low-end cards.
Tub is offline   Reply With Quote
Old 03-02-08, 08:42 AM   #12
OsZ
Registered User
 
Join Date: Jan 2008
Posts: 19
Default Re: Hardware-Accelerated 3D

just a simple one... When I am at LAN's, UT is running slowly because I always forget to get the CPU throttle deactivated. UT is not enough pushing the CPU to run always at 100% so it keeps hanging at 1GHz and giving poor frame rates. I am on KDE using KPowersave but there must be something under gnome as well. Please make sure you are running the CPU at max speed and X without composite. Anything better then? What is with PowerMizer - also sucking down clock frequencies maybe? Try an older driver (100.14.23) maybe - anything different then?

OsZ
OsZ is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Performance Boost: troubleshooting hardware, Android toolchains, and tiny computing News Archived News Items 0 06-16-12 12:10 PM
The technologist's guide to troubleshooting hardware News Archived News Items 0 06-13-12 11:20 AM
Podcast: DDN WOS Software on OCP Storage Hardware to Enable Hyperscale Storage Clouds News Archived News Items 0 05-22-12 08:10 AM
PowerDVD Hardware Acceleration adrianhall General Software 11 06-08-10 04:46 PM
hardware T&L nosrema NVIDIA Linux 2 09-14-02 03:35 PM

All times are GMT -5. The time now is 07:35 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.