Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-24-03, 08:50 PM   #1
ziltch
Registered User
 
Join Date: Apr 2003
Posts: 14
Default I have install the driver,but None OpenGL Game Working

here is the log of Quake3:
3 1.32 linux-i386 Oct 7 2002
----- FS_Startup -----
Current search path:
/root/.q3a/baseq3
/usr/local/games/quake3/baseq3/pak8.pk3 (9 files)
/usr/local/games/quake3/baseq3/pak7.pk3 (4 files)
/usr/local/games/quake3/baseq3/pak6.pk3 (64 files)
/usr/local/games/quake3/baseq3/pak5.pk3 (7 files)
/usr/local/games/quake3/baseq3/pak4.pk3 (272 files)
/usr/local/games/quake3/baseq3/pak3.pk3 (4 files)
/usr/local/games/quake3/baseq3/pak2.pk3 (148 files)
/usr/local/games/quake3/baseq3/pak1.pk3 (26 files)
/usr/local/games/quake3/baseq3/pak0.pk3 (3539 files)
/usr/local/games/quake3/baseq3
./quake3.x86/baseq3

----------------------
4073 files in pk3 files
execing default.cfg
execing q3config.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok

------- Input Initialization -------
Joystick is not active.
------------------------------------
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 3: 640 480
Using XFree86-VidModeExtension Version 2.1
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 640x480
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Couldn't get a visual
...WARNING: could not set the given mode (3)
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
----- CL_Shutdown -----
-----------------------
Sys_Error: GLimp_Init() - could not load OpenGL subsystem
ziltch is offline   Reply With Quote
Old 04-24-03, 08:51 PM   #2
ziltch
Registered User
 
Join Date: Apr 2003
Posts: 14
Default

glxinfo Log:
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x21 16 tc 0 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x22 16 dc 0 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x23 16 tc 0 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x24 16 tc 0 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x25 16 tc 0 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x26 16 dc 0 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x27 16 dc 0 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x28 16 dc 0 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
[root@LG root]#
ziltch is offline   Reply With Quote
Old 04-24-03, 08:52 PM   #3
ziltch
Registered User
 
Join Date: Apr 2003
Posts: 14
Default

unreal LOg:
Unreal engine initialized
Bound to SDLDrv.so
Joystick [0] : Unknown Joystick
SDLClient initialized.
Bound to Render.so
Lighting subsystem initialized
Rendering initialized
LoadMap: Entry
Bound to Fire.so
Case-insensitive search: Botpack -> ..\System\BotPack.u
Bound to IpDrv.so
Game class is 'UTIntro'
Level is Level Entry.MyLevel
Bringing Level Entry.MyLevel up for play (0)...
InitGame:
Base Mutator is Entry.Mutator0
Browse: CityIntro.unr?Name=Player?Class=Botpack.TMale2?tea m=255?skin=SoldierSkins.blkt?Face=SoldierSkins.Oth ello
LoadMap: CityIntro.unr?Name=Player?Class=Botpack.TMale2?tea m=255?skin=SoldierSkins.blkt?Face=SoldierSkins.Oth ello
Case-insensitive search: genfluid -> ..\Textures\GenFluid.utx
Collecting garbage
Purging garbage
-0.0ms Unloading: Package Render
Garbage: objects: 16419->16416; refs: 224671
Game class is 'UTIntro'
Level is Level CityIntro.MyLevel
Bringing Level CityIntro.MyLevel up for play (0)...
InitGame: ?Name=Player?Class=Botpack.TMale2?team=255?skin=So ldierSkins.blkt?Face=SoldierSkins.Othello
Base Mutator is CityIntro.Mutator1
Initialized moving brush tracker for Level CityIntro.MyLevel
Created and initialized a new SDL viewport.
Bound to UWeb.so
Team 255
Login: Player
Case-insensitive search: SoldierSkins -> ..\Textures\Soldierskins.utx
Possessed PlayerPawn: TMale2 CityIntro.TMale0
Input system initialized for SDLViewport0
Opening SDL viewport.
Bound to SDLGLDrv.so
Loaded render device class.
Initializing SDLGLDrv...
binding libGL.so.1
Resizing SDL viewport. X: 640 Y: 480
OpenGL
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
appError called:
Couldn't set video mode: Couldn't find matching GLX visual

Executing UObject::StaticShutdownAfterError
Executing USDLClient::ShutdownAfterError
Executing USDLViewport::ShutdownAfterError
USDLGLRenderDevice::ShutdownAfterError
Signal: SIGIOT [iot trap]
Aborting.
Exiting.
Name subsystem shut down


----I have install the driver ,mplayer works perfect
My system :Intel C566,Via 693,256 SDRAM, Geforce 2 Ti vx
ziltch is offline   Reply With Quote
Old 04-24-03, 09:04 PM   #4
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

Which driver did you install? Did you follow the directions in the README? You're either not loading glx, or it didn't install correctly. Please look at http://www.nvnews.net/vbulletin/show...&threadid=9614 and post the requested information.

Thanks!

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 04-25-03, 09:06 PM   #5
ziltch
Registered User
 
Join Date: Apr 2003
Posts: 14
Default

I have installed 1.0-2313 1.0-3123 and 1.0-4363
Geforce 2 Ti VX (Unika 7100)
Redhat 7.2
Intel Celeron 566 oc 800
Via 693 (QDI Advance 9)
cat /proc/nv/card0
----- Driver Info -----
NVRM Version: NVIDIA NVdriver Kernel Module 1.0.2313 Tue Nov 27 12:01:24 PST 2001
Compiled with: gcc version 2.96 20000731 (Red Hat Linux 7.1 2.96-98)
------ Card Info ------
Model: GeForce2 Ti
IRQ: 11
Video BIOS: 03.15.01.06
------ AGP Info -------
AGP status: Enabled
AGP Driver: AGPGART
Bridge: Via Apollo Pro
SBA: Supported [disabled]
FW: Unsupported [disabled]
Rates: 2x 1x [2x]
Registers: 0x07000203:0x00000102
Attached Files
File Type: txt xf86config-4.txt (1.8 KB, 178 views)
ziltch is offline   Reply With Quote
Old 04-25-03, 09:07 PM   #6
ziltch
Registered User
 
Join Date: Apr 2003
Posts: 14
Default

XFree86.0.log
Attached Files
File Type: txt xfree86.0.txt (18.7 KB, 201 views)
ziltch is offline   Reply With Quote
Old 04-25-03, 09:09 PM   #7
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

Change GLX to glx.

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 04-25-03, 09:41 PM   #8
ziltch
Registered User
 
Join Date: Apr 2003
Posts: 14
Default

Quote:
Originally posted by Andy Mecham
Change GLX to glx.

--andy
yes ,i have done that
ziltch is offline   Reply With Quote

Old 04-25-03, 10:43 PM   #9
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

And... what happened? Post the X log from a try with the lowercase "glx" module loading.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 04-25-03, 10:45 PM   #10
ziltch
Registered User
 
Join Date: Apr 2003
Posts: 14
Default

it is the same as above
ziltch is offline   Reply With Quote
Old 04-25-03, 10:59 PM   #11
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

Did you install the glx package? Can you try the 1.0-4363 installer?

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 04-25-03, 11:11 PM   #12
ziltch
Registered User
 
Join Date: Apr 2003
Posts: 14
Default

the attach file is copied after installation of driver 1.0-4363

Thank you for you help.
I have tried my tnt2 m64 ,it goes well.
But this card works perfect in Windows system.
ziltch is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mageia 2 Cannot Install 71.86.15 for Riva TNT/TNT2 kbulgrien NVIDIA Linux 3 06-29-12 09:27 AM
Nvidia 302.17 OpenGL not working 6200 PCI Archmbc NVIDIA Linux 1 06-18-12 12:23 PM
Saturday Crapshoot: Quest For Glory 4 1/2 News Gaming Headlines 0 06-09-12 12:10 PM
Remastered Doom 3 BFG Edition Game Coming with Stereo 3D Support News Archived News Items 0 06-01-12 06:30 AM
Major WineX prob... I think it has to do with the vidcard... Linewbie NVIDIA Linux 20 10-09-02 10:58 PM

All times are GMT -5. The time now is 12:00 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.