Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-01-08, 02:12 AM   #1
David Marec
Registered User
 
Join Date: Nov 2006
Location: Toulouse, France
Posts: 22
Default Driver 96-43.05

Hello,

My FreeBSD box is now updated to FreeBSD 7.0.

I read on this board that a new release of the 96-x driver is available, but not from the port tree.

I began to read the instructions here : http://www.nvidia.com/object/freebsd..._96.43.05.html

But the «README» link is not correct.

I would like to know if the «compat-5x» is still required to run the driver ?
David Marec is offline   Reply With Quote
Old 03-01-08, 12:39 PM   #2
gigiita
Registered User
 
Join Date: Jan 2008
Posts: 17
Default Re: Driver 96-43.05

Yes, it is required
It seems that nVidia driver are still based on old 5.x structure....
gigiita is offline   Reply With Quote
Old 03-02-08, 01:59 AM   #3
David Marec
Registered User
 
Join Date: Nov 2006
Location: Toulouse, France
Posts: 22
Default Re: Driver 96-43.05

Quote:
Originally Posted by gigiita
Yes, it is required
It seems that nVidia driver are still based on old 5.x structure....
Actually, this new driver is not available for FreeBSD 7 branch.
David Marec is offline   Reply With Quote
Old 03-03-08, 02:14 PM   #4
gigiita
Registered User
 
Join Date: Jan 2008
Posts: 17
Default Re: Driver 96-43.05

Quote:
Originally Posted by David Marec
Actually, this new driver is not available for FreeBSD 7 branch.
Yes, but from long time ago it is possible to use any driver version under FreeBSD 7 branch (and even on 8). Simply, in case they works (and it is not always true), they use the same infrastructure as under 6 branch: compat5x is anyway required.
The new 7 branch is not so different from the older to require a completely new driver release, just some minor patch will do the work. And since it seems that nVidia is so sticky with that compatibility package, there are no reason to believe they will do a total rework of their driver
gigiita is offline   Reply With Quote
Old 03-03-08, 02:28 PM   #5
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Driver 96-43.05

The compat-5x-i386 package is required because the NVIDIA FreeBSD graphics driver's user-space components are built on a FreeBSD 5.3-RELEASE system and pick up references to that FreeBSD release's system libraries. The driver components will likely continue to be built on FreeBSD 5.3-RELEASE until FreeBSD drops backwards compatibility. That said, official FreeBSD 7.0-RELEASE support is planned for the near future.
zander is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
failing to initialize NV driver PsyShook NVIDIA Linux 10 09-19-02 12:41 PM
Nvidia Driver causes crash on Standby/Suspend dasher NVIDIA Linux 5 09-16-02 05:57 PM
new nforce driver!! 1.12!! frenchy2k1 CPUs, Motherboards And Memory 9 08-27-02 01:09 AM

All times are GMT -5. The time now is 08:29 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.