Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-12-03, 06:48 PM   #1
KarlArschus
Registered User
 
Join Date: Feb 2003
Posts: 4
Default slow 2D refresh with nvidia driver

Hi,

I'm having a nvidia driver related problem on my Debian woody installation. The driver is - as far as I know - working properly (glx is fine). I had no problem with the installation although my hardware - M1541 and TNT - is sad not to work well with the driver.

My problem is that all my applications have problems in displaying text with the speed I am used to. Scrolling through large documents (text, pdf, thatever) is slow and in some apps I can write faster than the display draws the characters (and I am not a very fast writer
Moving Windows on the screen has the same effect. Both things - scrolling and moving - need much CPU also.

Switching to the nv driver everything is normal (fast).

The card is detected correctly, no os-registry.c tweaking necessary. I tested 2880 and 3123 both with the same effect.

I tried to
- disable AGP (mode 2x is default, 1x is not working)
- using the kernel APG module

- (BIOS) disable the APG Turbo Mode
- (BIOS) disable Frame Buffer Post Write
- (BIOS) set I/O Recovery to 4 BUSCYL instead of 2

Could need some help here. Any ideas would be appreciated.

Thanks,

karl

-- now some infos that might be useful

ASUS P5A BIOS 1011 Beta 05
ASUS APG 3400 TNT/TV SDRAM BIOS 2.04.17
XFree86 4.1.0

- [ /proc/mtrr
reg00: base=0xe7000000 (3696MB), size= 16MB: write-combining, count=1
reg01: base=0xe0000000 (3584MB), size= 64MB: write-combining, count=1

- [ /proc/driver/nvidia/version
NVRM version: NVIDIA NVdriver Kernel Module 1.0-2880 Tue Mar 26 08:12:38 PST 2002
GCC version: gcc version 2.95.4 20011002 (Debian prerelease)

- [ /proc/driver/nvidia/agp/card
Fast Writes: Not Supported
SBA: Not Supported
AGP Rates: 2x 1x
Registers: 0x0f000003:0x0f000102

- [ /proc/driver/nvidia/agp/host-bridge
Host Bridge: ALi M1541
Fast Writes: Not Supported
SBA: Supported
AGP Rates: 2x 1x
Registers: 0x1c000203:0x0f000102

- [ /proc/driver/nvidia/agp/status
Status: Enabled
Driver: AGPGART
AGP Rate: 2x
Fast Writes: Disabled
SBA: Disabled

- [ /proc/driver/nvidia/cards/0
Model: RIVA TNT
IRQ: 11
Video BIOS: 02.04.17.00
Card Type: AGP
Attached Files
File Type: txt xfree86.0.log.txt (18.4 KB, 128 views)
KarlArschus is offline   Reply With Quote
Old 02-13-03, 02:30 AM   #2
f00000
Registered User
 
Join Date: Feb 2003
Posts: 3
Default

check your XF86Config-4 for RenderAccel

Option "RenderAccel" "boolean"
Enable or disable hardware acceleration of the RENDER
extension. Default: hardware acceleration of the RENDER
extension is disabled.
__________________
Help me become Immortal !!!
f00000 is offline   Reply With Quote
Old 02-13-03, 04:48 AM   #3
KarlArschus
Registered User
 
Join Date: Feb 2003
Posts: 4
Default

Since this option was introduced in 4191 I installed this one.
Thanks to this version the first init process is MUCH faster now -- compared to 2880 and 3123

However my problem still remains: the refresh is not keeping up.
Then I take a small window in front of this browser f.e. and move it really fast in small circles there are many instances of this window which are trying to keep up with top one. They are not supposed to be there, are they ?! With the nv driver everything is fine.

Any other suggestions ?
(other than taking the nv driver instead )
Attached Files
File Type: txt xfree86-nvidia-4191.0.log.txt (17.2 KB, 157 views)
KarlArschus is offline   Reply With Quote
Old 02-14-03, 09:28 AM   #4
duboiswi
Registered User
 
Join Date: Feb 2003
Posts: 1
Default same problems on tnt2 with 4191

I'm seening the same slow 2d performance with tnt2 using the
4191 driver -- 3d seems to work fine.

I also set
Option "RenderAccel" "True"

with no noticable improvement.
duboiswi is offline   Reply With Quote
Old 02-16-03, 07:19 AM   #5
KarlArschus
Registered User
 
Join Date: Feb 2003
Posts: 4
Default

I now removed the kernels agpgart-Support so nvidia has control over AGP now. nvidia disables AGP (as described in the README), which is fine with me as long as the performance is the same as with nv.
Unfortunately it isn't

Hmm, maybe the test with the small window above the browser wasn't a good example after all.
I just wonder why there is so much CPU involved when using the nvidia driver. Isn't the driver supposed to transfer graphical stuff to the card not to bother the CPU ? At least in 3d related stuff?

Here is another test:

close all desktop apps. start two console windows a 80x24.
run "top" in the fist and type "P" to sort by CPU usage.
move the second window in small circles as fast as you can.

[nv]
CPU comes up to 40 %

[nvidia with glx]
CPU comes up to 65 %

[nvidia without glx]
no difference

I think that explains my performance probs relating office/video applications ?! But why ? Is this normal ?

--
AMD K6-2 450
128MB SDRAM
KarlArschus is offline   Reply With Quote
Old 04-29-03, 05:29 AM   #6
kajoaatde
Registered User
 
Join Date: Aug 2002
Posts: 3
Default Re: slow 2D refresh with nvidia driver

Quote:
Originally posted by KarlArschus
Hi,
The card is detected correctly, no os-registry.c tweaking necessary. I tested 2880 and 3123 both with the same effect.
... did you try some older drivers from nvidia.

the 1541-version did and do *very* well for me! (ftp://download.nvidia.com/XFree86_40/1.0-1541)

Bye
Joachim
kajoaatde is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia driver quality decrease? legluondunet NVIDIA Linux 17 06-26-12 10:03 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM
NVIDIA 3123 driver on SuSE 8.0 Ok , but slow to start X Gabolander NVIDIA Linux 3 09-27-02 07:41 AM

All times are GMT -5. The time now is 06:27 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.