Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-23-03, 03:55 PM   #1
jszobody
Registered User
 
Join Date: Apr 2003
Posts: 3
Default Toshiba Satellite + Redhat 9 + nVidia Geoforce 4

Folks,

I just did a Redhat 9 install on my Toshiba Satellite 2415-S205 this week. This laptop has nVidia GeoForece4 420 graphics. Yesterday I downloaded the nVidia drivers from the nVidia website and installed them. The install process was smooth, and everything actually works... it just doesn't look all that pretty.

I can only get 800x600 resolution, it looks a bit blurry, and there is a big black strip down the right side of the screen.

After doing some Google searches, I found a webpage that suggested that I edit the os-registry.c file making the following two changes...

NVreg_SoftEDID = 0;
NVreg_Mobile = 2;

... and then compile the driver.

1. Can anyone tell me if my problem is a known issue and should I make the suggested changes and if so...
2. How do I compile the driver after making these changes

Any help is appreciated. As I'm sure you can tell, I'm kinda new to this

Joseph
jszobody is offline   Reply With Quote
Old 04-23-03, 06:10 PM   #2
jszobody
Registered User
 
Join Date: Apr 2003
Posts: 3
Default

After some more searching, I saw someone had put the following in the XF86Config file:

Option "IgnoreEDID" "1"

I tried it, it's beautiful! I still get the black strip with TuxRacer, but the desktop looks and works great.

Joseph
jszobody is offline   Reply With Quote
Old 05-10-03, 12:06 AM   #3
DWebb82
Registered User
 
Join Date: Feb 2003
Location: Arkansas
Posts: 13
Default Tux Racer Fix....

To fix tux racer to displayer properly go into your root or home directory (whichever you are running tux racer at root or user). Click on view and show hidden files. A directory should come up with something about tux. If you go into that directory their should be a config file. Open that file with an editor and go down a couple of lines. There is an X and Y axis. These are your display modes. Fill in your proper display mode and save. Then just start Tux and you won't have the black line. You must do this for all of your 3D games because the games configuration files don't know what your display settings are for some weird reason. I know this is vague somewhat, but it will work. Any questions then email me DWebb82@msn.com.


Have Fun,
David
DWebb82 is offline   Reply With Quote
Old 05-10-03, 03:39 PM   #4
jszobody
Registered User
 
Join Date: Apr 2003
Posts: 3
Default

David,

Thanks a heap. That worked perfectly.

Joseph
jszobody is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM
NVidia Drivers HowTo for RedHat 8.0 needed eduardp NVIDIA Linux 10 10-04-02 03:59 AM
Working RedHat 7.3 with Nvidia?? Be'Lal NVIDIA Linux 3 08-03-02 05:16 PM

All times are GMT -5. The time now is 08:51 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.