Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-17-08, 08:14 PM   #1
pinguin74
Registered User
 
Join Date: Aug 2007
Posts: 39
Default Composite extension crashes X server when starting kaffeine player

people who are affected by similar issue: scroll down, solution found

Since using the new driver 169.12 I experience an issue I can reproduce: when I start the kaffeine player to play a video file the whole X server crashes immediately. I have to add, it does not neceserrily happen when clicking only once on a movie file, sometimes I have to try 5 or 6 times until X crashes. But it never crashes when composite disabled.

The composite extension is enabled, when disabled this issue does not occur. I do NOT use Beryll or similar stuff, just plain KDE 3.5.7 with enabled composite.

I have attached an nVidia bug report. It also does not occur with the old driver series (100.14.x if I remember correctly)

I cannot see this behaviour with other applications, only when I start kaffeine to watch a movie.

My system:

openSUSE 10.3 (32 Bit, Athlon XP)
KDE 3.5.7
kaffeine 0.8.5
xine-lib 1.1.10.1 (the only package build on my own)
Xorg 7.2
nVidia 6200 (nv44) based ASUS AGP card

It would be nice if you could do further investigation, I don't want to drop composite extension, cause I like KDEs cool desktop effects.

thanx in advance


By the way, this issue does not seem to be new, there is a thread where folks discusses something very similar:

http://www.nvnews.net/vbulletin/show...t=kopete+crash
Attached Files
File Type: gz nvidia-bug-report.log.gz (25.6 KB, 276 views)

Last edited by pinguin74; 03-21-08 at 08:53 PM.
pinguin74 is offline   Reply With Quote
Old 03-19-08, 01:55 AM   #2
pinguin74
Registered User
 
Join Date: Aug 2007
Posts: 39
Exclamation Re: Composite extension crashes X server when starting kaffeine player

Important note: I am currently trying several things to be sure it is not a KDE or Kaffeine issue. Should this be a Kaffeine issue I will let know.
pinguin74 is offline   Reply With Quote
Old 03-19-08, 05:01 AM   #3
NvFuchs
Registered Fox
 
NvFuchs's Avatar
 
Join Date: Oct 2007
Location: Confoederatio Helvetica
Posts: 530
Default Re: Composite extension crashes X server when starting kaffeine player

kaffeine is a frontend for xine,
so try xine-ui and check if it happens there as well.

Please also try other video output plugins,
you'll find them in xine parameters in settings,
in the video tab.

Fuchs
NvFuchs is offline   Reply With Quote
Old 03-20-08, 04:29 AM   #4
pinguin74
Registered User
 
Join Date: Aug 2007
Posts: 39
Default Re: Composite extension crashes X server when starting kaffeine player

Update: solution found

I found now a solution:

Put Option "UseCompositeWrapper" "true" that was introduced with the 169.xx driver generation in the device section of your xorg.conf

So it works now fine with the 169.12 driver on my machine (GForce 6200 AGP and SiS 735 based Athlon XP machine)

Last edited by pinguin74; 04-01-08 at 04:30 AM.
pinguin74 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 02:44 PM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 07:45 AM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 09:23 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 11:16 PM
RH7.3 and nForce - can't find the module dmw400 NVIDIA Linux 4 08-05-02 01:14 PM

All times are GMT -5. The time now is 04:55 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.