Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-21-08, 03:11 PM   #1
simlan
Registered User
 
Join Date: Dec 2005
Posts: 3
Question Linux crashes when loading XOrg (GF8600 + 169.12 + 2.6.24.3)

Hello!

I recently bought an Asus EN8600GT card. I plugged it in, booted linux, started X and it crashes. I normally get a NVIDIA logo on X startup, with the new card it just crashes, and the monitor turns off.

I tried to compile the latest kernel version and reinstalled the NVIDIA driver, but the problems still remains. I turned AGP completely off in the kernel, tried to use NvAGP (it's an PCIe card though), disabled the DRI module in xorg.conf and tried a nvidia-xconfig utitlity generated xorg.conf, no change.

I cannot give any logs, because the screen just turns black and nothing works anymore, the kernel logs doesn't give any detail. By the way, the card works under Windows with TwinView enabled, everythink is fine there. Also the the old card (GF 6600) works without any issues. Under Linux, the card works with the NV driver from xorg.

Is anyone experiencing the same problem or know what to do?

NVIDIA card: EN8600GT SILENT/HTDP/512M (http://www.asus.com/products.aspx?l1...00&modelmenu=1)
NVIDIA drivers tried: Current (169.12) and my pervious version (an older one).
Kernels tried: 2.6.18, 2.6.24.3

Thanks,
Simon
simlan is offline   Reply With Quote
Old 03-21-08, 04:29 PM   #2
logan
Registered User
 
Join Date: Aug 2002
Posts: 492
Default Re: Linux crashes when loading XOrg (GF8600 + 169.12 + 2.6.24.3)

Similar problems at - http://www.nvnews.net/vbulletin/showthread.php?t=109359

BIOS updates seemed to help most of them.
logan is offline   Reply With Quote
Old 03-21-08, 06:53 PM   #3
pinguin74
Registered User
 
Join Date: Aug 2007
Posts: 39
Default Re: Linux crashes when loading XOrg (GF8600 + 169.12 + 2.6.24.3)

Quote:
Originally Posted by simlan
Hello!

I recently bought an Asus EN8600GT card. I plugged it in, booted linux, started X and it crashes. I normally get a NVIDIA logo on X startup, with the new card it just crashes, and the monitor turns off.
Hi there,

I'm also having problems (with composite extension and new nVidia driver 169.xx), ok, they are not related to yours, but in my case a downgrade of the driver has helped. Version 100.14.19 has proven to be much more stable on my machine. Do you really need the 169.xx drivers? If the older version 100.14.19 (its from Sep-2007 IIRC) supports your chip, you might give it a try.
pinguin74 is offline   Reply With Quote
Old 03-21-08, 06:56 PM   #4
logan
Registered User
 
Join Date: Aug 2002
Posts: 492
Default Re: Linux crashes when loading XOrg (GF8600 + 169.12 + 2.6.24.3)

I don't think anything before 169.xx supports the 8800GT.
logan is offline   Reply With Quote
Old 03-21-08, 08:41 PM   #5
pinguin74
Registered User
 
Join Date: Aug 2007
Posts: 39
Default Re: Linux crashes when loading XOrg (GF8600 + 169.12 + 2.6.24.3)

Quote:
Originally Posted by logan
I don't think anything before 169.xx supports the 8800GT.
Ok. And this stability issue may not be related to compositing, because his server crashes at such an early stage. Nevertheless, i now found out the new option Option "UseCompositeWrapper" "true" has solved my compositing problem. It would be nice if he could try this. Of course, this option does only make sense if compositing is enabled at all.
pinguin74 is offline   Reply With Quote
Old 03-22-08, 01:47 PM   #6
simlan
Registered User
 
Join Date: Dec 2005
Posts: 3
Default Re: Linux crashes when loading XOrg (GF8600 + 169.12 + 2.6.24.3)

Hello!

Thanks for the answers. First, it's an 8600GT card, not 8800. And I found an older driver that supports the chip (http://www.nvidia.com/object/linux_d...100.14.09.html) but it didn't work, it's just the same problem.

The problem is getting even worse. I tried switch back to the NV driver but now the X-Server crashes almost immediately, regardless of the driver (vesa, nv, nvidia) and graphics card (even with my old card). Unlike the previous problem, the system still runs, I can switch back to a console (Alt+F1). I reinstalled my linux, and X worked again with nv drivers. I installed the older nvidia drivers (mentioned above) - system crash. Tried to switch back to NV, and I have the same problem, X doesn't start anymore.

I'll try to post some logs from Xorg under w3m if I'm back in linux. Now I'm going deeper into the topic that Logan posted. I will report back with my experience.

And pinguin74, I tried to start X without compositing before. It's definitely not a compositing problem.

Cheers, Simon
simlan is offline   Reply With Quote
Old 03-23-08, 11:15 AM   #7
simlan
Registered User
 
Join Date: Dec 2005
Posts: 3
Default Re: Linux crashes when loading XOrg (GF8600 + 169.12 + 2.6.24.3)

Hello again!

I finally got it working! I'm happy! Thanks Logan and all others that helped solving this problem.

The problem is related to a combination of hardware, in my case:

* ASUS graphics card EN8600GT (also applies to 8800 cards)
* Abit AN8-Ultra mainboard with nForce 4 (also applies to older nForce versions)

and an old BIOS version. I updated the BIOS (which was a pain without floppy drive) and it just worked. Note that if you have the "even worse problem", described in my last post, you need to fix that first. I used to reinstall Linux (ten ton hammer-version of fixing problems). Get your Abit BIOS update from here: http://www.abit.com.tw/.

If you have similar problems but different hardware, you might also want to try a BIOS update first. It may help.

More information about this problem can be found here:
http://www.nvnews.net/vbulletin/showthread.php?t=109359 (it's the link Logan posted before).

Thanks,
Simon
simlan is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 02:44 PM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 11:46 PM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 09:23 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 11:16 PM
RH7.3 and nForce - can't find the module dmw400 NVIDIA Linux 4 08-05-02 01:14 PM

All times are GMT -5. The time now is 01:23 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.