Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-21-08, 09:24 PM   #1
anon.knee.mass
Registered User
 
Join Date: Mar 2008
Posts: 4
Default quadro fx 3500 ubuntu linux 3d stereo coot pymol

Hi. I am trying to get 3D stereo graphics working on my nvidia quadro fx 3500.

Previously, I tried enabling 3D stereo via the default restricted nvidia driver that ubuntu provides. That didn't work, so I decided to install the drivers from nvidia. Here's the link to my progress: http://forums.nvidia.com/index.php?showtopic=58743

Currently, I have installed the the nvidia drivers (not nvidia-glx) using the nvidia installer (http://www.nvidia.com/object/linux_d...2_169.12.html). You can look for the driver that fits your needs at http://www.nvidia.com/object/unix.html. I tried to use envy to automatically install the correct driver, but it wasn't working for some reason. So I referred to this post: http://ubuntuforums.org/showthread.php?t=57368. I followed most of the instructions with the following differences: installing the nvidia-settings application broken the nvidia driver installation. So after installing nvidia-settings, I re-installed the driver using:
sudo sh NVIDIA-"YOUR VERSION HERE".run

Also, I didn't change my xorg.conf, I just used the default the driver provided, which was:
Section "Module"
Load "glx"
Load "v4l"
EndSection


I also knew (from previous experience) to add the line "Stereo" line to the Section "Device" section:
Section "Device"
Identifier "nVidia Corporation G71GL [Quadro FX 3500]"
Driver "nvidia"
BoardName "nv"
BusID "PCI:5:0:0"
Screen 0
Option "Stereo" "0"
EndSection

However, none of this has worked. I have tried "Stereo" "1" but that doesn't seem to work either.
I get an error like this when I try to go into 3D mode:

Code:
VENDOR     : NVIDIA Corporation

CATASTROPHIC ERROR:: in gl_extras no GtkGL widget!
WARNING:: switch to hardware_stereo_mode failed
Do I have to do something with the extensions library? Do I have to enable OpenGL? Do I have to disable composite?
Am I doing something wrong? Can anyone provide some help? Thanks in advance.

update:
I found a post at http://lists.freedesktop.org/archive...ly/016919.html. Then I took a look at my /var/log/Xorg.0.log
It says that my Stereo has been disabled. Can someone tell me why?

This is the relevant part of my log:
Code:
(**) NVIDIA(0): Virtual screen size configured to be 2048 x 1536
(--) NVIDIA(0): DPI set to (79, 86); computed from "UseEdidDpi" X config
(--) NVIDIA(0):     option
(WW) NVIDIA(0): UBB is incompatible with the Composite extension.  Disabling
(WW) NVIDIA(0):     UBB.
(WW) NVIDIA(0): Stereo is incompatible with the Composite extension.
(II) NVIDIA(0): Disabling stereo.
anon.knee.mass is offline   Reply With Quote
Old 03-21-08, 10:50 PM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: quadro fx 3500 ubuntu linux 3d stereo coot pymol

Please see the forum sticky posts about how to report a problem. Check /var/log/Xorg.0.log to see why stereo is failing to initialize. Composite and stereo are not compatible with each other, so that would be a good place to start.
AaronP is offline   Reply With Quote
Old 03-25-08, 05:06 PM   #3
anon.knee.mass
Registered User
 
Join Date: Mar 2008
Posts: 4
Default Re: quadro fx 3500 ubuntu linux 3d stereo coot pymol

I don't think this is a exactly a problem with the drivers. I'm just having trouble configuring the correct settings.

edit:

I don't think it is a bug in the driver.
I assumed that I installed the command line install script correctly. (http://us.download.nvidia.com/XFree8...1.06-pkg1.run).
So I think the problem problem is that ubuntu doesn't detect the driver after driver installation. Every time I reboot, I will get the same dialogue box saying "Ubuntu is running on low graphics mode. Your screen and graphics could not be detected correctly..."

How do I configure it to see the newly installed driver?
anon.knee.mass is offline   Reply With Quote
Old 03-25-08, 08:24 PM   #4
anon.knee.mass
Registered User
 
Join Date: Mar 2008
Posts: 4
Default Re: quadro fx 3500 ubuntu linux 3d stereo coot pymol

Does reinstalling the driver break it if you reinstall it after the first install? Because the first install worked. It provided me with an nvidia-settings menu, but then I or someone else reinstalled the driver. So did it break because of that?
anon.knee.mass is offline   Reply With Quote
Old 03-28-08, 05:48 PM   #5
anon.knee.mass
Registered User
 
Join Date: Mar 2008
Posts: 4
Default Re: quadro fx 3500 ubuntu linux 3d stereo coot pymol

Okay. I was just being stupid. Install the NVIDIA driver per the instructions for your distro of linux. Then when you used the console driver installer provided by nvidia. DO NOT HAVE THE SCRIPT MAKE THE XORG.CONF FILE. you the one you edited prior to invoking the console script.

I am still stuck with the problem of not being able to render in Stereo however.

Fixed! Just add the following to xorg.conf to disable Composite:

Code:
Section "Extensions"
    Option      "Composite" "off"
EndSection
anon.knee.mass is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux gaming on the rise: EA arrives on Ubuntu and Valve plans Steam port News Gaming Headlines 0 06-15-12 04:20 PM
Best Linux driver for Quadro FX2700M dclement NVIDIA Linux 0 05-07-12 06:58 AM
Instability using Quadro FX1800 in Ubuntu 12.04 talex NVIDIA Linux 0 04-30-12 01:38 AM
_which_ quadro cards have stereo support under driver 3123 codingfrenzy NVIDIA Linux 3 12-29-02 03:24 PM

All times are GMT -5. The time now is 07:57 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.