Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-26-08, 01:24 PM   #13
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: When is something going to be done about the crashing problem!!

55, but the speed is ok. 1,6GB used of the 4gb I have
energyman76b is offline   Reply With Quote
Old 03-26-08, 03:48 PM   #14
billydv
Registered User
 
Join Date: Sep 2006
Posts: 88
Default Re: When is something going to be done about the crashing problem!!

Okay, Firstoff, I run on 2 of my boxes gentoo ~x86 and ~amd64. After having upgraded on either of those boxes to 169 or 171 drivers these problems occurred. Are there leftover libraries, I don't see how. Furthermore, I run 2 other boxes with Debian, one is amd64 the other I386, both run unstable. The results are identical on those boxes too. The message I posted about the nvidia drivers on the Fedora alpha has nothing at all to do with this. I emailed 2 bug reports when the 169 series drivers first came out and nothing, no response.
I will for the hell of it retry the 169 drivers on my gentoo ~amd64 and start posting some error messages.
billydv is offline   Reply With Quote
Old 03-26-08, 04:50 PM   #15
xorbe
Unbuffered User
 
Join Date: Jun 2005
Posts: 388
Default Re: When is something going to be done about the crashing problem!!

I am using the latest 171.06 presently, it's working "fine". I'm running recent Mandriva/Manbo cooker rpms, kernel 2.6.24.3 -- I will try that exact thing when I get home -- I thought you meant the KDE start menu button.
xorbe is offline   Reply With Quote
Old 03-26-08, 05:09 PM   #16
billydv
Registered User
 
Join Date: Sep 2006
Posts: 88
Default Re: When is something going to be done about the crashing problem!!

No, I mean the k icon in the top right corner of konqueror

here is xorg log after a crtash

(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "MetaModes" "1024x768_85 +0+0; 1024x768 +0+0; 800x600 +0+0; 640x480 +0+0"
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0): enabled.
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device PCI:3:0:0.
(EE) NVIDIA(0): Please see the COMMON PROBLEMS section in the README for
(EE) NVIDIA(0): additional information.
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
(II) UnloadModule: "nvidia"
(II) UnloadModule: "wfb"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
billydv is offline   Reply With Quote
Old 03-26-08, 06:01 PM   #17
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: When is something going to be done about the crashing problem!!

that is something else. That is not a crash, that is the log of an 'can't start X' error.
energyman76b is offline   Reply With Quote
Old 03-26-08, 07:02 PM   #18
billydv
Registered User
 
Join Date: Sep 2006
Posts: 88
Default Re: When is something going to be done about the crashing problem!!

Just to try something else, I disabled sync to vblank in both nvidia settings and compiz and instead of x dying and needing a reboot, x restarted and here is the log

Backtrace:
0: /usr/bin/X(xf86SigHandler+0x6a) [0x48e04a]
1: /lib/libc.so.6 [0x2b68106241f0]
2: /usr/lib64/xorg/modules/drivers//nvidia_drv.so(_nv000754X+0x6a) [0x2b6812c6f37a]

Fatal server error:
Caught signal 11. Server aborting
billydv is offline   Reply With Quote
Old 03-26-08, 07:06 PM   #19
billydv
Registered User
 
Join Date: Sep 2006
Posts: 88
Default Re: When is something going to be done about the crashing problem!!

Just in case someone wants to try to help me with this here is my xorg.conf, BTW, although I have overclocking enabled in xorg, I don't actually use it, I just like having it enabled and the reason for the custom edid is that sometime the computer will boot without the monitor on since its hooked up to a KVM, but disabling custom edid made no difference with regards to this problem.


Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "True"
#Option "Xinerama" "0"
EndSection

Section "Files"
FontPath "/usr/share/fonts/100dpi"
FontPath "/usr/share/fonts/75dpi"
FontPath "/usr/share/fonts/artwiz-aleczapka-en"
FontPath "/usr/share/fonts/corefonts"
FontPath "/usr/share/fonts/default/ghostscript"
FontPath "/usr/share/fonts/dejavu"
FontPath "/usr/share/fonts/liberation-fonts-ttf"
FontPath "/usr/share/fonts/misc"
FontPath "/usr/share/fonts/ttf-bitstream-vera"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/urw-fonts"
FontPath "/usr/local/share/fonts"
EndSection

Section "Module"
# Load "pcidata"
# Load "dbe"
# Load "glx"
# Load "freetype"
# Load "type1"
# Load "record"
# Load "wfb"
# Load "xtrap"
# Load "vbe"
SubSection "extmod"
Option "omit XFree86-DGA"
EndSubSection
EndSection


Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbOptions" "grp:toggle,grp_led:scroll"
Option "XkbVariant" ",winkeys"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/input/mouse0"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "IBM"
ModelName "IBM C190 CRT"
#HorizSync 30.0 - 96.0
#VertRefresh 50.0 - 160.0
#Option "Dpms" "False"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8800 GTS"
Option "CustomEDID" "CRT-0:/etc/X11/edid.bin"
Option "NoLogo" "True"
Option "Coolbits" "1"
#Option "DynamicTwinView" "False"
Option "BackingStore" "True"
Option "TripleBuffer" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "metamodes" "1024x768_85 +0+0; 1024x768 +0+0; 800x600 +0+0; 640x480 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection
billydv is offline   Reply With Quote
Old 03-26-08, 07:59 PM   #20
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: When is something going to be done about the crashing problem!!

Backtrace:
0: /usr/bin/X(xf86SigHandler+0x6a) [0x48e04a]
1: /lib/libc.so.6 [0x2b68106241f0]
2: /usr/lib64/xorg/modules/drivers//nvidia_drv.so(_nv000754X+0x6a) [0x2b6812c6f37a]

Fatal server error:
Caught signal 11. Server aborting

-----------------

does that happen on the start of X?

usually this happens when:
a) the /usr/lib64/xorg/modules/drivers//nvidia_drv.so has not the same version like the rest of the nvidia driver files.
or
b) the symlink /usr/src/linux does not point to the kernel used, when the driver module was built.

btw, your xorg.conf. Every module commented? Why? And metamodes? is that a kvm artifact?
energyman76b is offline   Reply With Quote

Old 03-27-08, 03:50 AM   #21
pawels133
Registered User
 
pawels133's Avatar
 
Join Date: Mar 2008
Posts: 201
Default Re: When is something going to be done about the crashing problem!!

s far as I know Load "glx" shouldn't be commented.
__________________
Not everybody can smoke and drink... xd
pawels133 is offline   Reply With Quote
Old 03-27-08, 06:56 AM   #22
billydv
Registered User
 
Join Date: Sep 2006
Posts: 88
Default Re: When is something going to be done about the crashing problem!!

GLX gets loaded automatically, it show in the log.
billydv is offline   Reply With Quote
Old 03-27-08, 06:59 AM   #23
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: When is something going to be done about the crashing problem!!

the log you didn't post so far.
energyman76b is offline   Reply With Quote
Old 03-27-08, 11:20 AM   #24
elanthis
Always Annoyed
 
Join Date: Oct 2002
Posts: 71
Default Re: When is something going to be done about the crashing problem!!

Quote:
why is it that this behaviour doesn't occur at all after returning to the 100.14.23 driver?
Because the older driver may not trigger the path in the buggy library that leads to the crash. Welcome to software. The actual cause of the crash can be totally unrelated to what you did that led to the crash. Happens all the ****ing time.

Or it could be, as others say, left over libraries from the old driver conflicting with the newer driver. Also happens a lot with NVIDIA's drivers since they decided to **** the existing Linux GL ecosystem and drop in custom GL libraries instead of using the ones all the other drivers use. (Which has several other negative consequences, such as being unable to have two videos cards from separate manufacturers running in the same system simultaneously.)

If you're using Gentoo and you have to ask "how could that happen," then you're not cut out for that OS. Install one that is friendlier for people who don't actually have a clue how software works at a low level, and then use the RPMs/DPKGs for that distro to install the drivers to ensure you avoid the shared-library hell NVIDIA causes.
__________________
What?
elanthis is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Powermizer problem, nvidia 9500m gs ubuntu backtoback NVIDIA Linux 3 05-25-12 12:13 PM
Post working out problem with 40.xx trying to work problem out, ONLY system specs b5fan NVIDIA Windows Graphics Drivers 11 10-19-02 09:17 AM
nv30 problem rumor bob747b Rumor Mill 37 10-10-02 03:14 PM
kswapd kernel problem and the NVdriver kwaz NVIDIA Linux 2 09-25-02 08:33 PM
Nvidia Go on laptop, black border within XFree86 problem raxip NVIDIA Linux 3 07-31-02 10:58 AM

All times are GMT -5. The time now is 09:11 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.