Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-24-08, 10:21 AM   #1
sygin
Registered User
 
Join Date: Mar 2008
Posts: 1
Default Gstreamer Totem colours wrong

Hi,

I have a nVidia GeForce 8500 GT (rev a1) video card.

When playing video the colours are incorrect, red becomes purple etc. I have attached a picture, the correct colors are on the right.

I have tried the Ubuntu 8.04 Beta restricted drivers (version 169.12) and version 169.12 from the nvidia.com site, but with no success.

I have tried turning glx off and also tried with or without compiz enabled.

If I run the open source XORG driver "nv" the problem goes away. I have also found that changing gstreamer-propeties video output to "X Window System (No xv)" fixes the problem for Totem but Kaffeine is still broken.

From my previous investigations it seems that this problem only occurs with the 8xxx cards.

Help would be appreciated.

Thanks,
Sygin

PS: Xorg.Conf

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "vmmouse"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "False"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
SubSection "Display"
Modes "1280x1024" "1152x864" "1024x768" "800x600"
EndSubSection
EndSection
Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
EndSection
Section "Module"
Load "glx"
EndSection
Attached Thumbnails
Click image for larger version

Name:	Screenshot.jpg
Views:	120
Size:	43.1 KB
ID:	30846  
Attached Files
File Type: zip nvidia-bug-report.log.zip (34.9 KB, 85 views)
sygin is offline   Reply With Quote
Old 03-24-08, 01:50 PM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Gstreamer Totem colours wrong

Hi sygin,

This is a known problem with Totem's gstreamer backend. Please see http://nvnews.net/vbulletin/showthread.php?t=107009
AaronP is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:06 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.