Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-05-08, 05:29 PM   #1
kjetilk
Registered User
 
Join Date: Apr 2008
Posts: 9
Default Problems getting Full-HD resolution with 8500 GT

Hi there!

I've recently bought a 37" LCD TV branded Elfunk 37781 FHD. It is connected through HDMI-to-DVI to a Asus EN8500GT SILENT MAGIC 512MB, which has a NVIDIA GPU GeForce 8500 GT (G86), and runs Ubuntu Gutsy installation, i.e. it is MythBuntu. Apparently, I'm using this driver:
Code:
(II) NVIDIA dlloader X Driver  100.14.19  Wed Sep 12 14:10:47 PDT 2007
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
The LCD TV was sold to me as a Full HD panel, and the documentation says clearly that it will display 720p, 1080i and 1080p through the HDMI connector.

But I'm not getting that resolution. The X logs say that

Code:
(II) NVIDIA(0): NVIDIA GPU GeForce 8500 GT (G86) at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 524288 kBytes
(--) NVIDIA(0): VideoBIOS: 60.86.39.00.00
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce 8500 GT at PCI:1:0:0:
(--) NVIDIA(0):     OEM 37'' TFT-TV (DFP-0)
(--) NVIDIA(0): OEM 37'' TFT-TV (DFP-0): 330.0 MHz maximum pixel clock
(--) NVIDIA(0): OEM 37'' TFT-TV (DFP-0): Internal Dual Link TMDS
(II) NVIDIA(0): Assigned Display Device: DFP-0
(WW) NVIDIA(0): No valid modes for "1920x1080_60"; removing.
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):     "1280x720_60"
(II) NVIDIA(0):     "720x480_60"
(II) NVIDIA(0): Virtual screen size determined to be 1280 x 720
What is going on here? Have I configured the card wrong. I have this modeline:

Code:
#       1080p           720p            480p
Modes    "1920x1080_60" "1280x720_60" "720x480_60"
I've experimented with setting "UseEDID" "FALSE" or Option "ignoreedid", thinking that EDID may not represent the resolution correctly. In either case, the resolution is then set to 640x480, IIRC. Also, I'm running on amd64, which doesn't have the edid command line tool, so I can't really tell what EDID actually says.


Maybe I'm just getting paranoid, but I've experimented with this stuff over several weeks, and can't find anything I haven't tried. So, I'm starting to suspect one of two things: Either, I'm not "allowed" to use Full HD because I'm on Linux, and thus isn't on a "trusted" platform in DRM ideology, or I've been given a panel that isn't Full HD at all.

I hope someone can shed some light on this.
kjetilk is offline   Reply With Quote
Old 04-06-08, 03:06 AM   #2
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default Re: Problems getting Full-HD resolution with 8500 GT

From the 'If you have a problem, PLEASE read this first' sticky article:
please start the X server with `startx -- -logverbose 6` and run `nvidia-bug-report.sh` after the problem has occurred.
pe1chl is offline   Reply With Quote
Old 04-06-08, 03:15 PM   #3
kjetilk
Registered User
 
Join Date: Apr 2008
Posts: 9
Default Re: Problems getting Full-HD resolution with 8500 GT

Right. It didn't occur to me, since I'm pretty sure it isn't a bug I'm looking at, but it was a truly instructive exercise. It is attached, gzipped.

So, this is what I'm seeing:

Code:
(II) NVIDIA(0):   Validating Mode "1920x1080":
(II) NVIDIA(0):     1920 x 1080 @ 60 Hz
(II) NVIDIA(0):     For use as DFP backend.
(II) NVIDIA(0):     Mode Source: EDID
(II) NVIDIA(0):        Pixel Clock      : 148.35 MHz
(II) NVIDIA(0):        HRes, HSyncStart : 1920, 2008
(II) NVIDIA(0):        HSyncEnd, HTotal : 2052, 2200
(II) NVIDIA(0):        VRes, VSyncStart : 1080, 1084
(II) NVIDIA(0):        VSyncEnd, VTotal : 1089, 1125
(II) NVIDIA(0):        H/V Polarity     : +/+
(WW) NVIDIA(0):     Mode is rejected: HorizSync (67.4 kHz) out of range
(WW) NVIDIA(0):     (15.000-46.000 kHz).
This looks like a mode I might like to use... But then it says it is rejected I don't understand what's going on here, though. EDID, in the screen, says that this mode exists, and then NVIDIA decides it is invalid because it computes the horizsync is out of range. I'm pretty sure the the horizsync range is correct, so I guess the trick is to set some parameters to get it in range. That means a more elaborate ModeLine, I guess... Anything that can help do this...?
Attached Files
File Type: gz nvidia-bug-report.log.gz (37.5 KB, 113 views)
kjetilk is offline   Reply With Quote
Old 04-06-08, 03:37 PM   #4
NvFuchs
Registered Fox
 
NvFuchs's Avatar
 
Join Date: Oct 2007
Location: Confoederatio Helvetica
Posts: 530
Default Re: Problems getting Full-HD resolution with 8500 GT

Yes, overrirde EDID Freqs.

Option "UseEdidFreqs" "false"

as described in Appendix B of the driver manual / readme.

Make sure horizontal freq and vert refresh are set
and correct _before_ adding this option to your xorg.conf
device section.

Fuchs
NvFuchs is offline   Reply With Quote
Old 04-06-08, 04:44 PM   #5
kjetilk
Registered User
 
Join Date: Apr 2008
Posts: 9
Default Re: Problems getting Full-HD resolution with 8500 GT

Hmmm, that didn't seem to have any effect, it still says that

Code:
(II) NVIDIA(0):   Validating Mode "1920x1080":
(II) NVIDIA(0):     1920 x 540 @ 60 Hz
(II) NVIDIA(0):     For use as DFP backend.
(II) NVIDIA(0):     Mode Source: EDID
(II) NVIDIA(0):        Pixel Clock      : 74.18 MHz
(II) NVIDIA(0):        HRes, HSyncStart : 1920, 2008
(II) NVIDIA(0):        HSyncEnd, HTotal : 2052, 2200
(II) NVIDIA(0):        VRes, VSyncStart :  540,  542
(II) NVIDIA(0):        VSyncEnd, VTotal :  547,  562
(II) NVIDIA(0):        H/V Polarity     : +/+
(II) NVIDIA(0):        Extra            : Interlace
(WW) NVIDIA(0):     Mode is rejected: VertRefresh (120.0 Hz) out of range
(WW) NVIDIA(0):     (49.000-61.000 Hz).
etc... any other options?
kjetilk is offline   Reply With Quote
Old 04-06-08, 05:18 PM   #6
kjetilk
Registered User
 
Join Date: Apr 2008
Posts: 9
Default Re: Problems getting Full-HD resolution with 8500 GT

I got some good help on IRC too, and it turned out that it was lying on the HorizSync, so setting that higher did the trick!
kjetilk is offline   Reply With Quote
Old 04-07-08, 03:07 AM   #7
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default Re: Problems getting Full-HD resolution with 8500 GT

Mode is rejected: VertRefresh (120.0 Hz) out of range

I think this is an issue with the older driver version that you are using. It should be resolved in the newest driver.
pe1chl is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Opinions on 1280x1024 resolution skipparoo NVIDIA GeForce 7, 8, And 9 Series 103 06-22-12 11:38 PM
Problems with configuring monitors and keeping them disabled with 302.17 Erosmith NVIDIA Linux 2 06-20-12 12:10 AM
Full HD Autosterescopic 3D Displays are Coming Soonâ?¦ Probably News Archived News Items 0 06-15-12 12:30 AM
resolution problems the fat bastid NVIDIA Linux 4 09-15-02 09:40 PM
30.82 and 40.41 resolution + monitor OSD. Max3D NVIDIA Windows Graphics Drivers 2 09-05-02 02:15 AM

All times are GMT -5. The time now is 12:48 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.