Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-27-08, 12:26 AM   #13
kenjitamura
Registered User
 
Join Date: Mar 2008
Posts: 8
Default Re: 9600 GT, WoW, WINE- low fps black screen

Well I cave lol. Going to re-install ubuntu again. I'll use kernel 2.6.23-17 because I've yet to figure out how to compile ralink driver on 2.6.24. Hopefully this will resolve the graphics issue. Wipe the disk tonight, and format/install tomorrow.
kenjitamura is offline   Reply With Quote
Old 03-27-08, 09:22 PM   #14
Sam234
Registered User
 
Join Date: Mar 2008
Posts: 2
Default Re: 9600 GT, WoW, WINE- low fps black screen

I am having the exact same issue except on an Quadro FX 2500M. I'm using the latest non-beta driver with kernel version 2.6.24.3-50.fc8 on Fedora Core 8. My glxgears only shows 2500 fps windowed. My son's computer is running Ubuntu with a GeForce 4 and get's 2600 in glxgears and his wow runs great. I was getting around 20000 fps in glxgears until I ran all the system updates. Somewhere down the line it broke. Glxinfo shows that I'm running direct rendering. The only thing I can think of is this. The driver readme says this:

If the libraries appear to be correct, then verify that the application is using the correct libraries. For example, to check that the application /usr/X11R6/bin/glxgears is using the NVIDIA libraries, run:

% ldd /usr/X11R6/bin/glxgears
linux-gate.so.1 => (0xffffe000)
libGL.so.1 => /usr/lib/libGL.so.1 (0xb7ed3000)
libXp.so.6 => /usr/lib/libXp.so.6 (0xb7eca000)
libXext.so.6 => /usr/lib/libXext.so.6 (0xb7eb9000)
libX11.so.6 => /usr/lib/libX11.so.6 (0xb7dd4000)
libpthread.so.0 => /lib/libpthread.so.0 (0xb7d82000)
libm.so.6 => /lib/libm.so.6 (0xb7d5f000)
libc.so.6 => /lib/libc.so.6 (0xb7c47000)
libGLcore.so.1 => /usr/lib/libGLcore.so.1 (0xb6c2f000)
libnvidia-tls.so.1 => /usr/lib/tls/libnvidia-tls.so.1 (0xb6c2d000)
libdl.so.2 => /lib/libdl.so.2 (0xb6c29000)
/lib/ld-linux.so.2 (0xb7fb2000)

Now if I run that command I get this:

[Sam@localhost ~]$ ldd /usr/bin/glxgears
linux-gate.so.1 => (0x00110000)
libGL.so.1 => /usr/lib/libGL.so.1 (0x00111000)
libc.so.6 => /lib/libc.so.6 (0x00aa9000)
libX11.so.6 => /usr/lib/libX11.so.6 (0x00c6b000)
libGLcore.so.1 => /usr/lib/libGLcore.so.1 (0x00d67000)
libnvidia-tls.so.1 => /usr/lib/tls/libnvidia-tls.so.1 (0x001b5000)
libm.so.6 => /lib/libm.so.6 (0x00c04000)
libXext.so.6 => /usr/lib/libXext.so.6 (0x001b7000)
libdl.so.2 => /lib/libdl.so.2 (0x00c2f000)
/lib/ld-linux.so.2 (0x00a86000)
libxcb-xlib.so.0 => /usr/lib/libxcb-xlib.so.0 (0x001c7000)
libxcb.so.1 => /usr/lib/libxcb.so.1 (0x001c9000)
libXau.so.6 => /usr/lib/libXau.so.6 (0x00c66000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x001e5000)

Now do the hex values at the end matter? As far as I can tell the libraries are jacked up and causing all of our issues. Can someone please take a look at this that has a better understanding of libGL than myself? I would greatly appreciate it.
Sam234 is offline   Reply With Quote
Old 03-31-08, 02:08 PM   #15
Sam234
Registered User
 
Join Date: Mar 2008
Posts: 2
Default Re: 9600 GT, WoW, WINE- low fps black screen

/bump

Anyone? Please? Pretty please?

Update: I installed Ubuntu and did all the updates. WoW runs great with an fps over 160 sometimes and Quake4 runs great 1920x1280 on ultra settings. But why does it work so well in Ubuntu using the restricted driver than Fedora does using the latest nvidia driver? Just doesn't make any sense...
Sam234 is offline   Reply With Quote
Old 04-03-08, 10:54 AM   #16
tec-buck
Registered User
 
Join Date: Mar 2007
Posts: 17
Default Re: 9600 GT, WoW, WINE- low fps black screen

You may want to play with the registry in wine. I had two 7600 gt's working fine then upgraded to 8800 gt's which resulted in a few problems that were addressed by changing some values in the wine registry. See http://wiki.winehq.org/UsefulRegistryKeys for more information. After I changed GLSL to disabled from enabled, my problems (slow video, low fps, anomlies during game play) were corrected.
Good luck
tec-buck is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
GT240M - black screen with newer drivers > 275.33 and win 7 doktor5000 NVIDIA GeForce 200 Series 1 07-08-12 12:17 PM
[9800gt] Xorg black screen after installing nvidia driver HacKurx NVIDIA Linux 1 06-07-12 02:29 PM
Black screen after switching between graphical virtual consoles five times rrr-wtf NVIDIA Linux 1 05-21-12 05:40 PM
Black screen and lockup on startx. redmoose NVIDIA Linux 4 09-18-02 12:53 PM
kernel 2.4.19 and 2960 -> black screen osterhase NVIDIA Linux 7 08-22-02 07:24 PM

All times are GMT -5. The time now is 11:58 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.