Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-31-08, 02:32 AM   #1
alex1020
Registered User
 
Join Date: Mar 2008
Posts: 11
Unhappy Poor 2D performance with 8600gt

I have very poor 2D performance with 8600GT ,movies are showing slow motion , menus are opening slow , xorg has very high cpu usage & .....

GTKPerf with 100 rounds :
Code:
GtkPerf 0.40 - Starting testing: Sat Mar 22 19:48:28 2008

GtkEntry - time:  0.05
GtkComboBox - time:  4.34
GtkComboBoxEntry - time:  2.24
GtkSpinButton - time:  1.33
GtkProgressBar - time:  9.34
GtkToggleButton - time:  2.54
GtkCheckButton - time:  1.03
GtkRadioButton - time:  0.80
GtkTextView - Add text - time:  1.79
GtkTextView - Scroll - time:  0.47
GtkDrawingArea - Lines - time:  0.41
GtkDrawingArea - Circles - time:  1.53
GtkDrawingArea - Text - time:  0.55
GtkDrawingArea - Pixbufs - time:  0.75
 --- 
Total time: 27.14
I attached xorg.conf and nvidia-bug-report.log


thanks
Attached Files
File Type: gz xorg.conf.tar.gz (832 Bytes, 93 views)
File Type: gz nvidia-bug-report.log.tar.gz (29.7 KB, 101 views)
alex1020 is offline   Reply With Quote
Old 03-31-08, 10:43 AM   #2
txf
Registered User
 
Join Date: Feb 2008
Posts: 272
Default Re: Poor 2D performance with 8600gt

There are plenty of other posts on the forum complaining of the same thing...not much you can do about it now.

try:
Code:
nvidia-settings -a InitialPixmapPlacement=2
It may help a little bit in some cases (opposite effect in others, depends on your usage). You could also change your gtk engine to a lighter on (dunno if you already do but engines like Murrine are much slower than say...clearlooks).

As for movies, they should not b slow. Are you watching them with xv enabled or high-def h.264?

How high is your xorg cpu usage?

Nvidia really needs to fix this...its only going to get worse as themes get richer and more dependent on render. I believe this slowness will also extend to the 9 series, anyone care to rebut?
txf is offline   Reply With Quote
Old 03-31-08, 11:45 AM   #3
alex1020
Registered User
 
Join Date: Mar 2008
Posts: 11
Default Re: Poor 2D performance with 8600gt

Quote:
Originally Posted by txf
There are plenty of other posts on the forum complaining of the same thing...not much you can do about it now.

try:
Code:
nvidia-settings -a InitialPixmapPlacement=2
It may help a little bit in some cases (opposite effect in others, depends on your usage). You could also change your gtk engine to a lighter on (dunno if you already do but engines like Murrine are much slower than say...clearlooks).

As for movies, they should not b slow. Are you watching them with xv enabled or high-def h.264?

How high is your xorg cpu usage?

Nvidia really needs to fix this...its only going to get worse as themes get richer and more dependent on render. I believe this slowness will also extend to the 9 series, anyone care to rebut?
Thanks
what does InitialPixmapPlacement do ?
now I am using clearlooks engine and overall 2D performance is a lot better ! especially working with menus and browsing web sites. But still performance is poor

My friend is using an onboard graphic card ( Intel chipset ) and his computer performance (2d) is a lot better than me !

could you please testing following link :
http://www.break.com/index/driver-cr...recks-car.html
its a flash movie ( like youtube) try to watch it in fullscreen , with my friend computer its showing fine ! ( my friend's computer's cpu is just a AMD 3000 but mine is Intel Q6600!) but with my computer its showing slow motion ! and xorg is using 100% cpu usage

For movies I am using NV ( I tried other video drivers but they aren't better ) when there is a fast action its a bit slow , ( like old graphic cards ) and its annoying

I have only 2 choices , saying byebye to Linux and using f**** windows and changing graphic card !
I heard Nvidia 7series have better support and performance in linux , is this true ?
I am not a gamer and I need to have a good 2D performance on dual display .


I hope Nvidia do something for linux users
alex1020 is offline   Reply With Quote
Old 03-31-08, 01:26 PM   #4
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: Poor 2D performance with 8600gt

first of all, please don't pack the logs.

second. This looks not nice:
16: 35583 35425 35535 35443 IO-APIC-fasteoi uhci_hcd:usb1, uhci_hcd:usb6, ahci, nvidia

great, the driver shares its interrupt with almost everybody else. A different kernel might help

third, try enabling backingstore.

fourth, you are using a 32bit kernel. This slows down memory acess A LOT if you have more than 1gb of ram.
Try a 64bit system.

fifth, gtk is slow.

sixth, nvidia-settings -a InitialPixmapPlacement=2 -a GlyphCache=1
energyman76b is offline   Reply With Quote
Old 03-31-08, 01:27 PM   #5
Linuxhippy
Registered User
 
Join Date: Feb 2004
Posts: 585
Default Re: Poor 2D performance with 8600gt

well, probably your best bet is to buy a mainboard with intel-chipset.
Intel's drivery are currently the best thing you can get for fast 2D.

lg Clemens
Linuxhippy is offline   Reply With Quote
Old 03-31-08, 02:53 PM   #6
txf
Registered User
 
Join Date: Feb 2008
Posts: 272
Default Re: Poor 2D performance with 8600gt

seventh , flash is terrible under linux (it maxes out one of my cores) and they have the same freq as yours 2.4Ghz. You shouldn't be getting 100% cpu usage tho.

As for general slowness of gtk, you could consider using kde instead of gnome (unless of course you don't like it).

try ubuntu 64 bit it works fine for me. My system works alright but 2d still sucks but it is usable.
txf is offline   Reply With Quote
Old 03-31-08, 03:48 PM   #7
alex1020
Registered User
 
Join Date: Mar 2008
Posts: 11
Thumbs up Re: Poor 2D performance with 8600gt

Quote:
Originally Posted by energyman76b
first of all, please don't pack the logs.
I did because it was a rule:
http://www.nvnews.net/vbulletin/showthread.php?t=46678
Quote:
Please note: if nvidia-bug-report.log, nvidia-installer.log and/or any other log/support files are too large to be attached to nV News forum posts as-is, you can create and attach .bz2 or .gz archives, instead.
anyway I've uploaded them in another place

xorg.conf
http://pastebin.com/m3ef22ecc

nvidia-bug-report.log
http://pastebin.com/m647618b6

Quote:
second. This looks not nice:
16: 35583 35425 35535 35443 IO-APIC-fasteoi uhci_hcd:usb1, uhci_hcd:usb6, ahci, nvidia
eat, the driver shares its interrupt with almost everybody else. A different kernel might help
hmmz
but I've tested both ubuntu kernels (2.4.22 & 2.4.24) and kernel.org kernel and I had same result with all of them !
Do you need .config of kernel ?

Quote:
third, try enabling backingstore.
ok I will test it , what about following options ?

Code:
Option "RenderAccel" "True" 
Option "DamageEvents" "True"
Option "TripleBuffer" "True"
Quote:
fourth, you are using a 32bit kernel. This slows down memory acess A LOT if you have more than 1gb of ram.
Try a 64bit system.
I've 2GB of ram and my CPU is Q6600 , I heard there are a lot of applications/packages that they have problem in 64bit system and some of them don't have 64bit support

Quote:
fifth, gtk is slow.
yes , and sometimes it over 20-30s !

Quote:
sixth, nvidia-settings -a InitialPixmapPlacement=2 -a GlyphCache=1
Code:
#nvidia-settings -a InitialPixmapPlacement=2 -a GlyphCache=1

  Attribute 'InitialPixmapPlacement' (artin:0.0) assigned value 2.


ERROR: Error parsing assignment 'GlyphCache=1' (Unrecognized attribute name).
---

Thank you for taking time and answering to me patiently
alex1020 is offline   Reply With Quote
Old 03-31-08, 03:51 PM   #8
alex1020
Registered User
 
Join Date: Mar 2008
Posts: 11
Default Re: Poor 2D performance with 8600gt

Quote:
Originally Posted by txf
seventh , flash is terrible under linux (it maxes out one of my cores) and they have the same freq as yours 2.4Ghz. You shouldn't be getting 100% cpu usage tho.

As for general slowness of gtk, you could consider using kde instead of gnome (unless of course you don't like it).

try ubuntu 64 bit it works fine for me. My system works alright but 2d still sucks but it is usable.
what is your graphic card and nvidia version ? Do you have same problems ?

Quote:
Originally Posted by Linuxhippy
well, probably your best bet is to buy a mainboard with intel-chipset.
Intel's drivery are currently the best thing you can get for fast 2D.

lg Clemens
it will be my last choice
alex1020 is offline   Reply With Quote

Old 03-31-08, 04:42 PM   #9
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: Poor 2D performance with 8600gt

Quote:
Originally Posted by alex1020
I did because it was a rule:
http://www.nvnews.net/vbulletin/showthread.php?t=46678

anyway I've uploaded them in another place
the rule was about files too big - and only gzipping them, not tar

Quote:
Originally Posted by alex1020
pastebin is not such a great choice - because they delete after a while - the stuff you already attached was good enough.

Quote:
Originally Posted by alex1020
hmmz
but I've tested both ubuntu kernels (2.4.22 & 2.4.24) and kernel.org kernel and I had same result with all of them !
Do you need .config of kernel ?
no need for that. Really. Maybe a different kernel would change something, but most probably not. It is not that important anyway. Just.. sad that with so many interrupts available, some boards still mash everything together

Quote:
Originally Posted by alex1020
ok I will test it , what about following options ?

Code:
Option "RenderAccel" "True" 
Option "DamageEvents" "True"
Option "TripleBuffer" "True"
I like them.

Quote:
Originally Posted by alex1020
I've 2GB of ram and my CPU is Q6600 , I heard there are a lot of applications/packages that they have problem in 64bit system and some of them don't have 64bit support
a well set up 64bit system can use 32bit apps without problems. I have a 64bit system, and 32bit openoffice works without problems. Flash works too. And those two are almost the only problematic ones ....



Quote:
Originally Posted by alex1020
Code:
#nvidia-settings -a InitialPixmapPlacement=2 -a GlyphCache=1

  Attribute 'InitialPixmapPlacement' (artin:0.0) assigned value 2.


ERROR: Error parsing assignment 'GlyphCache=1' (Unrecognized attribute name).
---

Thank you for taking time and answering to me patiently
you need to install latest drivers. I am sorry not to catch that. Please install the 171 drivers - they should be faster with 2d.
energyman76b is offline   Reply With Quote
Old 03-31-08, 04:56 PM   #10
alex1020
Registered User
 
Join Date: Mar 2008
Posts: 11
Default Re: Poor 2D performance with 8600gt

I've tested all nvidia drivers (100.xx 169.xx 171.xx ) 171 was the worst ! maybe because its beta ?
//
I've added all those options to my xorg.conf but I cant see any noticeable difference
//
ok I will test the 64bit system and will post the result here
//

I don't know why firefox is eating 90-100% of cpu usage when I am in this forum , maybe its because of top flash banner ?
//

alex1020 is offline   Reply With Quote
Old 03-31-08, 05:00 PM   #11
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: Poor 2D performance with 8600gt

000 24865 4.1 0.2 132860 9828 ? R 22:59 0:01 /usr/kde/3.5/bin/nspluginviewer -dcopid nspluginviewer-24856
1000 24881 5.9 0.3 65392 13692 ? Sl 22:59 0:02 /usr/lib64/nspluginwrapper/i386/linux/npviewer.bin --plugin /usr/lib32/nsbrowser/pl
energyman76b is offline   Reply With Quote
Old 03-31-08, 05:33 PM   #12
txf
Registered User
 
Join Date: Feb 2008
Posts: 272
Default Re: Poor 2D performance with 8600gt

Quote:
Originally Posted by alex1020
I've tested all nvidia drivers (100.xx 169.xx 171.xx ) 171 was the worst ! maybe because its beta ?

I've added all those options to my xorg.conf but I cant see any noticeable difference

I don't know why firefox is eating 90-100% of cpu usage when I am in this forum , maybe its because of top flash banner ?

1. xorg in ubuntu already has the most important options enabled by default so adding them to xorg.conf won't really make a difference for most situations

2. Get Adblock plus ff extension and kill those flash banners...kill them dead!

btw my laptop is a C2D 2.4Ghz and my gfx card is an 8600m GT, so for most (esp single threaded) cases its the same speed
txf is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disk Performance Expectations vs. Reality News Archived News Items 0 05-27-12 04:00 PM
Boost Your Performance Goals 10x ' This Week on inside* Publications News Archived News Items 0 05-13-12 06:20 PM
NVIDIA Unleashes the GeForce GTX 670 Graphics Card ' Performance Perfected (WCCFTECH) News GeForce GTX 670 Reviews 0 05-10-12 09:40 AM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-31-02 12:59 AM
so let's try this again in the new forum - bad performance with correctly inst.driver neutrino NVIDIA Linux 11 08-01-02 05:19 PM

All times are GMT -5. The time now is 02:03 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.