Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-01-03, 07:23 PM   #1
fearofcarpet
Registered User
 
Join Date: May 2003
Posts: 5
Angry 100% CPU Utilization isntead of OpenGL on AthlonXP2100+

I figure I'll just post my problem then attach whatever files/outputs are needed...

I recently swapped my Celery out for an ASUS A7V333 & AthlonXP2100+ (and left Linux as is). I was running RedHat 9, kernel-2.4.20-9.athlon and the latest NVidia driver (4363) on my GF2MX. Everything was happy until the switch, at which point all my OpenGL apps pegged the CPU at 100% and gave slow, crappy graphics. I later upgraded to a GF4 Ti4200- same problem. I have reinstalled Mesa, the NVidia driver, qt, ran through all the OpenGL troubleshooting in the NVidia manual... I don't know what else to try, or even where to look for a problem!

FYI I installed the athlon version of the RH9 kernel because the x86's crash so I haven't been able to see if the i686 kernel (which I was using with the Celery) has the same problem. Me wantie fast fast 3D back!
fearofcarpet is offline   Reply With Quote
Old 05-01-03, 07:47 PM   #2
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

Please read http://www.nvnews.net/vbulletin/show...&threadid=9614 and post the requested information.

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 05-01-03, 08:28 PM   #3
Soul-Crusher
Leadtek 6800GT
 
Join Date: Aug 2002
Location: Albuquerque, NM, USA
Posts: 195
Send a message via ICQ to Soul-Crusher Send a message via AIM to Soul-Crusher Send a message via Yahoo to Soul-Crusher
Default

Uninstall Mesa. Install nVidia's package and leave it at that. Mesa is software OpenGL and will definitely peg your CPU.

If you're using agpgart, you may also need to edit your kernel config and make sure you're using the right AGP driver (Under "character devices").
__________________
"Floating in a dream-like state, I am the emporer of a parallel universe." --Arch Enemy
My xorg.conf file
Soul-Crusher is offline   Reply With Quote
Old 05-02-03, 08:24 AM   #4
fearofcarpet
Registered User
 
Join Date: May 2003
Posts: 5
Default Info

Ok, here is that info.
____

Model: GeForce4 Ti 4200 with AGP8X
IRQ: 11
Video BIOS: 04.28.20.05.24
Card Type: AGP

_____
XFree86 log/Config are included in a single text file.
Attached Files
File Type: txt xf86config_xfree86log.txt (43.1 KB, 102 views)
fearofcarpet is offline   Reply With Quote
Old 05-02-03, 08:41 AM   #5
fearofcarpet
Registered User
 
Join Date: May 2003
Posts: 5
Default Mesa

Ok, Mesa is gone and I reinstalled the NVidia driver, but the problem remains. Thanks for the suggestion though; I will leave it uninstalled.

Perhaps this belongs in another forum, but I was looking into the agpgart.o thing and found this in /usr/include/linux/autoconf.h-- "#error Invalid kernel header included in userspace"

Last edited by fearofcarpet; 05-02-03 at 09:21 AM.
fearofcarpet is offline   Reply With Quote
Old 05-02-03, 12:42 PM   #6
fearofcarpet
Registered User
 
Join Date: May 2003
Posts: 5
Default Fixed it...

Clean reinstall of RH9 fixed the problem.
fearofcarpet is offline   Reply With Quote
Old 05-03-03, 12:45 AM   #7
Soul-Crusher
Leadtek 6800GT
 
Join Date: Aug 2002
Location: Albuquerque, NM, USA
Posts: 195
Send a message via ICQ to Soul-Crusher Send a message via AIM to Soul-Crusher Send a message via Yahoo to Soul-Crusher
Default

Sorry it came to that. It looks like you needed to install the kernel header RPMs. I assume in your new installation, you enabled all the 'development' packages, correct? If so, I believe this is what solved your problem.
__________________
"Floating in a dream-like state, I am the emporer of a parallel universe." --Arch Enemy
My xorg.conf file
Soul-Crusher is offline   Reply With Quote
Old 05-05-03, 02:43 PM   #8
fearofcarpet
Registered User
 
Join Date: May 2003
Posts: 5
Default

Actaully, after dealing with Windows, I find Linux clean installs to be no trouble.

I did in fact have the kernel headers installed before. I even uninstalled/reinstalled the RPM packages... Something was messed up though, because my computer was telling the RedHat Network it wanted i386 packages, but after the reinstall (where athlon packages were installed from the get go) it requested the correct architecture.

At any rate, thanks for everyone's input, my new GF4 is running famously.
fearofcarpet is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Maintain Your Privacy by Manually Accepting and Rejecting "Cookies" (nV News) MikeC Open Forum 2 02-02-13 07:15 PM

All times are GMT -5. The time now is 02:43 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.