Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-06-08, 02:13 PM   #1
almora99
Registered User
 
Join Date: Apr 2008
Posts: 3
Default So interesting problem with 8400M G on acer 5520G

Hi everybody.
I have an interesting problem with my nvidia card.

With 169.12 driver ;
when graphic card working at performance level 0,
My X server freezes if I try to move a window or open a divx in GNOME.
(Only X freezes with losing keyboard control, system goes properly.)
(System is not aware of this freezes, no log, no kernel messages...)

But if graphic card works at performance level 1 or 2, no any problem.

"Nvidia X server settings" from "applications->System tools" menu in gnome desktop shows this performance levels and related frequency values:

performance level 0: 169MHz GPU / 100MHz Memory
performance level 1: 275MHz GPU / 200MHz Memory
performance level 2: 400MHz GPU / 400MHz Memory

Is performance level 0 (169MHz/100MHz) too slow for system stability?
Which one is controlling this values? "Nvidia's BIOS" or "nvidia's DRIVER" ?
Should I update nvidia card's Bios?
What should I do about this problem?

My card is "nvidia 8400M G"
My laptop is "Acer 5520G"
I'm using Fedora 8 and its up to date.
A detailed description of my problem is here: http://www.linuxquestions.org/questi...r-5520-630877/

Please write your suggestions...
almora99 is offline   Reply With Quote
Old 04-06-08, 02:39 PM   #2
shaundennie
Registered User
 
Join Date: Nov 2006
Posts: 79
Default Re: So interesting problem with 8400M G on acer 5520G

GPU frequency scaling isn't always very stable on laptops. There are various ways to force the card to maximum power and I think that searching this message board for PerfLevelSrc should give you the information you need to fix your problem.
shaundennie is offline   Reply With Quote
Old 04-08-08, 08:54 AM   #3
almora99
Registered User
 
Join Date: Apr 2008
Posts: 3
Default Re: So interesting problem with 8400M G on acer 5520G

Thanks for reply.

Yes... Adding modprobe.conf
options nvidia NVreg_RegistryDwords="PerfLevelSrc=0x2222"
worked for me. But card works at Performance level 2 (full power) always.

Can I assign different values to "PerfLeverSrc" parameter to make my card work only level 1 or level 2 (I want to disable only level 0) I couldn't find any info about logic of "0x2222". Do you know any?
almora99 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:09 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.