Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-08-08, 10:40 AM   #1
mavidako
Registered User
 
Join Date: Apr 2008
Posts: 6
Default 8800GT on openSUSE 10.3 64bit

Hi!
I'm new one in Linux world so please don't laugh!

I done Online Update (so i think that i done a Kernel-Update, if not please tell me)
I tried to install Nvidia drivers for this system but I couldn't.
I fallow "SuSE NVIDIA Installer HOWTO" and I done a YaST part and nothing happend. He still said to me in SAX2 that 3D acceleration not supported.
I even tried to install it over root and init 3 but i didn't sucess because first time he said that i don't have "gcc" and when i installed it he said some other problems.

I read in some posts that i need "to configure the X server using nvidia-xconfig or by editing the file /etc/X11/xorg.conf manually" and i don't know how to do that and what to do or write manually!!


Please help!!!!

Thank You
mavidako is offline   Reply With Quote
Old 04-08-08, 11:05 AM   #2
tec-buck
Registered User
 
Join Date: Mar 2007
Posts: 17
Default Re: 8800GT on openSUSE 10.3 64bit

I've never used SuSE so I can't help much with the driver installation issue. As far the xconfig goes, the simples way would be to type this into a shell 'sudo nvidia-xconfig'. (If you don't have sudo working, then su to root and just type 'nvidia-xconfig') Typicaly I would see three lines with saying something to the effect that the the xorg file was updated and a backup was made. If not then the driver is not installed. And you always need to restart the xserver after any change to the file. This can be done with Alt-Ctrl-Backspace.
Before you do this, make a backup of the xorg file. As root or with sudo, 1) 'cd /etc/X11/', 2) 'cp Xorg.conf Xorg.conf.911backup'.
Now if you find that you can no long boot to a graphical interface, you can 'cp Xorg.conf.911backup Xorg.conf' and 'startx'.
Hope this helps and good luck.
tec-buck is offline   Reply With Quote
Old 04-08-08, 11:08 AM   #3
NvFuchs
Registered Fox
 
NvFuchs's Avatar
 
Join Date: Oct 2007
Location: Confoederatio Helvetica
Posts: 530
Default Re: 8800GT on openSUSE 10.3 64bit

Open the file /etc/X11/xorg.conf as root with your preferred editor,
and change the line

Driver "nv"

to

Driver "nvidia"

Don't install it by hand. But I recommend you install
gcc and other development tools anyway.
NvFuchs is offline   Reply With Quote
Old 04-08-08, 11:29 AM   #4
mavidako
Registered User
 
Join Date: Apr 2008
Posts: 6
Default Re: 8800GT on openSUSE 10.3 64bit

Thank you!
Graphic changed, but still can't enter SAX2 without warning "3D acceleration not supported"?
mavidako is offline   Reply With Quote
Old 04-08-08, 11:38 AM   #5
NvFuchs
Registered Fox
 
NvFuchs's Avatar
 
Join Date: Oct 2007
Location: Confoederatio Helvetica
Posts: 530
Default Re: 8800GT on openSUSE 10.3 64bit

if glxinfo tells you that nvidia is in use
and glxgears runs fine:

Just don't care what SAX says, in my opinion
it is a horrible tool anyway.

Fuchs
NvFuchs is offline   Reply With Quote
Old 04-08-08, 11:48 AM   #6
mavidako
Registered User
 
Join Date: Apr 2008
Posts: 6
Default Re: 8800GT on openSUSE 10.3 64bit

Quote:
Originally Posted by NvFuchs
if glxinfo tells you that nvidia is in use
and glxgears runs fine:

Fuchs
Hmm whatever it is !
I'm using linux for the first time in my life and i'm working on it for about 2 days !

So how do i change a resolution and stuff like that? over xconfig?
mavidako is offline   Reply With Quote
Old 04-08-08, 11:50 AM   #7
NvFuchs
Registered Fox
 
NvFuchs's Avatar
 
Join Date: Oct 2007
Location: Confoederatio Helvetica
Posts: 530
Default Re: 8800GT on openSUSE 10.3 64bit

I recommend using nvidia-settings
for settings like screen-resolution and stuff.


Both glxinfo and glxgears are commands
which are best run from a terminal emulation.

If you are using KDE: run konsole,
enter those two commands.
The first one should provide you with information about OpenGL/GLX,
the second should open a new window with rotating gears.

If you are using Gnome: run gnome-terminal,
proceed as described above.

If you run anything else: run a terminal like xterm.
NvFuchs is offline   Reply With Quote
Old 04-08-08, 11:56 AM   #8
txf
Registered User
 
Join Date: Feb 2008
Posts: 272
Default Re: 8800GT on openSUSE 10.3 64bit

Quote:
Originally Posted by mavidako
Graphic changed, but still can't enter SAX2 without warning "3D acceleration not supported"?
I don't think sax2 (as the yast applet) works with the nvidia driver, If you want to change settings use nvidia-settings..yup its already been said
txf is offline   Reply With Quote

Old 04-08-08, 12:06 PM   #9
mavidako
Registered User
 
Join Date: Apr 2008
Posts: 6
Default Re: 8800GT on openSUSE 10.3 64bit

Thak you, thank you, thank you guys!!
Everything works fine!

Next step is "how to copy files from suse to NTFS windows partition", but this is not for nvidia forum i think, but if you know...

Thanks again a lot for informations and help...

Greetings from Croatia
mavidako is offline   Reply With Quote
Old 04-08-08, 12:18 PM   #10
NvFuchs
Registered Fox
 
NvFuchs's Avatar
 
Join Date: Oct 2007
Location: Confoederatio Helvetica
Posts: 530
Default Re: 8800GT on openSUSE 10.3 64bit

Even though this is not a SuSE forum:

don't.

Don't if it is not really nececary.
The official ntfs driver does not support (or halfway supports)
write access on ntfs, because this is dangerous,
as microsoft doesn't give NTFS documentation out for free,
so it's lot of reverse engineering.

You can use the ntfs-3g driver, which supports writing on ntfs,
on your own risk. I guess there are SuSE packages
for it, so search for them or ask SuSE forums.

have fun with linux.

Fuchs
NvFuchs is offline   Reply With Quote
Old 04-08-08, 01:19 PM   #11
mavidako
Registered User
 
Join Date: Apr 2008
Posts: 6
Default Re: 8800GT on openSUSE 10.3 64bit

I have that drivers but he still don't want to copy files to NTFS partitions. Anyway I'll find something. Thanx!
mavidako is offline   Reply With Quote
Old 04-08-08, 01:24 PM   #12
NvFuchs
Registered Fox
 
NvFuchs's Avatar
 
Join Date: Oct 2007
Location: Confoederatio Helvetica
Posts: 530
Default Re: 8800GT on openSUSE 10.3 64bit

Make sure that

a) this driver is used, not ntfs
b) you have write access (gid/uid/umask options)
c) the device is mounted rw

this can be changed in the fstab (/etc/fstab)
if the device is not mounted by an automounter.

Otherwhise you'll need to write udev rules / hal policies,
which is rather difficult for a beginner.

Fuchs
NvFuchs is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:54 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.