Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-06-08, 12:55 PM   #1
jamjag
Registered User
 
Join Date: Apr 2008
Posts: 2
Default OpenSuse 10.3 installatin failed

Hello all!

I recently bought a NVIDIA Geforce 7300 GT card and would like to use it for Opensuse 10.3. I found a driver at NVIDIA.com and tried to follow the "Nvidia Installer HOWTO for SUSE LINUX users" documentation. Unfortunately I didn't work.

Maybe I provide you some more details. As I have an three year old celeron I used the description for openSUSE 10.3-IA.32 and perfromed the following steps:

1. I added the NVIDA server to the repositories.
2. I selected and installed the x11-video-nvidiaG01 package.

After this I'm not sure how to proceed. In SaX2 I get the information that my card is the "VESA Framebuffer Graphic". I don't know whether I can change anything. Furthermore I started the system in Runlevel mode 3 and tried to start the installer directly but unfortunately the sh command couldn't find the installer file.

Does anyone know what's my fault? I'm quite sure that it shouldn't be a big problem to install the driver.

Thank you in advance for your feedback.

Regards,
jamjag
jamjag is offline   Reply With Quote
Old 04-07-08, 01:37 AM   #2
krokodil
Null Byte Bug Hunter
 
krokodil's Avatar
 
Join Date: Mar 2007
Location: N 49 52'19", E 8 38'17", Germany
Posts: 79
Default Re: OpenSuse 10.3 installatin failed

Quote:
Originally Posted by jamjag
Hello all!

[...deleted...]

1. I added the NVIDA server to the repositories.
2. I selected and installed the x11-video-nvidiaG01 package.
I'm not shure what you did here. Normally, I go the the Nvidia website, download a driver, enter level 3, run the installer script, test, reenter level 5 and am done.

Quote:
Originally Posted by jamjag
After this I'm not sure how to proceed. In SaX2 I get the information that my card is the "VESA Framebuffer Graphic". I don't know whether I can change anything. Furthermore I started the system in Runlevel mode 3 and tried to start the installer directly but unfortunately the sh command couldn't find the installer file.

Does anyone know what's my fault? I'm quite sure that it shouldn't be a big problem to install the driver.

Thank you in advance for your feedback.

Regards,
jamjag
VESA graphics basically means the driver isn't installed.

There are several ways to invoke the execution of a shell script. Did you set the downloaded shar to -x? In my opinion this is the easiest way to execute it.
In the latest driver releases nvidia-xconfig does a much better job of configuring driver and X-server than it did before so no need to fiddle with SaX anymore (it might still be useful one way or another ).
__________________

GA-EX38-DS5 | Core 2 Q9450 | AC Freezer 7 Pro | 2x KVR800D2E5/2G | ZOTAC GeForce 8800GT AMP!
4x HDP725032GLA360 RAID-10 | Enermax PRO82+ 525W | CoolerMaster RC-590

GA-EX58-UD5 | Core i 7-940 | CoolerMaster V8 | KHX12800D3LLK3/6GX | ZOTAC GeForce GTX 280
4x WD10EADS RAID-10 | Enermax REVOLUTION85+ 850W | CoolerMaster RC-600

ZOTAC GeForce 9300-ITX WiFi | Celeron E3200 | 2x KVR800D2E5/2G | SSDSA2MH160G2
WD10EADS | GGC-H20L | Enermax PRO82+ 385W | Lian Li PC-Q07B | Boy this box is cramped
krokodil is offline   Reply With Quote
Old 04-07-08, 03:18 AM   #3
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default Re: OpenSuse 10.3 installatin failed

The procedure with installing x11-video-nvidiaG01 is correct for opensuse 10.3
You may need to configure the X server using nvidia-xconfig or by editing the file /etc/X11/xorg.conf manually.
pe1chl is offline   Reply With Quote
Old 04-07-08, 01:15 PM   #4
jamjag
Registered User
 
Join Date: Apr 2008
Posts: 2
Default Re: OpenSuse 10.3 installatin failed

Thanks for your feedback.



If the major problem is the X server configuration, can I find somewhere a "eay to use" description how I can handle it? To be honest, I haven't changed a xorg.conf file manually up to know.

PS: I have already executed the nvidia-xconfig, but the result was that the X server couldn't be started anymore. After that I executed sax2 which (well, this is at least my understanding) reinstalled the "Vesa driver".
jamjag is offline   Reply With Quote
Old 04-10-08, 08:03 PM   #5
IkBenDeMan
Registered User
 
Join Date: Apr 2008
Posts: 5
Default Re: OpenSuse 10.3 installatin failed

Read the README and Installation README where you download the NVidia driver on it's website... or actually I'll just copy paste...

Quote:
If you have a working X config file for a different driver (such as the “nv” or “vesa” driver), then simply edit the file as follows.

Remove the line:

Driver "nv"
(or Driver "vesa")
(or Driver "fbdev")

and replace it with the line:

Driver "nvidia"

Remove the following lines:

Load "dri"
Load "GLCore"

In the Module section of the file, add the line (if it does not already exist):

Load "glx"

If the X config file does not have a Module section, you can safely skip the last step if the X server installed on your system is an X.Org X server or an XFree86 X release version 4.4.0 or greater. If you are using an older XFree86 X server, add the following to your X config file:

Section "Module"
Load "extmod"
Load "dbe"
Load "type1"
Load "freetype"
Load "glx"
EndSection
If you follow these instructions, everything should work. I have SuSE too and your Xconfig file should be set to "nv" after installation, once you install the new drivers, you just do this. I also add
Quote:
Option "NoLogo" "false"
under the driver section, because I like the pretty NVidia splash screen
IkBenDeMan is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Regression with 295.33 and GeForce GT 240 maro NVIDIA Linux 16 06-29-12 06:47 PM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM
kernel: NV0: isr request failed 0xfffffff0 Shark NVIDIA Linux 13 09-11-02 11:01 AM

All times are GMT -5. The time now is 08:25 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.